Bug 568940 - [abrt] crash in Window::~Window (on closing file recovery dialog?)
Summary: [abrt] crash in Window::~Window (on closing file recovery dialog?)
Keywords:
Status: CLOSED DUPLICATE of bug 607286
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0a40b160819282a0f7964b8653e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-27 01:31 UTC by Rob
Modified: 2010-06-23 19:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-28 18:02:19 UTC


Attachments (Terms of Use)
File: backtrace (39.84 KB, text/plain)
2010-02-27 01:31 UTC, Rob
no flags Details

Description Rob 2010-02-27 01:31:55 UTC
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/simpress.bin -impress file:///media/68D4-F9FC/Learnin/2618/ShareOut/Revised%202618%20PPT%20Slides/CppHTP5e_13_revised.ppt
comment: None.
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/simpress.bin
kernel: 2.6.31.12-174.2.22.fc12.i686.PAE
package: openoffice.org-impress-1:3.1.1-19.26.fc12
rating: 4
reason: Process /usr/lib/openoffice.org3/program/simpress.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Open up MS Powerpoint file from USB drive.

Comment 1 Rob 2010-02-27 01:31:57 UTC
Created attachment 396709 [details]
File: backtrace

Comment 2 David Tardon 2010-02-27 07:50:11 UTC
The application crashed just after you clicked away some dialog. What dialog it was and what button (or key) did you click (press)? Anyway, my guess, based on the stack, is it was file recovery dialog, so it could be another bug with the recovering process. Could you attach your configuration directory here (in hope the recovery information is still here)? I.e. run

tar -cjf /tmp/config.tar.bz2 ~/.openoffice.org

and attach /tmp/config.tar.bz2 here.

Comment 3 Rob 2010-02-27 20:50:45 UTC
Looks like I got a bit impatient. I haven't used Bugzilla before so I wasn't clear on much response I would get. Thanks for getting back to me.

I've removed Openoffice 3.1 and am now installing the latest from OpenOffice.org.

I'll be sure to stay closer to the BZ process next time.

Is there something else I can do for this report?

Comment 4 Caolan McNamara 2010-02-28 18:02:19 UTC
I suspect the config backend got confused about something. This backend is getting replaced in 3.3 so hopefully the occurrences of these hard-to-reproduce config bugs will reduce. If you can reproduce this then let me know.

Comment 5 Rob 2010-02-28 23:31:52 UTC
Okay, no problem. This bug happened in the Fedora 12 distro but I'm too busy now not to have a working OpenOffice so I installed 3.2 from openoffice.org.

I'll try to reproduce the error ASAP.

Thanks a mil.

Comment 6 Caolan McNamara 2010-06-23 19:19:59 UTC

*** This bug has been marked as a duplicate of bug 607286 ***


Note You need to log in before you can comment on or make changes to this bug.