Bug 568950 - Publican RPM has unmet dependency in Perl IO::String module
Publican RPM has unmet dependency in Perl IO::String module
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
: Reopened
: 572019 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 22:58 EST by Jared Smith
Modified: 2010-11-23 23:20 EST (History)
6 users (show)

See Also:
Fixed In Version: publican-1.6.1-0.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 20:46:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2010-02-26 22:58:03 EST
Description of problem:

Upgrading publican to 1.50 gives me the following error:

LibXSLT: error coming back from perl-dispatcher in pm file. Can't locate object method "new" via package "IO::String" at /usr/lib/perl5/vendor_perl/5.10.0/Publican/Builder.pm line 1165.

 at /usr/lib/perl5/vendor_perl/5.10.0/Publican/Builder.pm line 744

If I manually install the perl-IO-String package (which wasn't needed before), publican once again builds documents for me.  The IO::String module should probably be listed in the Publican SPEC file.

Version-Release number of selected component (if applicable):

publican-1.5-0.fc12.noarch

How reproducible:

always

Steps to Reproduce:
1. Upgrade from publican 1.4 to publican 1.5
2. Try to build PDF output of a document
3. Note the error
4. Install perl-IO-String package
5. Attempt to build the PDF output again
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Fearn 2010-02-26 23:22:06 EST
Curses! This was added to fix the call out duplicate text bug ... Rudi we need to get a test book so we can get better test coverage, that would have detected this error at build time.

<mutter>
Comment 2 Jared Smith 2010-02-26 23:43:28 EST
Sorry to cause you to mutter and curse... I was happy to see that the callout duplicate text bug was fixed, then surprised when some of my footnotes went missing.  I didn't see the two as being related, but now that you mention it, they very likely are related.

I'll go back through my documents and look for any other anomolies I might have missed.  

I know it's probably a thankless job, but I really appreciate all the work you put into Publican -- it's really is starting to shine!
Comment 3 Jeff Fearn 2010-02-26 23:50:49 EST
FWIW I was muttering at myself for missing the new Requires ... it was either that or blush O_O
Comment 4 Fedora Update System 2010-02-28 23:13:54 EST
publican-1.6-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6-0.fc12
Comment 5 Fedora Update System 2010-02-28 23:14:03 EST
publican-1.6-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6-0.fc13
Comment 6 Fedora Update System 2010-02-28 23:14:13 EST
publican-1.6-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.6-0.fc11
Comment 7 Fedora Update System 2010-03-01 20:03:40 EST
publican-1.6-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-03-01 20:04:35 EST
publican-1.6-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-03-01 20:06:15 EST
publican-1.6-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Jeff Fearn 2010-03-22 01:56:33 EDT
*** Bug 572019 has been marked as a duplicate of this bug. ***
Comment 11 Jeff Fearn 2010-03-22 01:57:32 EDT
No, why would deps in Build.PL be picked up automatically :(
Comment 12 Ruediger Landmann 2010-03-22 02:46:28 EDT
verified for 1.6.1
Comment 13 Fedora Update System 2010-03-23 20:12:58 EDT
publican-1.6.1-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc12
Comment 14 Fedora Update System 2010-03-23 20:13:33 EDT
publican-1.6.1-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc11
Comment 15 Fedora Update System 2010-03-23 20:14:03 EDT
publican-1.6.1-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.6.1-0.fc13
Comment 16 Fedora Update System 2010-03-23 20:46:17 EDT
publican-1.6.1-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-03-24 19:35:52 EDT
publican-1.6.1-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-03-24 19:37:33 EDT
publican-1.6.1-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.