This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 572019 - perl-IO-String dependency missing from Publican install
perl-IO-String dependency missing from Publican install
Status: CLOSED DUPLICATE of bug 568950
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 20:36 EST by Richard Wilding
Modified: 2010-11-23 23:17 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 01:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Wilding 2010-03-09 20:36:24 EST
Description of problem:
Publican does not install the dependency perl-IO-String.
Without it installed the following error can occur during a build:

"LibXSLT: error coming back from perl-dispatcher in pm file. Can't locate object method "new" via package "IO::String" at /usr/lib/perl5/vendor_perl/5.8.8/Publican/Builder.pm line 1165"


Version-Release number of selected component (if applicable):
1.6

Additional info:
The workaround is to install perl-IO-String manually:
yum install perl-IO-String
Comment 2 Jeff Fearn 2010-03-22 01:56:33 EDT

*** This bug has been marked as a duplicate of bug 568950 ***

Note You need to log in before you can comment on or make changes to this bug.