This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 569024 - NetworkManager will not connect to the network
NetworkManager will not connect to the network
Status: CLOSED DUPLICATE of bug 567978
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-27 12:26 EST by Dale Snell
Modified: 2010-08-17 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 12:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The output of nm-tool. (774 bytes, text/plain)
2010-04-14 14:34 EDT, Dale Snell
no flags Details
/var/log/messages (17.40 KB, text/plain)
2010-04-14 14:35 EDT, Dale Snell
no flags Details

  None (edit)
Description Dale Snell 2010-02-27 12:26:07 EST
Description of problem:
NetworkManager will not connect to the network.

Version-Release number of selected component (if applicable):
1:0.7.996-6.git20091021.fc12

How reproducible:


Steps to Reproduce:
1.  Install 1:0.7.996-6.git20091021.fc12
2.  Restart (or reboot)
3.  Log in.
  
Actual results:
The NetworkManager applet shows that the network is disconnected.  Attempting to reconnect will fail.  At this point the network is unavailable.  It can be restored with "service network restart", but NM-applet still shows the network to be down.

Expected results:
The network should be up, and NM-applet should show that.

Additional info:
Once I restarted the network with the  service network restart  command, I was able to do a  yum downgrade NetworkManager\*  and restore normal operation.  Obviously, something in the latest upgrade to NetworkManager went awry.
Comment 1 Jirka Klimes 2010-04-13 06:26:14 EDT
Is it still problem with the latest upgrade?
If so, please include:
1. output of nm-tool
2. /var/log/messages

Thanks.
Comment 2 Dale Snell 2010-04-14 14:33:09 EDT
I upgraded to the latest version in updates-testing, and the problem is still there.  If it helps any, this machine is a Dell Inspiron 9300 laptop.  It has a Broadcom BCM4401-B0 Ethernet NIC (eth0) and an Intel PRO/Wireless 2915ABG [Calexico2] wireless NIC.  The driver for eth0 is b44; the wireless device is shut off in the BIOS since I almost never use it.  I'll upload the output of nm-tool and the relevant portion of /var/log/messages as separate attachments.
Comment 3 Dale Snell 2010-04-14 14:34:17 EDT
Created attachment 406595 [details]
The output of nm-tool.
Comment 4 Dale Snell 2010-04-14 14:35:36 EDT
Created attachment 406596 [details]
/var/log/messages
Comment 5 Jirka Klimes 2010-04-15 10:33:40 EDT
comment #4:
Apr 14 11:12:17 localhost NetworkManager: <info> (eth0): IP6 addrconf timed out or failed.

Your connection has probably IPv6 method set to "Automatic". That's why NM tries
to configure IPv6, but it times out (your network is probably not IPv6-enabled).
So NM marks the connection as invalid even if IPv4 succeeded.

I think it could be regarded as a bug. We may just issue a warning that IPv6 is not available and continue with IPv4 only.

To resolve the issue, open nm-connection-editor:
1. click on "System eth0" connection on "Wired" tab
2. click "Edit..."
3. click "IPv6 Settings" tab
4. change Method from "Automatic" to "Ignore"
5. click Apply

For reference, I think it is the same issue as bugs:
bug 565926  
bug 567978
bug 569192
Comment 6 Dale Snell 2010-04-15 13:19:00 EDT
That fixed it!  As soon as I hit "Apply" the little green lights spun around and then everything was connected.  Thank you!

This sure looks like a repeat of the other bugs you referenced.  My DSL modem/router is IPv4 only, so I've never bothered with IPv6.  Sounds to me like Anaconda set things up correctly during installation, but something in the update changed the settings.  What's really odd is that it only happened on the Dell machine.  My IBM T40 was happy as a clam with NetworkManager.  It never occurred to me that the settings would be different.  Unfortunately I can't check the T40's settings, since its display died just after this mess started.  A couple days ago, though, I bought a 64-bit AMD Sempron desktop system, and it has no trouble.  I just checked its settings for NetworkManager, and lo and behold, IPv6 was set to "Ignore."  Sunspots and gremlins?  :-)
Comment 7 Dan Williams 2010-08-17 12:31:18 EDT
This got fixed in the run-up to F13 and the update was rolled out right after that as well.

*** This bug has been marked as a duplicate of bug 567978 ***

Note You need to log in before you can comment on or make changes to this bug.