Bug 569196 - Printer qt Segmentation fault
Printer qt Segmentation fault
Status: CLOSED DUPLICATE of bug 566304
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-28 12:11 EST by Andy Lawrence
Modified: 2010-02-28 12:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-28 12:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Lawrence 2010-02-28 12:11:30 EST
Description of problem:
Ran into this debugging gambas, I believe it was caused by the qt updates a couple days ago.

Version-Release number of selected component (if applicable):
qt3-devel-3.3.8b-28.fc12.x86_64
qt-sqlite-4.6.2-1.fc12.x86_64
qt-4.6.2-1.fc12.i686
qt3-3.3.8b-28.fc12.x86_64
polkit-qt-0.95.1-3.fc12.x86_64
avahi-qt3-0.6.25-5.fc12.x86_64
qt-sqlite-4.6.2-1.fc12.i686
qtoctave-0.8.2-2.fc12.x86_64
qt-x11-4.6.2-1.fc12.x86_64
qt-debuginfo-4.6.2-1.fc12.x86_64
qt-devel-4.6.2-1.fc12.i686
qt-devel-4.6.2-1.fc12.x86_64
qt-4.6.2-1.fc12.x86_64
qwtplot3d-qt4-0.2.7-9.fc12.x86_64
polkit-qt-debuginfo-0.95.1-3.fc12.x86_64
qt-x11-4.6.2-1.fc12.i686
qt-qsa-1.1.5-7.fc12.x86_64
qt-mysql-4.6.2-1.fc12.x86_64


Fedora 12x64, all updates.

How reproducible:
Every time if I have a default printer setup.  If I remove the default printer the issue is gone.

Steps to Reproduce:
I've only been able to reproduce with from within gambas, but I don't believe it is a gambas bug.  Not sure what other information to provide.  This was not a problem until the qt updates from 2-3 days ago.
  
Actual results:
seg fault

Expected results:


Additional info:

Program received signal SIGSEGV, Segmentation fault. 
0x0000003b2c124cd1 in QPrinter::QPrinter (this=<value optimized out>, mode=<value optimized out>) 
    at painting/qprinter.cpp:658 
658	    	if( cups.currentPPD()->color_device ) 
(gdb) bt 
#0  0x0000003b2c124cd1 in QPrinter::QPrinter (this=<value optimized out>, mode=<value optimized out>) 
    at painting/qprinter.cpp:658 
#1  0x00007ffff7978a67 in Printer_new (_object=0xe19e70, _param=<value optimized out>) 
    at cprinter.cpp:168 
#2  0x0000000000407519 in EXEC_call_native (exec=0xe4fbb8, object=0x7fffffffc420, type=0, 
    param=<value optimized out>) at gbx_exec.c:979 
#3  0x000000000040813f in EXEC_native () at gbx_exec.c:1180 
#4  0x00000000004091c8 in EXEC_special (special=<value optimized out>, class=<value optimized out>, 
    object=<value optimized out>, nparam=0, drop=<value optimized out>) at gbx_exec.c:1485 
#5  0x00000000004094d4 in EXEC_special_inheritance (special=0, class=0x66dc60, object=0xe19e70, nparam= 
    0, drop=1 '\001') at gbx_exec.c:1627 
#6  0x0000000000409bde in EXEC_new () at gbx_exec.c:1837 
#7  0x0000000000429215 in EXEC_loop () at gbx_exec_loop.c:820 
#8  0x0000000000408c96 in EXEC_function_loop () at gbx_exec.c:795 
#9  0x0000000000409050 in EXEC_function_real () at gbx_exec.c:782 
#10 0x00000000004095b5 in EXEC_special_inheritance (special=0, class=0x93b100, object=0xe098e0, 
    nparam=<value optimized out>, drop=<value optimized out>) at gbx_exec.c:1673 
#11 0x000000000041f0c2 in OBJECT_create (object=<value optimized out>, class=<value optimized out>, 
    name=<value optimized out>, parent=<value optimized out>, nparam=<value optimized out>) 
    at gbx_object.c:369 
#12 0x000000000040bca3 in CLASS_auto_create (class=0x93b100, nparam=0) at gbx_class.c:1077 
#13 0x00007ffff795151d in CFORM_load (_object=<value optimized out>, _param=<value optimized out>) 
    at CWindow.cpp:475 
#14 0x0000000000407519 in EXEC_call_native (exec=0xe4fbb8, object=0x7fffffffc420, type=0, 
    param=<value optimized out>) at gbx_exec.c:979 
#15 0x000000000040813f in EXEC_native () at gbx_exec.c:1180 
#16 0x0000000000429201 in EXEC_loop () at gbx_exec_loop.c:975 
#17 0x0000000000408c96 in EXEC_function_loop () at gbx_exec.c:795 
---Type <return> to continue, or q <return> to quit--- 
#18 0x0000000000409050 in EXEC_function_real () at gbx_exec.c:782 
#19 0x00000000004091e3 in EXEC_special (special=<value optimized out>, class=<value optimized out>, 
    object=<value optimized out>, nparam=0, drop=<value optimized out>) at gbx_exec.c:1493 
#20 0x00000000004096e2 in EXEC_special_inheritance (special=0, class=0x914980, object=0x9a5cc0, 
    nparam=<value optimized out>, drop=<value optimized out>) at gbx_exec.c:1720 
#21 0x000000000041f0c2 in OBJECT_create (object=<value optimized out>, class=<value optimized out>, 
    name=<value optimized out>, parent=<value optimized out>, nparam=<value optimized out>) 
    at gbx_object.c:369 
#22 0x000000000040bca3 in CLASS_auto_create (class=0x914980, nparam=0) at gbx_class.c:1077 
#23 0x00007ffff795151d in CFORM_load (_object=<value optimized out>, _param=<value optimized out>) 
    at CWindow.cpp:475 
#24 0x0000000000407519 in EXEC_call_native (exec=0xe4fbb8, object=0x7fffffffc420, type=0, 
    param=<value optimized out>) at gbx_exec.c:979 
#25 0x000000000040813f in EXEC_native () at gbx_exec.c:1180 
#26 0x0000000000429201 in EXEC_loop () at gbx_exec_loop.c:975 
#27 0x0000000000408c96 in EXEC_function_loop () at gbx_exec.c:795 
#28 0x0000000000409050 in EXEC_function_real () at gbx_exec.c:782 
#29 0x000000000041e218 in main (argc=1, argv=<value optimized out>) at gbx.c:356 
(gdb)
Comment 1 Kevin Kofler 2010-02-28 12:43:07 EST

*** This bug has been marked as a duplicate of bug 566304 ***

Note You need to log in before you can comment on or make changes to this bug.