This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 566304 - Qt and KDE applications crash when trying to print when a CUPS printer has no PPD assigned
Qt and KDE applications crash when trying to print when a CUPS printer has no...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 569189 569196 (view as bug list)
Depends On:
Blocks: qt46
  Show dependency treegraph
 
Reported: 2010-02-17 15:49 EST by nucleo
Modified: 2010-03-01 20:07 EST (History)
6 users (show)

See Also:
Fixed In Version: qt-4.6.2-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-01 20:07:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Okular crash backtrace (14.87 KB, text/plain)
2010-02-17 15:49 EST, nucleo
no flags Details

  None (edit)
Description nucleo 2010-02-17 15:49:34 EST
Created attachment 394819 [details]
Okular crash backtrace

Description of problem:
Okular, konqueror, opera are crashes when I press Ctrl+P.


Version-Release number of selected component (if applicable):
qt-4.6.1-3.fc11.i586.rpm

How reproducible:
Every time.

Steps to Reproduce:
1. Open for document in okular.
2. Press Ctrl+P.
  
Actual results:
Crash.

Expected results:
No crash.

Additional info:
Comment 1 nucleo 2010-02-17 16:08:55 EST
I have two local printers.
First and default is virtual cups-pdf and second is real printer.
Comment 2 Kevin Kofler 2010-02-27 21:37:24 EST
The offending line is added by our qt-cups-1.patch (in 2 places, they probably both need the same fix):
+    	// set default color
+    	if( cups->currentPPD()->color_device )
+    	  options.color->setChecked(true);
+    	else
+    	  options.grayscale->setChecked(true);
and later:
+    	// set default color
+    	if( cups.currentPPD()->color_device )
+	  setColorMode(Color);
+    	else
+	  setColorMode(GrayScale);

They should be changed to:
   	if ( cups->currentPPD() )
   	  {
   	    // set default color
   	    if( cups->currentPPD()->color_device )
   	      options.color->setChecked(true);
   	    else
   	      options.grayscale->setChecked(true);
   	  }
and:
   	if ( cups.currentPPD() )
   	  {
   	    // set default color
   	    if( cups.currentPPD()->color_device )
   	      setColorMode(Color);
   	    else
   	      setColorMode(GrayScale);
   	  }
(I matched the coding style of the surrounding code.)

I'm going to try changing this.
Comment 3 Kevin Kofler 2010-02-27 23:39:26 EST
This should be fixed in 4.6.2-3 which I just committed to devel. I'm going to issue updates.
Comment 4 Kevin Kofler 2010-02-28 12:43:07 EST
*** Bug 569196 has been marked as a duplicate of this bug. ***
Comment 6 nucleo 2010-02-28 13:16:05 EST
This build http://koji.fedoraproject.org/koji/buildinfo?buildID=159091 fixes bug.
Comment 7 Fedora Update System 2010-02-28 13:25:35 EST
qt-4.6.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.2-3.fc13
Comment 8 Fedora Update System 2010-02-28 13:25:59 EST
qt-4.6.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.2-3.fc12
Comment 9 Fedora Update System 2010-02-28 13:26:23 EST
qt-4.6.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.6.2-3.fc11
Comment 10 Ralf Ertzinger 2010-02-28 13:56:58 EST
*** Bug 569189 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-02-28 20:37:56 EST
qt-4.6.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-03-01 19:51:20 EST
qt-4.6.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-03-01 20:07:52 EST
qt-4.6.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.