Bug 569357 - DeviceError: ('cannot replace active format', 'xvda4')
Summary: DeviceError: ('cannot replace active format', 'xvda4')
Keywords:
Status: CLOSED DUPLICATE of bug 563526
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:a3a100ca724e71104...
: 569359 573909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-01 12:19 UTC by Alexander Todorov
Modified: 2010-05-16 12:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 14:28:47 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (118.79 KB, text/plain)
2010-03-01 12:19 UTC, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (207.89 KB, text/plain)
2010-03-04 09:36 UTC, Pavel Holica
no flags Details
Attached traceback automatically from anaconda. (106.41 KB, text/plain)
2010-03-19 11:24 UTC, Thomas Woerner
no flags Details
Attached traceback automatically from anaconda. (176.76 KB, text/plain)
2010-04-30 20:01 UTC, Phillip Lahman
no flags Details
Attached traceback automatically from anaconda. (182.17 KB, text/plain)
2010-05-16 12:59 UTC, Vinny
no flags Details

Description Alexander Todorov 2010-03-01 12:19:36 UTC
The following was filed automatically by anaconda:
anaconda 13.21.16 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 697, in _setFormat
    raise DeviceError("cannot replace active format", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 1171, in _setFormat
    StorageDevice._setFormat(self, format)
  File "/usr/lib/anaconda/storage/devices.py", line 705, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 307, in __init__
    self.device.format = None
  File "/usr/lib/anaconda/storage/__init__.py", line 782, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/anaconda/partIntfHelpers.py", line 143, in doDeleteDevice
    storage.destroyDevice(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1290, in deleteCB
    device):
DeviceError: ('cannot replace active format', 'xvda4')

Comment 1 Alexander Todorov 2010-03-01 12:19:40 UTC
Created attachment 397051 [details]
Attached traceback automatically from anaconda.

Comment 3 Alexander Todorov 2010-03-01 12:25:24 UTC
After I've hit bug #563523 I've started another install and tried to delete the previously present partitions. When deleting the extended partition (I think) I hit this traceback.

Comment 5 RHEL Product and Program Management 2010-03-01 12:40:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Alexander Todorov 2010-03-01 12:52:38 UTC
*** Bug 569359 has been marked as a duplicate of this bug. ***

Comment 7 Hans de Goede 2010-03-01 14:28:47 UTC

*** This bug has been marked as a duplicate of bug 563526 ***

Comment 8 Pavel Holica 2010-03-04 09:36:18 UTC
Created attachment 397768 [details]
Attached traceback automatically from anaconda.

Comment 9 Chris Lumens 2010-03-16 14:21:50 UTC
*** Bug 573909 has been marked as a duplicate of this bug. ***

Comment 10 Thomas Woerner 2010-03-19 11:24:09 UTC
Created attachment 401226 [details]
Attached traceback automatically from anaconda.

Comment 11 Phillip Lahman 2010-04-30 20:01:47 UTC
Created attachment 410589 [details]
Attached traceback automatically from anaconda.

Comment 12 Vinny 2010-05-16 12:59:24 UTC
Created attachment 414347 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.