Bug 56947 - Broken man-page
Broken man-page
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Raw Hide
Classification: Retired
Component: groff (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 17:31 EST by Enrico Scholz
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-04 12:26:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-11-30 17:31:08 EST
Description of Problem:

RPM compresses mans/mpi.share but mpi.7 relies on the uncompressed version:

| $ rpm -ql lam | grep mans
| /usr/share/man/mans/mpi.share.gz
|
| $ zcat /usr/share/man/man7/mpi.7.gz
| [...]
| .so mans/mpi.share

Therefore, calling 'man mpi' fails and gives no senseful output:

---------
$ man mpi | cat
<standard input>:6: realpath on `mans/mpi.share' failed: No such file or
directory
MPI(7)                     LAM OVERVIEW                    MPI(7)



NAME
       MPI, mpi - LAM MPI implementation

DESCRIPTION
LAM 6.5.6                 November, 2001                   MPI(7)
$
---------


Version-Release number of selected component (if applicable):

lam-6.5.6-1.ssh
man-1.5j-1
Comment 1 Trond Eivind Glomsrxd 2001-12-04 12:26:14 EST
That's a groff bug, it should handle that.
Comment 2 Trond Eivind Glomsrxd 2002-05-14 16:55:23 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.