Bug 569542 - qt: FTBFS on sparc64 since 4.5.3-12
qt: FTBFS on sparc64 since 4.5.3-12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
sparc64 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 11:59 EST by Rex Dieter
Modified: 2010-03-22 22:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: qt-4.6.2-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 22:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-03-01 11:59:57 EST
looks like src/corelib/arch/sparc/arch.pri contains:

*-64 {
    SOURCES += $$QT_ARCH_CPP/qatomic64.s
}
else {
    SOURCES += $$QT_ARCH_CPP/qatomic32.s \
               $$QT_ARCH_CPP/qatomic_sparc.cpp
}

and since we switched to
platform linux-g++
everywhere (see bug #478481), this breaks.
Comment 1 Rex Dieter 2010-03-01 12:08:31 EST
looks like this same "trick" is used for ppc64 and mips64 too.
Comment 2 Fedora Update System 2010-03-14 20:23:18 EDT
qt-4.6.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc12
Comment 3 Fedora Update System 2010-03-14 20:25:20 EDT
qt-4.6.2-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc11
Comment 4 Fedora Update System 2010-03-15 20:39:35 EDT
qt-4.6.2-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-7.fc12
Comment 5 Fedora Update System 2010-03-18 09:38:13 EDT
qt-4.6.2-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.2-8.fc13
Comment 6 Fedora Update System 2010-03-22 22:09:46 EDT
qt-4.6.2-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-03-22 22:23:53 EDT
qt-4.6.2-8.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-03-22 22:24:07 EDT
qt-4.6.2-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.