Bug 569969 - "No system tray detected on this system"
"No system tray detected on this system"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:a503a7e6028a044ce55d6a5e5c8...
: Reopened
: 579277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-02 15:37 EST by Jim Gribbin
Modified: 2010-07-26 22:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: hplip-3.10.5-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 22:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (20.31 KB, text/plain)
2010-03-02 15:37 EST, Jim Gribbin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 335662 None None None Never

  None (edit)
Description Jim Gribbin 2010-03-02 15:37:09 EST
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: python /usr/bin/hp-systray -x
comment: I set the HP-Systray to start automatically on login using the "Startup Applications Preferences" tool provided by Fedora for the Gnome Desktop.
component: hplip
executable: /usr/bin/python
kernel: 2.6.31.12-174.2.22.fc12.i686.PAE
package: hplip-gui-3.9.8-28.fc12
rating: 3
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Set HP-Systray to start automaticaly on login
2. log in to the Gnome Desktop
3. hp-lip-gui crashes w/ an error about there not being a tray to load into
Comment 1 Jim Gribbin 2010-03-02 15:37:11 EST
Created attachment 397409 [details]
File: backtrace
Comment 2 Jiri Popelka 2010-03-03 04:35:18 EST

*** This bug has been marked as a duplicate of bug 543286 ***
Comment 3 Tim Waugh 2010-03-26 07:02:59 EDT
Jim: please copy exactly what the error message says into this bug report.
Comment 4 Jim Gribbin 2010-03-26 17:10:46 EDT
In a message box that pops up, I have:

No system tray detected on this system.
Unable to start, exiting.

(copied and pasted)

I did notice in checking this that if I go into Gnome Start-up Applications tool, activate this for automatically starting, then log out and back in, I do not get the error.

If I shut the box completely down and re-start it with this activated as a start-up application, I get the message.

I did not notice this part of what's going on previously. Not certain it makes any difference anyway. Just something I noticed.
Comment 5 Tim Waugh 2010-03-29 11:50:55 EDT
This is coming from ui4/systemtray.py.  It's talking about the 'notification area' on the panel.

It's already waited for 10s to see if a system tray becomes available, and it still hasn't.  My guess is it just needs to wait longer until the notification area applet starts up.
Comment 6 Jiri Popelka 2010-04-06 05:30:03 EDT
*** Bug 579277 has been marked as a duplicate of this bug. ***
Comment 8 Jiri Popelka 2010-05-11 10:17:28 EDT
Jim, can you try this build of hplip ?
http://koji.fedoraproject.org/koji/buildinfo?buildID=172930

Download the appropriate rpms into empty directory and install them as root:
yum localinstall --nogpgcheck *.rpm
Comment 9 Jim Gribbin 2010-05-11 18:06:50 EDT
It works!! :)

Up and going from a restart of the box. No error messages, no flashing abrt. Everything appears normal.

Thanks

Jim G
Comment 10 Jim Gribbin 2010-05-12 16:49:18 EDT
Nuts. It's still doing it. Occasionally anyway.

I powered (shut down) my laptop down when I went home yesterday. This morning when I booted up, I had the message back, but no crash notification from abrt.

I powered the computer completely back down and and brought it up a second time. hplip started without issue.
Comment 11 Tim Waugh 2010-05-13 07:43:47 EDT
Jim, how long does it take your desktop to start up?  Can you time it?
Comment 13 Jim Gribbin 2010-05-13 17:59:46 EDT
Hope you just meant w/ a stopwatch. I don't know how to write a script for that.

It ooks like 1 min 23 sec from the moment I click the login button after keying 
in my password to where the hplip systray icon shows in the system tray.

When I first booted the box this AM after it was powered off all night, I received the error. When I powered down and brought it back up just now to time it, it worked fine.

I guess the slight difference it makes in having everything warmed up is affecting the timing just enough to make it work?
Comment 14 Fedora Update System 2010-05-17 11:33:09 EDT
hplip-3.10.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/hplip-3.10.5-1.fc13
Comment 15 Fedora Update System 2010-05-17 11:35:31 EDT
hplip-3.10.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hplip-3.10.5-1.fc12
Comment 16 Fedora Update System 2010-05-18 17:51:02 EDT
hplip-3.10.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/hplip-3.10.5-1.fc12
Comment 17 Fedora Update System 2010-07-01 14:50:10 EDT
hplip-3.10.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2010-07-26 22:44:08 EDT
hplip-3.10.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.