This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 543286 - Fatal error in "XFreeColormap" in /usr/bin/hp-systray
Fatal error in "XFreeColormap" in /usr/bin/hp-systray
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:874bc1a81c867a472097956f599...
: Patch
: 542148 543317 543960 544898 545580 548764 550867 554238 558882 559454 564388 568710 569703 569829 570147 571159 571552 571989 572780 574189 575659 (view as bug list)
Depends On:
Blocks: 559454 576282
  Show dependency treegraph
 
Reported: 2009-12-01 22:57 EST by Michel Angulo
Modified: 2010-04-12 21:56 EDT (History)
42 users (show)

See Also:
Fixed In Version: hplip-3.10.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 576282 (view as bug list)
Environment:
Last Closed: 2010-04-03 00:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (9.97 KB, text/plain)
2009-12-01 22:57 EST, Michel Angulo
no flags Details
0001-Don-t-call-XFreeColormap-with-a-NULL-display.patch (806 bytes, patch)
2010-01-20 11:35 EST, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 486698 None None None Never

  None (edit)
Description Michel Angulo 2009-12-01 22:57:44 EST
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: python /usr/bin/hp-systray
component: python
executable: /usr/bin/python
kernel: 2.6.31.5-127.fc12.i686.PAE
package: python-2.6.2-2.fc12
rating: 3
reason: Process was terminated by signal 11
Comment 1 Michel Angulo 2009-12-01 22:57:46 EST
Created attachment 375312 [details]
File: backtrace
Comment 2 Dave Malcolm 2009-12-02 09:35:33 EST
Thank you for reporting this bug.

How reproducable is this problem?  If you run the program from a terminal, is an error message printed?

What version of hplip-gui do you have installed?

Looking at the backtrace, it looks like the problem occurred in the program's single thread in XFreeColormap

Reassigning component from "python" to "hplip-gui"
Comment 3 Dave Malcolm 2009-12-02 09:36:59 EST
*** Bug 543317 has been marked as a duplicate of this bug. ***
Comment 4 Dave Malcolm 2009-12-03 14:06:25 EST
*** Bug 543960 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2009-12-04 08:35:45 EST
*** Bug 542148 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2009-12-08 11:33:52 EST
*** Bug 544898 has been marked as a duplicate of this bug. ***
Comment 7 Dave Malcolm 2009-12-09 17:22:02 EST
*** Bug 545580 has been marked as a duplicate of this bug. ***
Comment 8 Dave Malcolm 2009-12-18 11:16:47 EST
*** Bug 548764 has been marked as a duplicate of this bug. ***
Comment 9 Dave Malcolm 2010-01-04 13:27:06 EST
*** Bug 550867 has been marked as a duplicate of this bug. ***
Comment 10 Tim Waugh 2010-01-11 07:45:11 EST
*** Bug 554238 has been marked as a duplicate of this bug. ***
Comment 11 Diego 2010-01-16 07:11:50 EST
(In reply to comment #2)
> How reproducable is this problem?

To me it looks like it crashes only when you close the icon in the tray. I'll let you know better.
Comment 12 Diego 2010-01-17 05:37:48 EST
Ok, here are informations you asked.

(In reply to comment #2)
> How reproducable is this problem?

Always: just open hp-systray, right click the system tray icon and click on "Quit".

>  If you run the program from a terminal, is
> an error message printed?

Not much informative, just "Segmentation fault (core dumped)".

$ hp-systray

HP Linux Imaging and Printing System (ver. 3.9.8)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:122: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
Segmentation fault (core dumped)
 
> What version of hplip-gui do you have installed?

Mine is hplip-gui-3.9.8-21.fc12.x86_64
Comment 13 Tim Waugh 2010-01-20 11:34:37 EST
Looks like a qt bug to me.
Comment 14 Tim Waugh 2010-01-20 11:35:36 EST
Created attachment 385716 [details]
0001-Don-t-call-XFreeColormap-with-a-NULL-display.patch

This looks like it should fix it.
Comment 15 Rex Dieter 2010-01-20 11:52:49 EST
Thanks (is that patch really from 2001? :) )
Comment 16 Tim Waugh 2010-01-20 12:08:39 EST
It's not from 2001, it was created using 'git format-patch' which always uses that date in the From header.

Hmm, my local qt build finished and I tested it, but I'm still getting crashes -- I think it's for some other reason now though...
Comment 17 Kevin Kofler 2010-01-20 12:54:33 EST
I think QtGui as a whole doesn't work that great if its display is NULL. ;-)
Comment 18 Tim Waugh 2010-01-21 05:23:30 EST
Indeed.  A few lines further up, just outside the context of that patch, is another test to see if display is NULL.  I figured that meant it was a possibility -- plus see the stack trace from bug #554238:

Program terminated with signal 11, Segmentation fault.
#0  XFreeColormap (dpy=0x0, cmap=69206028) at FreeCmap.c:43
43	    LockDisplay(dpy);

Thread 1 (Thread 6374):
#0  XFreeColormap (dpy=0x0, cmap=69206028) at FreeCmap.c:43
No locals.
#1  0x0417bb1c in QSystemTrayIconSys::~QSystemTrayIconSys (
    this=<value optimized out>, __in_chrg=<value optimized out>)
    at util/qsystemtrayicon_x11.cpp:213
        display = 0x0
[...]
Comment 19 b2062407 2010-01-25 15:15:27 EST
I encounter same problem :

" Core was generated by `python /usr/bin/hp-systray --force-startup'.
Program terminated with signal 11, Segmentation fault.
#0  XFreeColormap (dpy=0x0, cmap=90177548) at FreeCmap.c:43
43	FreeCmap.c: No such file or directory.
	in FreeCmap.c

Thread 1 (Thread 30426):"

architecture: i686
cmdline: python /usr/bin/hp-systray --force-startup
component: hplip
coredump: /var/cache/abrt/ccpp-1264371774-30426/coredump
executable: /usr/bin/python
kernel: 2.6.31.12-174.2.3.fc12.i686
package: hplip-gui-3.9.8-21.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)
Comment 20 Dave Malcolm 2010-01-26 20:10:24 EST
*** Bug 558882 has been marked as a duplicate of this bug. ***
Comment 21 Jiri Popelka 2010-02-22 08:47:49 EST
*** Bug 564388 has been marked as a duplicate of this bug. ***
Comment 22 Dave Malcolm 2010-02-26 19:08:06 EST
*** Bug 568710 has been marked as a duplicate of this bug. ***
Comment 23 Jiri Popelka 2010-03-02 08:13:23 EST
*** Bug 569703 has been marked as a duplicate of this bug. ***
Comment 24 Jiri Popelka 2010-03-02 08:14:11 EST
*** Bug 559454 has been marked as a duplicate of this bug. ***
Comment 25 Dave Malcolm 2010-03-02 17:30:53 EST
*** Bug 569829 has been marked as a duplicate of this bug. ***
Comment 26 Jiri Popelka 2010-03-03 04:35:18 EST
*** Bug 569969 has been marked as a duplicate of this bug. ***
Comment 27 Dave Malcolm 2010-03-03 11:23:07 EST
*** Bug 570147 has been marked as a duplicate of this bug. ***
Comment 28 Dave Malcolm 2010-03-07 22:31:19 EST
*** Bug 571159 has been marked as a duplicate of this bug. ***
Comment 29 Dave Malcolm 2010-03-08 15:30:26 EST
*** Bug 571552 has been marked as a duplicate of this bug. ***
Comment 30 Dave Malcolm 2010-03-09 18:09:56 EST
*** Bug 571989 has been marked as a duplicate of this bug. ***
Comment 31 nakieb 2010-03-12 15:59:03 EST

How to reproduce
-----
1.Open hplip-gui while Printer is not connected
2.In the notification area , right click hplip-applet and choose quit
3.


Comment
-----
This crash happened while trying to reproduce BUG564388 , which also occured with same steps
Comment 32 nakieb 2010-03-12 16:06:57 EST

How to reproduce
-----
Comment 33 nakieb 2010-03-12 16:07:52 EST

How to reproduce
-----
Comment 34 Dave Malcolm 2010-03-18 16:43:16 EDT
*** Bug 574189 has been marked as a duplicate of this bug. ***
Comment 35 Dave Malcolm 2010-03-18 21:17:42 EDT
*** Bug 572780 has been marked as a duplicate of this bug. ***
Comment 36 Ken Dubrick 2010-03-19 13:24:03 EDT

How to reproduce
-----
1.Don't know...I wasn't printing or using anything to do with hplips
2.
3.


Comment
-----
HP Systray was active not using printer at all
Comment 37 Hector 2010-03-19 15:25:36 EDT

Comment
-----
It crash at startup
Comment 38 hlovdal 2010-03-20 07:38:33 EDT

How to reproduce
-----
1. Right click the systray icon and select Quit.
2.
3.


Comment
-----
I was just quitting the application. I had updated several packages with yumex before that (including several kde libraries, the crash might be related to that?).
Comment 39 Ken Dubrick 2010-03-21 10:08:30 EDT

How to reproduce
-----
1.Right click and Quit
2.
3.


Comment
-----
I just finished getting to the desktop when I exited the HP Print manager
Comment 40 Jiri Popelka 2010-03-23 04:17:40 EDT
*** Bug 575659 has been marked as a duplicate of this bug. ***
Comment 41 Ken Dubrick 2010-03-23 11:15:49 EDT

How to reproduce
-----
1.Right click - Quit
2.
3.


Comment
-----
I had just turned on my computer and being as the printer is not connected right now I quit the HP manager in the ystem Tray.
Comment 42 Ngo Than 2010-03-23 12:18:39 EDT
it seems the explicit deleting objects is needed after self.quit. I made a patch to fix the crash in hp-systray. It works fine for me

diff -up hplip-3.9.8/ui4/systemtray.py.than hplip-3.9.8/ui4/systemtray.py
--- hplip-3.9.8/ui4/systemtray.py.than  2010-03-23 17:10:04.000000000 +0100
+++ hplip-3.9.8/ui4/systemtray.py       2010-03-23 17:11:32.000000000 +0100
@@ -489,6 +489,7 @@ class SystemTrayApp(QApplication):
         log.debug("Exiting")
         self.sendMessage('', '', EVENT_SYSTEMTRAY_EXIT)
         self.quit()
+        del self.tray_icon
 
 
     def toolboxTriggered(self):
Comment 43 Ngo Than 2010-03-23 12:21:38 EDT
reassign to correct component.
Comment 45 Tim Waugh 2010-03-23 12:40:45 EDT
Thanks!  Reported upstream.
Comment 46 Fedora Update System 2010-03-23 13:29:41 EDT
hplip-3.10.2-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/hplip-3.10.2-5.fc13
Comment 47 Fedora Update System 2010-03-23 13:35:35 EDT
hplip-3.10.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/hplip-3.10.2-2.fc12
Comment 48 Fedora Update System 2010-03-23 13:59:24 EDT
hplip-3.10.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/hplip-3.10.2-1.fc11
Comment 49 Fedora Update System 2010-03-23 20:45:12 EDT
hplip-3.10.2-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/hplip-3.10.2-5.fc13
Comment 50 Fedora Update System 2010-03-24 19:33:37 EDT
hplip-3.10.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/hplip-3.10.2-1.fc11
Comment 51 Fedora Update System 2010-03-24 19:39:13 EDT
hplip-3.10.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/hplip-3.10.2-2.fc12
Comment 52 nakieb 2010-03-25 18:25:33 EDT
(In reply to comment #51)
> hplip-3.10.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If
> problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide
> feedback for this update here:
> http://admin.fedoraproject.org/updates/hplip-3.10.2-2.fc12    

this update works for me and solve this bug , thanks .
Comment 53 Mircea Sava 2010-03-26 06:46:54 EDT

How to reproduce
-----
1.Don't know
2.
3.


Comment
-----
It appeared immediately after login
Comment 54 Michael Norred 2010-03-31 19:56:43 EDT

How to reproduce
-----
1.Dont know
2.
3.
Comment 55 joe_rocket 2010-04-01 10:18:41 EDT

How to reproduce
-----
1. Sorry, I don't know how this occurred 
2.
3.


Comment
-----
I only noticed the issue after bootup.
Comment 56 Mircea Sava 2010-04-01 10:30:56 EDT

How to reproduce
-----
1. 
2.
3.


Comment
-----
It happends sometimes on startup when it loads the HP icon in the system tray.
Comment 57 Fedora Update System 2010-04-03 00:36:42 EDT
hplip-3.10.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 58 Fedora Update System 2010-04-03 00:43:02 EDT
hplip-3.10.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 59 Fedora Update System 2010-04-12 21:56:59 EDT
hplip-3.10.2-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.