Bug 57012 - LANG=ja_JP.eucJP gkrellm default font
Summary: LANG=ja_JP.eucJP gkrellm default font
Status: CLOSED DUPLICATE of bug 107696
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gkrellm   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: oxildntm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-03 07:27 UTC by Jens Petersen
Modified: 2006-02-21 18:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch to detect multibyte locale. (10.29 KB, patch)
2002-08-28 14:24 UTC, Nakai
no flags Details | Diff

Description Jens Petersen 2001-12-03 07:27:36 UTC
Description of Problem:
gkrellm when started in (default) Japanese locale doesn't shows "mojibake"
instead of Japanese in intranslated fields.

Version-Release number of selected component (if applicable):
gkrellm-1.2.4-2

How Reproducible:
always

Steps to Reproduce:
1. LANG=ja_JP.eucJP gkrellm

Actual Results:
As in description.

Expected Results:
Should display Japanese text correctly by default when started in a
Japanese locale.

Additional Information:
Under the config UI, going to Theme -> Fonts
and choosing "Load fonts as fontsets" and "Use alternative fonts..." and
using something like "-*-fixed-medium-r-normal-*-*-*-*-*-*-*-*-" gives
Japanese output (albeit not in a very nice Japanese font).

Comment 1 Karsten Hopp 2002-06-24 09:42:52 UTC
Seems top work with the latest from Rawhide (as far as I can tell)

Comment 2 Jens Petersen 2002-07-08 10:18:11 UTC
Perhaps, my report wasn't clear....
The text in question is the text in the krells themselves,
not the config window which displays Japanese fine.

Comment 3 Nakai 2002-08-28 14:23:05 UTC
The following is the patch to fix this.

This allows all font setting to .po files, and detect fontset
from locale for all CJK.

This does not include Chinese/Korean font settings though,
but actually there is no .po files for them.

Comment 4 Nakai 2002-08-28 14:24:17 UTC
Created attachment 73525 [details]
The patch to detect multibyte locale.

Comment 5 Leon Ho 2004-04-07 01:24:48 UTC
Do you like the patch? Do you think it is a close -> won't fix?

Comment 6 Nakai 2004-04-07 17:49:06 UTC

*** This bug has been marked as a duplicate of 107696 ***

Comment 7 Nakai 2004-04-07 17:51:33 UTC
Let's move to Fedora version of bug.
This bug still happens on FC2T2, LANG=ja_JP.UTF-8.

GTK+/Pango is not the magical word to fix i18n issue automatically,
 nor a medichine to heal bad hackers...

Comment 8 Red Hat Bugzilla 2006-02-21 18:48:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.