This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 570345 - [abrt] crash in muse-1:1.0.1-1.fc12: Process /usr/bin/muse was killed by signal 11 (SIGSEGV)
[abrt] crash in muse-1:1.0.1-1.fc12: Process /usr/bin/muse was killed by sign...
Status: CLOSED DUPLICATE of bug 561704
Product: Fedora
Classification: Fedora
Component: muse (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
abrt_hash:bd8d1ee73587881a1e3dca904cc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-03 18:21 EST by Adam Huffman
Modified: 2010-03-09 01:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-09 01:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.22 KB, text/plain)
2010-03-03 18:21 EST, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2010-03-03 18:21:13 EST
abrt 1.0.7 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: muse
component: muse
executable: /usr/bin/muse
kernel: 2.6.31.12-174.2.22.fc12.x86_64
package: muse-1:1.0.1-1.fc12
rating: 4
reason: Process /usr/bin/muse was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
Tried to start muse:

Denormal protection enabled.
Muse: __i386__ or __x86_64__ defined. Using optimized float buffer copying (asm movsl).
Using SSE optimized routines
no locale <muse_en_GB.utf8>/</usr/share/muse/locale>
Trying RTC timer...
fatal error: open /dev/rtc failed: Permission denied
hint: check if 'rtc' kernel module is loaded, or used by something else
Trying ALSA timer...
AlsaTimer::initTimer(): best available ALSA timer: system timer
got timer = 50
starting with default template
JACK ERROR: cannot use real-time scheduling (FIFO at priority -1) [for thread -747567344, from thread -747567344] (22: Invalid argument)
MusE: JackAudioDevice::realtimePriority: JACK is not running realtime
MusE: WARNING: Recommend setting audio realtime priority to at least 5!
Cannot set scheduling priority -5 for RT thread (Resource temporarily unavailable)
creating thread <Prefetch> failed: Invalid argument
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too high for timer (max is 1000)
  freq stays at 1000 Hz
Cannot set scheduling priority -2 for RT thread (Resource temporarily unavailable)
creating thread <Midi> failed: Invalid argument
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
midi sequencer thread does not start!? Exiting...
Comment 1 Adam Huffman 2010-03-03 18:21:15 EST
Created attachment 397680 [details]
File: backtrace
Comment 2 Orcan Ogetbil 2010-03-03 22:04:30 EST
The key line is this:

MusE: WARNING: Recommend setting audio realtime priority to at least 5!

How do you set up jack? If you are using qjackctl, go to Setup, and set the priority to at least 5. I usually set it to 20.

If you are using pure jackd, pass a priority flag, such as "-P20".

Let us know if it works.
Comment 3 Adam Huffman 2010-03-04 18:35:33 EST
I'm not currently running an RT kernel, so I can't make that setting.
Comment 4 Orcan Ogetbil 2010-03-04 19:27:33 EST
Uh, then how can we make this compatible with both kernels? We have to support the Fedora kernel, since this is Fedora right? I can patch up muse to pull the priority requirement down but that will screw up users who run the Fedora kernel.

I will think about this. Let me know if you have a solution.
Comment 5 Fernando Lopez-Lezcano 2010-03-04 21:06:51 EST
(In reply to comment #3)
> I'm not currently running an RT kernel, so I can't make that setting.    

What error do you get if you try:
  jackd -R -d alsa -d hw:0
(assuming your first soundcard is the one you want to use). 

You do not need at rt kernel to run jackd with "-R". If you are using the default jack package from Fedora you need to belong to a certain group to be able to use realtime priority (I forget what the name is for the group). Maybe that is what is missing.
Comment 6 Orcan Ogetbil 2010-03-04 21:16:50 EST
Oops. I missed the "not" in his sentence. I thought he was running RT kernel. My bad.

Fedora's jack configuration (the groups to add yourself to) is explained at
/usr/share/doc/jack-audio-connection-kit-0.118.0/README.Fedora

I assume every jack user already does this configuration. Maybe this is not a good assumption.
Comment 7 Adam Huffman 2010-03-05 03:34:29 EST
Ah, I'm glad to see there is such documentation as I've looked in vain for something like that.  Perhaps it should be mentioned more widely - on the Audio Creation SIG wiki page, for instance?

I was already in the pulse-rt group, but not the jackuser one.  Will rectify that and try again.
Comment 8 Adam Huffman 2010-03-05 03:43:18 EST
Sorry - my account is already in the 'jackuser' group as well and I already had '-R' and '-P' in my jackd invocation:

jackd -R -P4 -dalsa -r44100 -p512 -n4 -D -Chw:0 -Phw:0
Comment 9 Orcan Ogetbil 2010-03-05 03:55:09 EST
> Ah, I'm glad to see there is such documentation as I've looked in vain for
> something like that.  Perhaps it should be mentioned more widely - on the Audio
> Creation SIG wiki page, for instance?

Good idea.

> Sorry - my account is already in the 'jackuser' group as well and I already had
> '-R' and '-P' in my jackd invocation:
> 

Make sure you logout/login after you add yourself to those groups.

> jackd -R -P4 -dalsa -r44100 -p512 -n4 -D -Chw:0 -Phw:0    

Okay, now you want to have a priority of at least 5. So change that -P4 flag to -Px where x>4
Comment 10 Adam Huffman 2010-03-05 18:09:26 EST
Okay, I've invoked jackd with -P5 and started muse.  It still crashed...

muse
Denormal protection enabled.
Muse: __i386__ or __x86_64__ defined. Using optimized float buffer copying (asm movsl).
Using SSE optimized routines
no locale <muse_en_GB.utf8>/</usr/share/muse/locale>
Trying RTC timer...
fatal error: open /dev/rtc failed: Permission denied
hint: check if 'rtc' kernel module is loaded, or used by something else
Trying ALSA timer...
AlsaTimer::initTimer(): best available ALSA timer: system timer
got timer = 50
starting with default template
JACK ERROR: cannot use real-time scheduling (FIFO at priority 0) [for thread -2069096688, from thread -2069096688] (22: Invalid argument)
MusE: JackAudioDevice::realtimePriority: JACK is not running realtime
MusE: WARNING: Recommend setting audio realtime priority to at least 5!
Cannot set scheduling priority -5 for RT thread (Resource temporarily unavailable)
creating thread <Prefetch> failed: Invalid argument
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too high for timer (max is 1000)
  freq stays at 1000 Hz
Cannot set scheduling priority -2 for RT thread (Resource temporarily unavailable)
creating thread <Midi> failed: Invalid argument
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
looping waiting for sequencer thread to start
midi sequencer thread does not start!? Exiting...
Comment 11 Orcan Ogetbil 2010-03-06 18:04:31 EST
Thanks. But we can't proceed much further if you don't give us enough information.
Please tell us all the flags jack now starts with.

Can you kill your jack if it is running, then start it over? Then start muse.
Comment 12 Orcan Ogetbil 2010-03-06 18:06:26 EST
For instance my jack-0.118.0 starts with

/usr/bin/jackd -R -P20 -dalsa -dhw:0 -r44100 -p1024 -n2 -Xseq

and muse-1.0.1 works fine.
Comment 13 Adam Huffman 2010-03-07 03:39:49 EST
I mentioned the only parameter I changed from the invocation listed earlier...

Anyway, here it is:

jackd -R -P5 -dalsa -r44100 -p512 -n4 -D -Chw:0 -Phw:0
Comment 14 Orcan Ogetbil 2010-03-07 04:02:06 EST
Did you try anything higher than -P5?
Like -P6 or -P10 or -P20 etc?
Comment 15 Adam Huffman 2010-03-08 13:17:20 EST
Yes, it did startup successfully with -P20.  Still think it shouldn't crash with lower values.
Comment 16 Orcan Ogetbil 2010-03-08 15:07:08 EST
You are right. It shouldn't. I'll talk to the developers.
Comment 17 Orcan Ogetbil 2010-03-09 01:48:53 EST
I realized that this is the same crash on start that Fanis reported a while ago. There were a couple more reports of this crash too. Let's collect them all at one place.

*** This bug has been marked as a duplicate of bug 561704 ***

Note You need to log in before you can comment on or make changes to this bug.