Bug 561704 - [abrt] crash in muse-1:1.0-1.fc12
[abrt] crash in muse-1:1.0-1.fc12
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: muse (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
abrt_hash:87e662ee31fe848f3f46631cc53...
:
: 563933 564256 567025 570345 573422 595144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 00:46 EST by Fanis Attard
Modified: 2010-12-03 18:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 18:20:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.33 KB, text/plain)
2010-02-04 00:46 EST, Fanis Attard
no flags Details

  None (edit)
Description Fanis Attard 2010-02-04 00:46:08 EST
abrt 1.0.4 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: muse
component: muse
executable: /usr/bin/muse
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: muse-1:1.0-1.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)
Comment 1 Fanis Attard 2010-02-04 00:46:11 EST
Created attachment 388711 [details]
File: backtrace
Comment 2 Orcan Ogetbil 2010-02-04 01:03:43 EST
Thanks for the report. Could you tell us how to reproduce the crash?
Comment 3 Fanis Attard 2010-02-04 04:09:59 EST
I remember the crash during the exit of the application. After your message I tried the application again and again , but it denied tenaciously to repeat the desired "crash moment"...
Comment 4 Fanis Attard 2010-02-04 14:04:01 EST
....well, Jack is running (and it's ok) and I open the Muse application. Then I simply add a midi track and I wanted to continue searching the above problem but ... my wife told to me that the dinner was ready and I had to stop immediately my work in front of the computer , if I loved my life ....!! So, I closed the application without saving anything and to my surprise the ABRT mentioned the crash !! That's all. I must turn off the PC now , because the "nuclear reactor" will explode in my small dining room..... Thanks a lot for your interest.
Comment 5 Fanis Attard 2010-02-07 13:39:49 EST
I also noticed that the application was always crashed when I tried to input midi signals from the "midi through" port. I think that the procedure I followed was correct because Rosegarden did it successfully.
Comment 6 Orcan Ogetbil 2010-02-07 14:13:16 EST
The midi input section of the code saw extensive changes lately. This might have been fixed upstream. Could you try the latest build 1.0.1 from
    http://koji.fedoraproject.org/koji/buildinfo?buildID=154782
I submitted this one to updates-testing yesterday.

If it is still broken for you, we might as well contact upstream.
Comment 7 Fanis Attard 2010-02-08 00:11:50 EST
Forgive me because Iam new in Linux and I don't know how to build applications. Generally I avoid the experiments because I am not in position to face side effects. Can I install this new muse somehow with the package manager if I expand the software sources and mark the Fedora 12 Test-updates repo ?
Comment 8 Orcan Ogetbil 2010-02-08 02:31:33 EST
No problem. These are official builds that will be in the updates-testing repo in a couple days (or possibly later today). You don't need to rebuild them.

You can either download the appropriate RPM package for your architecture and install it. For example, you would update via (as root)
   # rpm -Uvh muse-1.0.1-1.fc12.x86_64.rpm
for the x86_64 architecture.

Or if this is complicated, wait a little, the packages will be in the updates-testing repo soon. Then you can install it with your package manager.

Thanks!
Comment 9 Orcan Ogetbil 2010-02-10 13:50:16 EST
The 1.0.1 version is in testing repository now. It can be installed via
   # yum --enablerepo updates-testing update muse
or with your favorite package management software.
Comment 10 Fanis Attard 2010-02-11 03:01:11 EST
Well , I did it and I have already 2 crashes. The first one was done because I did not run jack before I run muse. I believe that if someone wants to work only with midi he doesn't need jack. The second crash was done because the muse application "does not want" to receive midi data by the midi through port. You know I use other applications in parallel with muse. The midi through port can send midi data to other applications normally, but I can't discover a way to pass midi data to muse reversely. Somehow I did it with rosegarden. Generally, I can see the same muse as before. I can see the midi channels 1-16 (one by one) but I can't see the indication "Any channel" for multichannel midi data recording. I can't understand the per cent indication next to tempo box. The tempo can be a fixed value or an altered one. I need a tempo track or something like that to define an altered tempo for any midi song. You can see it in Cubase (windows application). Anyway , I am new in Linux and I have not enough experience on Linux midi-sequencer applications, so forgive me if I say something wrong here. I am only an amateur music composer (6-7 years) and I mainly use midi keyboards, midi sequencers and other useful midi tools.
Comment 11 Orcan Ogetbil 2010-03-09 01:45:58 EST
*** Bug 563933 has been marked as a duplicate of this bug. ***
Comment 12 Orcan Ogetbil 2010-03-09 01:46:08 EST
*** Bug 564256 has been marked as a duplicate of this bug. ***
Comment 13 Orcan Ogetbil 2010-03-09 01:48:09 EST
*** Bug 567025 has been marked as a duplicate of this bug. ***
Comment 14 Orcan Ogetbil 2010-03-09 01:48:53 EST
*** Bug 570345 has been marked as a duplicate of this bug. ***
Comment 15 Orcan Ogetbil 2010-03-14 21:10:03 EDT
*** Bug 573422 has been marked as a duplicate of this bug. ***
Comment 16 Bug Zapper 2010-11-03 19:06:14 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Karel Klíč 2010-11-08 14:08:23 EST
*** Bug 595144 has been marked as a duplicate of this bug. ***
Comment 18 Bug Zapper 2010-12-03 18:20:58 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.