Bug 57041 - RPM fails on servers which do not recognize the SIZE command
Summary: RPM fails on servers which do not recognize the SIZE command
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 50887 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-03 18:31 UTC by Frank Hirtz
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 20:09:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Hirtz 2001-12-03 18:31:56 UTC
Description of Problem:
RPM fails on servers which do not recognize the SIZE command.

The SIZE command is not in the RFC for FTP and is not included in the
solaris ftp server. RPM fails when it tries to install over the ftp link.
Nortel would like this corrected as they are using solaris extensively.

See bug#'s 50887 and 17346 for more detailed information.


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Jeff Johnson 2001-12-09 17:58:44 UTC
I need some help prioritizing this bug, basically whether rpm-4.0.4 or rpm-4.1
is gonna be the location of the fix. Frank has been very patient so far :-)

The issue is the use of a linux only ftpd SIZE command that
rpm uses to synthesize a Content-Length: field so that
the FTP command channel does not have to be repeatedly
torn down and reopened. If/when I attempt a fix, I will mark
the FTP command channel that has a failing SIZE command
as necessary to be reopened repeatedly.

Comment 2 Bill Nottingham 2001-12-10 04:40:50 UTC
If a customer wants it, it will probably need to be backported to
whatever-they're -running, so it probably is best to do it against 4.0.3/4.0.4
first...

Comment 3 Jeff Johnson 2001-12-10 14:59:19 UTC
*** Bug 50887 has been marked as a duplicate of this bug. ***

Comment 4 Paul Nasrat 2005-06-07 20:09:55 UTC
Use of a depsolver such as up2date or yum encouraged for network repos.


Note You need to log in before you can comment on or make changes to this bug.