Bug 50887 - rpm with FTP URL fails against servers w/o SIZE cmd
rpm with FTP URL fails against servers w/o SIZE cmd
Status: CLOSED DUPLICATE of bug 57041
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 17346 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 10:35 EDT by Cris Rhea
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-09 16:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cris Rhea 2001-08-04 10:35:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
rpm -i ftp://server/bla will fail when the server's ftpd doesn't
support the SIZE command. Noticed when attempting to use Solaris 7
as an RH7.1 RPM server (using stock in.ftpd on Sun Solaris).

How reproducible:
Always

Steps to Reproduce:
1. Build anon-ftp server on Sun Solaris 7 system following ftpd man page.
2. On RH7.1 system run: rpm -ihvv
ftp://solaris7.mayo.edu/rh7.1/RedHat/RPMS/koffic*
(example package name- doesn't matter)
	

Actual Results:  rpm -ihvv
ftp://solaris7.mayo.edu/rh7.1/RedHat/RPMS/koffic*
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: logging into solaris7.mayo.edu as ftp, pw (username)
Retrieving
ftp://solaris7.mayo.edu/rh7.1/RedHat/RPMS/koffice-2.0.1-2.i386.rpm
D:  ... as /var/tmp/rpm-xfer.S8pZL1
D: failed to open
ftp://solaris7.mayo.edu/rh7.1/RedHat/RPMS/koffice-2.0.1-2.i386.rpm: Success
error: skipping
ftp://solaris7.mayo.edu/rh7.1/RedHat/RPMS/koffice-2.0.1-2.i386.rpm -
transfer failed - Unknown or unexpected error
D: retrieved 0 packages


Expected Results:  Package install....

Additional info:

Real-world example of Linux not playing well with other Unix boxes.
While this could be solved by installing wu-ftp on the solaris box,
I shouldn't have to do that just to serve RPMs...
Comment 1 Jeff Johnson 2001-08-30 12:59:24 EDT
*** Bug 17346 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2001-12-09 12:51:24 EST

*** This bug has been marked as a duplicate of 50741 ***
Comment 3 Cris Rhea 2001-12-09 16:01:48 EST
I have no idea how this is a duplicate of 50741. This bug refers to RPM's usage
of the SIZE command within FTP while bug 50741 is a problem with which UID/GID
a mail package uses. Either the duplicate bug ID was typo'ed or there needs
to be some comment added as to how these two seemingly unrelated bugs
are duplicates.
Comment 4 Jeff Johnson 2001-12-10 09:59:24 EST
Sorry, my dyslexia.

*** This bug has been marked as a duplicate of 57041 ***

Note You need to log in before you can comment on or make changes to this bug.