Bug 57044 - zsh cannot be used without /usr mounted
Summary: zsh cannot be used without /usr mounted
Status: CLOSED DUPLICATE of bug 55735
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-03 19:07 UTC by Rik Faith
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-03 19:07:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rik Faith 2001-12-03 19:07:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.16 i686; Nav)

Description of problem:
zsh links with /usr/lib/libcap, so it cannot be used in single
user mode when /usr is not yet mounted.  This is really annoying
if you make /bin/zsh root's shell, since you can't start a single
user mode shell.  Note that there may be additional issues with
zsh's loadable modules, as described below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter single user mode
2. Make sure /usr is not mounted
3. Start zsh
	

Actual Results:  zsh didn't start

Expected Results:  zsh should have started

Additional info:

I'm not sure about the zsh 4.0.2 that RH is shipping, but 4.0.4
will use dynamically loaded modules.  This is an interesting
feature, but it will cause similar problems if the modules aren't
available if /usr isn't mounted.  I'd recommend configuring with
--disable-dynamic to avoid this (using modules appears to save
only about 200KB).  One expects that shells that are available 
from /bin will work in single user mode.

Comment 1 Trond Eivind Glomsrxd 2001-12-03 22:58:37 UTC

*** This bug has been marked as a duplicate of 55735 ***


Note You need to log in before you can comment on or make changes to this bug.