Bug 570612 - [abrt] crash in gonvert-0.2.20-2.fc12: gonvert:584:bottom:ValueError: invalid literal for float(): t
Summary: [abrt] crash in gonvert-0.2.20-2.fc12: gonvert:584:bottom:ValueError: invalid...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gonvert
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:69146305
: 558291 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-04 20:50 UTC by Dale Snell
Modified: 2010-05-18 21:57 UTC (History)
2 users (show)

Fixed In Version: gonvert-0.2.24-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 21:52:02 UTC


Attachments (Terms of Use)
File: backtrace (373 bytes, text/plain)
2010-03-04 20:50 UTC, Dale Snell
no flags Details

Description Dale Snell 2010-03-04 20:50:18 UTC
abrt 1.0.7 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/gonvert
comment: This is very repeatable, though abrt reports a different error for each time I do it, apparently responding to the differing "typos" I used.  Evidently gonvert is not checking the validity of the input data before trying to use it.
component: gonvert
executable: /usr/bin/gonvert
kernel: 2.6.31.12-174.2.22.fc12.i686
package: gonvert-0.2.20-2.fc12
reason: gonvert:584:bottom:ValueError: invalid literal for float(): t
release: Fedora release 12 (Constantine)

backtrace
-----
gonvert:584:bottom:ValueError: invalid literal for float(): t

Traceback (most recent call last):
  File "/usr/bin/gonvert", line 584, in bottom
    value = float(entry4.get_text())
ValueError: invalid literal for float(): t

Local variables in innermost frame:
a: <gtk.Entry object at 0xb73b7f7c (GtkEntry at 0xa2bbae8)>
self: <__main__.Ccalculate instance at 0xb73bd92c>

How to reproduce
-----
1. Launch gonvert
2. Select Temperature
3. Mis-type a number; i.e., 3t instead of 35.  Boom.

Comment 1 Dale Snell 2010-03-04 20:50:20 UTC
Created attachment 397921 [details]
File: backtrace

Comment 2 Gwyn Ciesla 2010-03-30 20:31:25 UTC
*** Bug 558291 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2010-03-30 20:56:22 UTC
gonvert-0.2.23-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gonvert-0.2.23-1.fc12

Comment 4 Fedora Update System 2010-03-30 20:56:27 UTC
gonvert-0.2.23-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gonvert-0.2.23-1.fc13

Comment 5 Gwyn Ciesla 2010-03-30 20:57:35 UTC
I'm not positive this will fix it, but it may.  Please test.

Comment 6 Fedora Update System 2010-04-01 01:42:41 UTC
gonvert-0.2.23-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gonvert'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gonvert-0.2.23-1.fc12

Comment 7 Fedora Update System 2010-04-01 19:28:52 UTC
gonvert-0.2.23-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gonvert'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gonvert-0.2.23-1.fc13

Comment 8 Dale Snell 2010-04-13 20:17:30 UTC
Alas, abrt still complains.  As before, I just typed an invalid character along with the valid one(s).  Here's the backtrace:

gonvert:540:top:ValueError: invalid literal for float(): 3e

Traceback (most recent call last):
  File "/usr/bin/gonvert", line 540, in top
    value = float(entry2.get_text())
ValueError: invalid literal for float(): 3e

Local variables in innermost frame:
a: <gtk.Entry object at 0xb731a20c (GtkEntry at 0x886a118)>
self: <__main__.Ccalculate instance at 0xb731baac>

Comment 9 Gwyn Ciesla 2010-04-28 19:06:36 UTC
Grr.

Ok.  I contacted upstream, who hopefully can shed some light here.

Comment 10 Fedora Update System 2010-05-13 22:05:09 UTC
gonvert-0.2.24-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gonvert-0.2.24-1.fc13

Comment 11 Fedora Update System 2010-05-13 22:05:15 UTC
gonvert-0.2.24-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gonvert-0.2.24-1.fc12

Comment 12 Gwyn Ciesla 2010-05-13 22:09:36 UTC
Upstream say this might fix it, please test and report back.

Comment 13 Fedora Update System 2010-05-15 20:25:18 UTC
gonvert-0.2.24-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gonvert'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gonvert-0.2.24-1.fc12

Comment 14 Fedora Update System 2010-05-15 20:41:13 UTC
gonvert-0.2.24-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gonvert'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gonvert-0.2.24-1.fc13

Comment 15 Dale Snell 2010-05-16 16:12:48 UTC
(In reply to comment #12)
> Upstream say this might fix it, please test and report back.    

Fixed!  I ran it on both i686 and x86_64 machines without a crash.

Comment 16 Walter 2010-05-17 04:45:48 UTC
I installed this and have not seen the browser crash, but for the first time EVER I see that Pidgin crashed at a time when the laptop should have been idle.  I generated a report on the crash.

Status: NEW
https://bugzilla.redhat.com/show_bug.cgi?id=592814

Comment 17 Fedora Update System 2010-05-18 21:51:57 UTC
gonvert-0.2.24-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-05-18 21:57:33 UTC
gonvert-0.2.24-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.