Bug 57075 - gcc gets an internal compiler error when compiling boost/regex library.
gcc gets an internal compiler error when compiling boost/regex library.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://www.boost.org/libs/regex/index...
:
: 58898 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-04 09:04 EST by Thorbjvrn Jemander
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 13:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorbjvrn Jemander 2001-12-04 09:04:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
Gcc (g++, 2.96) gets an internal compiler error when compiling boost/regex
library. See given URL.


Version-Release number of selected component (if applicable): 2.96


How reproducible:
Always

Steps to Reproduce:
1.Download the boost library from the given URL.
2.Go to boost/libs/regexp/build
3.Type make -f gcc.mk
	

Actual Results:  gcc fails with an internal compiler error when compiling
the file
../../../boost/regex.hpp:244: Internal compiler error in scan_region,
at except.c:2809

See below for an example.



Additional info:

thje@sulfur:~/proj/externt/boost/libs/regex/build>make -f gcc.mak
g++  -o gcc/boost_regex/cregex.o -c -O2 -I../../../  ../src/cregex.cpp
../../../boost/regex.hpp: In function `iterator
boost::re_detail::re_is_set_member (iterator, iterator,
boost::re_detail::re_set_long *, const boost::reg_expression<charT,
traits_type, Allocator> &) [with iterator =
boost::re_detail::mapfile_iterator, charT = char, traits_type =
boost::regex_traits<char>, Allocator = allocator<char>]':
../../../boost/regex/detail/regex_match.hpp:566:   instantiated from
`boost::re_detail::query_match_aux (iterator, iterator,
boost::match_results<iterator, Allocator> &, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int,
boost::re_detail::_priv_match_data<iterator, Allocator> &, iterator *)
[with iterator =
boost::re_detail::mapfile_iterator, Allocator = allocator<char>, charT =
char, traits = boost::regex_traits<char>, Allocator2 = allocator<char>]'
../../../boost/regex/detail/regex_match.hpp:1114:   instantiated from
`boost::re_detail::reg_grep2 (Predicate, I, I, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int, A2) [with
Predicate = boost::re_detail::pred4, I =
boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, A =
allocator<char>, A2 = allocator<char>]'
../../../boost/regex/detail/regex_match.hpp:1773:   instantiated from
`boost::regex_grep (Predicate, iterator, iterator, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int) [with
Predicate = boost::re_detail::pred4, iterator =
boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, Allocator = allocator<char>]'
../src/cregex.cpp:387:   instantiated from here
../../../boost/regex.hpp:244: Internal compiler error in scan_region,
at except.c:2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [gcc/boost_regex/cregex.o] Error 1
Comment 1 Jakub Jelinek 2001-12-18 07:51:14 EST
Please try a more recent gcc-2.96 rpm (I think 2.96-97 or above).
It should be fixed there.
Comment 2 Jakub Jelinek 2002-01-28 06:14:29 EST
*** Bug 58898 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2002-12-15 13:42:18 EST
No reply, assuming ok

Note You need to log in before you can comment on or make changes to this bug.