Bug 570869 - Ralink 2860 wireless cards do not work with rt2800 pci in 2.6.33
Ralink 2860 wireless cards do not work with rt2800 pci in 2.6.33
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
: 544428 574247 (view as bug list)
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2010-03-05 12:54 EST by Kostas
Modified: 2011-03-08 07:14 EST (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 11:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmseg results (43.07 KB, text/plain)
2010-03-05 14:25 EST, Kostas
no flags Details
var/log/messages (133.29 KB, text/plain)
2010-03-05 14:25 EST, Kostas
no flags Details
grep NetworkManager /var/log/messages (125.16 KB, text/plain)
2010-04-26 18:37 EDT, bloodandsoil76
no flags Details
dmesg output (48.69 KB, text/plain)
2010-04-26 18:39 EDT, bloodandsoil76
no flags Details

  None (edit)
Description Kostas 2010-03-05 12:54:45 EST
Ralink 2860 wireless cards do not work with rt2800pci driver in 2.6.33. Wireless card is recognized but no connection at all. Tested with all rawhide kernels till today (2.6.33-052.rc8.git6.fv13.i686)
Comment 1 John W. Linville 2010-03-05 13:58:50 EST
Can you be more specific?  Please attach the output of 'dmesg' and the contents of /var/log/messages shortly after a connection attempt.  Also include the output of 'iwlist wlan0 scan'.
Comment 2 Kostas 2010-03-05 14:25:07 EST
Created attachment 398105 [details]
dmseg results

dmseg results after connection attempt
Comment 3 Kostas 2010-03-05 14:25:45 EST
Created attachment 398106 [details]
var/log/messages

var/log/messages
Comment 4 Kostas 2010-03-05 14:30:25 EST

iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:50:7F:A5:69:78
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=27 dBm  
                    Encryption key:on
                    ESSID:"pkst"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000001da4ef32f4
                    Extra: Last beacon: 777ms ago
                    IE: Unknown: 0004706B7374
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0102
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D1606070700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: 0706545720010D10
                    IE: Unknown: DD1E00904C336E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3406070700000000000000000000000000000000000000
Comment 5 John W. Linville 2010-03-05 14:40:49 EST
IIRC, rt2800 has a lot of changes pending for the 2.6.34 series.  Please retest when a 2.6.34-based kernel is available in rawhide.
Comment 6 Adam Williamson 2010-04-14 15:43:46 EDT
I test periodically with compat-wireless built against the F13 kernel and haven't ever got it to work yet. Wanted to try with yesterday's but it wouldn't build. I'll try and remember to update here if I ever get it flying.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 bloodandsoil76 2010-04-23 23:38:27 EDT
Still not working on my system which is a default install of Fedora 13 beta from the netinstall.iso.  I can see the SSID and can type in my WPA2 key, but then the NetworkManager thinks about it for about 30 seconds and then kicks me back to the WPA2 key dialoge box.  I can never get a connection, even though the wireless router is known to be good and working.  Here is my info.

iwlist output:

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

eth1      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:21:91:FF:1C:77
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70  Signal level=33 dBm  
                    Encryption key:on
                    ESSID:"Evergreen 1"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000003c90a6a180
                    Extra: Last beacon: 2959ms ago
                    IE: Unknown: 000B45766572677265656E2031
                    IE: Unknown: 010482848B96
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
                    IE: Unknown: 32080C1218243048606C
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD070050F202000100
                    IE: Unknown: 2D1A4C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160900180000000F000000000000000000000000000000
                    IE: Unknown: DD1E00904C336C101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C340900000000000F000000000000000000000000000000
                    IE: Unknown: 050400010000
          Cell 02 - Address: 00:26:F2:FD:CB:49
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=70/70  Signal level=-191 dBm  
                    Encryption key:on
                    ESSID:"Randy's wifi"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000265821ce03
                    Extra: Last beacon: 2841ms ago
                    IE: Unknown: 000C52616E647927732077696669
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030102
                    IE: Unknown: 050400020000
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101820003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C33CC111BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 2D1ACC111BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3402001B00000000000000000000000000000000000000
                    IE: Unknown: 3D1602001B00000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010002004000
                    IE: Unknown: DD270050F204104A000110104400010210470010000000000000100000000026F2FDCB49103C000103
          Cell 03 - Address: 00:14:BF:AB:F7:70
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=63 dBm  
                    Encryption key:on
                    ESSID:"Monet"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000002e3eb2418b
                    Extra: Last beacon: 2602ms ago
                    IE: Unknown: 00054D6F6E6574
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD060010180200F0
          Cell 04 - Address: 00:21:63:5F:61:84
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=63 dBm  
                    Encryption key:on
                    ESSID:"Firebird"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000110e4be787
                    Extra: Last beacon: 2879ms ago
                    IE: Unknown: 00084669726562697264
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030101
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
          Cell 05 - Address: 00:21:63:5D:9B:6D
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=56 dBm  
                    Encryption key:on
                    ESSID:"EMGR4"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000006aa277d181
                    Extra: Last beacon: 2868ms ago
                    IE: Unknown: 0005454D475234
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030101
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
          Cell 06 - Address: 00:1D:7E:E4:63:DE
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70  Signal level=-185 dBm  
                    Encryption key:on
                    ESSID:"URANUS"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000002c63a430183
                    Extra: Last beacon: 2414ms ago
                    IE: Unknown: 00065552414E5553
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030109
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0105
                    IE: Unknown: 2F0105
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD090010180202F4000000

iwconfig output:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Evergreen 1"  
          Mode:Managed  Frequency:2.452 GHz  Access Point: Not-Associated   
          Tx-Power=8 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

nmtool output:

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sky2
  State:             unavailable
  Default:           no
  HW Address:        00:18:F3:44:D3:F5

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rt2800pci
  State:             disconnected
  Default:           no
  HW Address:        00:25:9C:F5:26:D9

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
    Evergreen 1:     Infra, 00:21:91:FF:1C:77, Freq 2452 MHz, Rate 54 Mb/s, Strength 100 WPA2
    cjzj-c:          Infra, 00:14:BF:72:DB:35, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA
    default:         Infra, 00:13:46:19:F3:A2, Freq 2462 MHz, Rate 54 Mb/s, Strength 100
    Randy's wifi:    Infra, 00:26:F2:FD:CB:49, Freq 2417 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
    EMGR4:           Infra, 00:21:63:5D:9B:6D, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WEP
    Monet:           Infra, 00:14:BF:AB:F7:70, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WEP
    Firebird:        Infra, 00:21:63:5F:61:84, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WEP


- Device: eth1 -----------------------------------------------------------------
  Type:              Wired
  Driver:            skge
  State:             unavailable
  Default:           no
  HW Address:        00:18:F3:44:C7:75

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

I also have "dmesg" and "grep NetworkManager /var/log/messages" output.  I do not know how to make an attachment.  If anyone cares to see that output please help me learn how to make an attachment in my post.  Thanks.
Comment 8 John W. Linville 2010-04-26 09:34:04 EDT
There is an "Add an attachment" link near the top of the page.  From there I think it is self-explanatory?

Please note that rt2800 support is still a work in progress.  I'm sorry it isn't "there" yet, but the rt2x00 team is still working on it.
Comment 9 bloodandsoil76 2010-04-26 18:37:25 EDT
Created attachment 409312 [details]
grep NetworkManager /var/log/messages
Comment 10 bloodandsoil76 2010-04-26 18:39:32 EDT
Created attachment 409313 [details]
dmesg output
Comment 11 Adam Williamson 2010-04-26 18:48:43 EDT
there's not much point, bloodandsoil. We already know it doesn't work. It doesn't work for anyone. Everyone has the same output in the logs. There's nothing we can do about it (well, we could disable the driver again; how about that, John?) All you can do is wait for upstream to fix it, and in the meantime install rt2860sta from RPM Fusion.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 bloodandsoil76 2010-04-27 02:46:17 EDT
Adam Williamson,

I apologize if my contributions are pointless.  I am new to bugzilla and I am only trying to help out.

I had no idea about rt2860sta from RPM Fusion.  Thank you for that information.
Comment 13 Adam Williamson 2010-04-27 20:10:26 EDT
Sorry, not trying to be dismissive, just save you the work, though I came too late :)

the info about rt2860sta is available further up the report.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Peter Robinson 2010-05-05 06:56:30 EDT
*** Bug 574247 has been marked as a duplicate of this bug. ***
Comment 15 Peter Robinson 2010-05-05 06:59:24 EDT
*** Bug 544428 has been marked as a duplicate of this bug. ***
Comment 16 Adam Williamson 2010-05-20 09:30:34 EDT
Just did one of my periodic tests, and with compat-wireless-2010-05-19 , it works! Been up for 10 minutes without falling over, call it stable and ship it =)

so it looks like there's working code to pull into f13, John.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Mike Heller 2010-05-28 01:58:34 EDT
Because I have the same problem I'd like to know some additional info about compat-wireless-2010-05-19. Could you explain more detailed what does that mean? I couldn't figure it out. :-(

Thanks in advance!
Comment 18 Adam Williamson 2010-05-28 10:58:39 EDT
Download it from http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/05/

extract it somewhere handy, run:

./scripts/driver_select rt2x00
make
su
make install
make wlunload
modprobe rt2800pci

and it should start working. Then you can remove your rt2860sta packages, so it'll use rt2800pci on boot. You'll have to do the above for each new kernel, and make sure you have the kernel -devel package.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Mike Heller 2010-05-29 04:41:30 EDT
After some tries I checked that I have to install a kernel without PAE.

Thanks, that works!
Comment 20 Adam Williamson 2010-05-29 12:02:44 EDT
if you have a PAE kernel, you just need to ensure you install the kernel -devel package with PAE in its name.
Comment 21 Peter Robinson 2010-05-29 18:17:22 EDT
With the 2.3.34 F-13 scratch build this still has issues with a WPA wifi connection.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2217307
Comment 22 John W. Linville 2010-06-09 13:57:25 EDT
Work continues upstream to support this hardware w/ the rt2x00 drivers.  I expect that 2.6.35-based kernels will support this hardware "out of the box".
Comment 23 Adam Williamson 2010-06-09 14:45:22 EDT
John: that still leaves us with a rather unsatisfactory situation for F13: it ships a driver that claims to work and loads and takes over the hardware so no other driver can work, but which is actually completely broken and will never work.

I'm re-opening this because F13 should behave more sanely. Either backport a newer version of the driver which works, or disable the driver in F13's kernels.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Adam Williamson 2010-06-09 16:03:36 EDT
sorry, above is a bit abrupt - of course I meant 'can you please either' etc etc.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 John W. Linville 2010-06-09 16:18:59 EDT
Disabling the driver would be a poor choice -- the fact that it isn't working for you does not imply that it isn't working for anyone.  I will, however, disable the rt30xx and rt35xx bits in the 2.6.34-based kernels (currently in rawhide) -- that option is new, and those devices are known not to work.  I'll even backport that patch to the 2.6.33 kernels in F-13.

Regarding "takes over the hardware so no other driver can work", feel free to blacklist the driver if you have an alternative.  Otherwise, we have made a policy out of _not_ doing things to accomodate out-of-stream drivers.  I don't see any reason to change that here.

As for backporting, I'm happy to review your patch.  Otherwise, I'm afraid you'll just have to wait for upstream support.
Comment 26 Adam Williamson 2010-06-09 16:40:46 EDT
Well I don't have a problem making it work for me, see above. I'm just worried about the general experience. I'm not aware of anyone reporting that the driver as shipped in the current F13 kernels actually works, though obviously it's harder to find positive than negative results.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Peter Robinson 2010-06-10 09:49:36 EDT
Using a usb based RT2870 and pci based RT2860 on APs with no, WEP and WPA security I couldn't get them to associate. It would be great if we could get a back port of this for F-13.
Comment 28 Adam Williamson 2010-06-10 12:17:24 EDT
I mentioned these to John on IRC, but for the record, I looked around for other experiences with the 2.6.33 driver, and found a couple of things from Arch:

http://bbs.archlinux.org/viewtopic.php?pid=741668
http://bugs.archlinux.org/task/19048

one forum thread and one bug, both complaining about wireless breaking with their first 2.6.33 kernel; they had rt2860sta in their kernels, then when they pushed 2.6.33, rt2800pci won out over rt2860sta and caused wireless not to work for a lot of people. I can't see anyone there reporting success with 2.6.33, just a couple of reports of success with 2.6.34 and 2.6.35.

My intuitive feeling in this case is that if the rt2800pci driver works for any hardware in 2.6.33, it's a pretty limited range.
Comment 29 Tim Lauridsen 2010-06-10 12:45:16 EDT
just for information, the kmod-rt28xx packages in rpmfusion has included a blacklist file for the rt2800pci driver, so installing the driver with work without any pain :)
Comment 30 Adam Williamson 2010-06-10 12:54:26 EDT
yeah, true, I'm just worried people will be confused by the presence of a driver by default that appears to half work, and think that they just need to tweak some configuration or something to make it fully work. But indeed, if you know you need to install rt2860sta to actually have the card work, you can do so from That Other Place, and it works without trouble.
Comment 31 John W. Linville 2010-06-10 16:04:49 EDT
Against my better judgment...give this a try?  Does your rt2800 device work?  Note that you'll need to remove the rt2860sta driver for proper testing.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2243376

Note that this is no way amounts to a promise to commit such a backport.  Wholesale backports like this are a maintenance problem, decrease stability, etc....
Comment 32 Adam Williamson 2010-06-10 17:40:14 EDT
Afraid that one doesn't work. Back to -112 with compat-wireless-2010-05-19 , that is the combination that works for me (haven't tried any newer compat-wireless).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 33 Adam Williamson 2010-06-10 17:41:03 EDT
oh, forgot to mention - it behaves just the same as the standard f13 kernel, will find networks and try to connect but never gets past 'Associating...'



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 34 acount closed by user 2010-06-11 06:48:06 EDT
linux-firmware package brings very old FW for rt2800usb and rt2800pci devices.

Try a new one, directly from RALINK: http://www.ralinktech.com/support.php?s=2
Comment 35 Adam Williamson 2010-06-11 14:10:43 EDT
I don't see how that has any relevance, given that we've already established it works with new enough driver code.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 36 John W. Linville 2010-06-14 08:56:55 EDT
Well, that was about as far as I was willing to consider going with a backport.  So I guess that puts us back to waiting for a 2.6.35-based kernel to appear.  If you don't like CLOSED->DEFERRED, then what state do you suggest?  Perhaps CLOSED->UPSTREAM?
Comment 37 Adam Williamson 2010-06-14 10:41:51 EDT
It wasn't the resolution which was the issue, DEFERRED is fine for the action you propose. I just re-opened it to propose disabling the driver as long as it appears to be non-functional for many people. If you've decided you don't want to do that either, then CLOSED DEFERRED is an appropriate resolution.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 38 Adam Williamson 2010-06-14 10:45:29 EDT
-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 39 Orcan Ogetbil 2010-06-29 18:53:14 EDT
Just for the record, the rt2800usb module that comes with the kernel-2.6.35 release candidate RPM from koji still does not work.
Comment 40 Orcan Ogetbil 2010-08-23 16:07:20 EDT
rt2800usb from kernel-2.6.35.2-9.fc14 doesn't work either. I guess we'll need to keep the sta drivers in RPMFusion for another release cycle. :(
Comment 41 Jose Rodriguez 2010-09-12 19:27:34 EDT
I am very new to Fedora - I need to get my RT2800PCI to work  and I downloaded the file you mentioned on the post I extracted the file onto my desktop - can you help me run the commands you mention below?  I have no idea and I have tried everything.  Thank you


(In reply to comment #18)
> Download it from http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/05/
> 
> extract it somewhere handy, run:
> 
> ./scripts/driver_select rt2x00
> make
> su
> make install
> make wlunload
> modprobe rt2800pci
> 
> and it should start working. Then you can remove your rt2860sta packages, so
> it'll use rt2800pci on boot. You'll have to do the above for each new kernel,
> and make sure you have the kernel -devel package.
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.