Bug 574247 - Network Manager cannot connect to wireless networks
Network Manager cannot connect to wireless networks
Status: CLOSED DUPLICATE of bug 570869
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-16 18:34 EDT by Alex G.
Modified: 2010-05-05 06:56 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-08 19:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex G. 2010-03-16 18:34:44 EDT
Description of problem:

Network Manager cannot connect to wireless networks, regardless of whether the networks are open or WEP/WPA/WPA2 protected.

I have tried this on an EEEPC 901 with the Ralink rt2860 wireless card.


How reproducible:

Attempting to connect to a wireless network using the above wireless card. I do not have any other wireless card to test this issue.


Steps to Reproduce:
1. Boot Fedora 13 alpha i686 from a live CD on a computer with an rt2860 wireless adapter
2. Attempt to connect to a wireless network
  
Actual results:

The wireless card (rt2860) is automatically detected, and "Wireless wlan0" shows up in the list when clicking the network manager icon. All wireless networks in range are correctly identified.

After selecting a network to connect to, the status changes to "Activating". It tries to connect to the network for a while, then asks for the network key. It tries to connect again, then asks for the network key again, repeating the process.

This happens on any wireless network, with any level of encryption, even unencrypted wireless networks.

dmesg |tail reports the following:

wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 1)
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 2)
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 1)
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 2)
wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out


Expected results:

Connect to network and have internet connectivity.


Additional info:

I have tested this issue on several networks, at different locations, where I was previously able to connect using Fedora 12 with akmod-rt2860.

I have also installed F13 to the computer in question (from the Live USB stick), ran "yum update", rebooted, but the issue persists
Wired network connectivity works as expected.
Comment 1 Alex G. 2010-03-19 03:49:14 EDT
I was able to test this on several laptops with different wireless cards. They all exhibit the same problem, but they work under Fedora12 (tested with live USB images of both F12 and F13 alpha).

I propose this bug as an F13Blocker.
Comment 2 CAI Qian 2010-03-22 00:37:27 EDT
Same problem here with,
NetworkManager-0.8.0-2.git20100317.fc14.i686
ipw2200-firmware-3.1-4.fc13.noarch
Comment 3 Dan Williams 2010-04-08 19:03:35 EDT
(In reply to comment #0)
> I have tried this on an EEEPC 901 with the Ralink rt2860 wireless card.

Note that rt2860 is not well supported by the in-kernel drivers, and any drivers you obtain from somewhere other than Fedora (rpmfusion, whatever) are not supported because they are not upstream kernel drivers, and therefore their quality is highly suspect.

In particular, the Ralink vendor drivers actually do suck in quite a few areas.

> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 1)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 2)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 1)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 2)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a (try 3)
> wlan0: direct probe to AP 00:24:d2:63:b7:0a timed out

This is a driver problem.  The driver is not able to talk to your access point.
Comment 4 Dan Williams 2010-04-08 19:04:35 EDT
Now WRT to the issues that other people are having with non-Ralink cards:

I'd like to get some debug logs from the directions here:

http://live.gnome.org/NetworkManager/Debugging

under the section "Debugging WiFi Connections".  Then attach your /var/log/messages and your /var/log/wpa_supplicant.log files, thanks.
Comment 5 Dan Williams 2010-04-08 19:05:41 EDT
dup-ing to 572796 since I'm pretty sure they are really the same bug.

*** This bug has been marked as a duplicate of bug 572796 ***
Comment 6 Peter Robinson 2010-05-05 06:56:30 EDT
Actually a dupe of 570869 so people find it correctly.

*** This bug has been marked as a duplicate of bug 570869 ***

Note You need to log in before you can comment on or make changes to this bug.