Bug 5710 - FTP Install hangs up
FTP Install hangs up
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 01:46 EDT by lockm
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 07:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lockm 1999-10-08 01:46:41 EDT
I have been atempting to do an FTP install of 6.1 with no
success.  At exactly the same spot every time the install
just stops.  After about 20 minutes of inactivity I get an
error dialog that pops up showing many lines of what appears
to be perl code.  At the bottom of this scrollable dialog
the last lines say that there was an FTP error and that the
connection has timed out.  At this point the only options
available are to select ok which aborts the installation or
to go into debug mode which also ultimately aborts the
install.

I have done many FTP installs of 6.0.  Each time I would see
similar behavour however, with 6.0 the message I got was
that the file was not found (I think it was becuase there
was an FTP error/timeout) and asked me if I wanted to try
again.  I would answer yes and the installation would
resume.

I am using a cable modem so bandwith should not be a
problem.  The site I am trying to FTP from is...

sunsite.ualberta.ca/pub/Mirror/Linux/redhat/ftp.redhat.com/r
edhat-6.1/i386

This site is very fast from where I am.  Early in the
morning the installation screen says it should only take
about 26 minutes to install 500+Mb of files!

Is there something about ftp (number of file limitation or
size limitation) that would cause this?

Why does 6.0 behave one way and 6.1 behave differently?
Does this qualify as a bug?
Comment 1 lockm 1999-10-08 03:21:59 EDT
I should mention that the place where the install stops with the ftp
install is at 24 files (I selected the Gnome workstation install).
The one it was working on when it stopped was GAWK

I also tried the HTTP install and got somewhat further but ultimately
it stopped as well.
Comment 2 hchcheng 1999-10-11 16:15:59 EDT
I have experienced this problem with both ftp and http installs in RH
5.1 and 6.0 (and I used the same site you did, plus a few others).
With the previous versions, I just gave up and downloaded everything
to my hard drive and install from there.  Every server hangs at
different, but predictable points.  I have not tried it with RH 6.1
yet.
Comment 3 lockm 1999-10-15 21:08:59 EDT
Here is the text of the error as best I can transcribe it and type it
in
--------------
Traceback(innermost last):
File "/usr/bin/anaconda.real"
  line 225 in ?
Comment 4 lockm 1999-10-15 21:39:59 EDT
Here is the text of the error as best I can transcribe it and type it
in
--------------
Traceback(innermost last):
File "/usr/bin/anaconda.real", line
  225, in ?
  intf.run(todo, test = test)
File "/tmp/lib/python1.5/site-packages/text.py",
  line 1000, in run
  rc = apply(step[1](), step[2])
File "/tmp/lib/python1.5/site-packages/text.py",
  line 572, in __call__
  if todo.doInstall():
File "/tmp/lib/python1.5/site-packages/todo.py",
  line 1482, in doInstall
  self.instCallback, p)
File "/tmp/lib/python1.5/site-packages/todo.py",
  line 1341, in instCallback
  fn = self.method.getfilename(h)
File "/tmp/lib/python1.5/site-packages/urlinstall.py",
  line 38, in getfilename file)
File "/tmp/lib/python1.5/urllib.py",
  line 66, in urlretrieve
  return _urlopener.retrieve(url, filename, reporthook)
File "/tmp/lib/python1.5/urllib.py",
  line 184, in retrieve
  fp = self.open(url)
File "/tmp/lib/python1.5/urllib.py",
  line 157, in open
  return getattr(self, name)(url)
File "/tmp/lib/python1.5/urllib.py",
  line 379, in open_ftp
  (ftp, retrlen) = self.ftpcache[key].retrfile(file, type)
File "/tmp/lib/python1.5/urllib.py",
  line 583, in retrfile
  self.ftp.nlst(file)
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 397, in nlst
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 345, in retrlines
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 285, in transfercmd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 267, in ntransfercmd
IOError: [Errno ftp error] (110,Connnection timed out')
-------------

I do not know perl at all however, there are a couple of things I
observe.  At the top is the routine called ? supposed to be there or
is that a placeholder for a routine that was not written?

I notice that there are a couple of places in the code that do have
unmatched parentheses...
...self.instCallback, p)... and
...getfilename file)...
Comment 5 sylvain_gingras 1999-10-18 00:03:59 EDT
Also observed the crashing of FTP install
just as it's about to start downloading
gawk.  At this point, the activity light
on my cable modem shows no more data coming
in.  Tried to find a way to exclude gawk
(in case the problem is with this file), but
couldn't find a way to do that yet.
Comment 6 sylvain_gingras 1999-10-18 00:05:59 EDT
Oh, I forgot to mention that I tried on the
alberta site, the ucsd site, and the w3.org
site.  Same problem everywhere.
Comment 7 Jay Turner 1999-10-21 07:48:59 EDT
*** This bug has been marked as a duplicate of 5691 ***

Note You need to log in before you can comment on or make changes to this bug.