Bug 5691 - FTP install does not work
FTP install does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-07 15:25 EDT by nihility
Modified: 2015-01-07 18:38 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 16:10:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nihility 1999-10-07 15:25:12 EDT
Ftp install does not start in gui mode,
when downloading an rpm, if the ftp server connection times
out, or the connection is lost. Instead of retrying the
download like the previous installer, It generates an
Exception in python

if you need more information let me know
Comment 1 bryan 1999-10-07 21:41:59 EDT
the python error appears to be the same as bug 5618, again.  I doubt
it's related to FTP timeouts, as my FTP moved along rather well.
Comment 2 Jay Turner 1999-10-21 07:34:59 EDT
Please submit the details of the python exception, as that is really
the only way that we will be able to diagnose the problem.
Comment 3 Jay Turner 1999-10-21 07:48:59 EDT
*** Bug 5710 has been marked as a duplicate of this bug. ***

I have been atempting to do an FTP install of 6.1 with no
success.  At exactly the same spot every time the install
just stops.  After about 20 minutes of inactivity I get an
error dialog that pops up showing many lines of what appears
to be perl code.  At the bottom of this scrollable dialog
the last lines say that there was an FTP error and that the
connection has timed out.  At this point the only options
available are to select ok which aborts the installation or
to go into debug mode which also ultimately aborts the
install.

I have done many FTP installs of 6.0.  Each time I would see
similar behavour however, with 6.0 the message I got was
that the file was not found (I think it was becuase there
was an FTP error/timeout) and asked me if I wanted to try
again.  I would answer yes and the installation would
resume.

I am using a cable modem so bandwith should not be a
problem.  The site I am trying to FTP from is...

sunsite.ualberta.ca/pub/Mirror/Linux/redhat/ftp.redhat.com/r
edhat-6.1/i386

This site is very fast from where I am.  Early in the
morning the installation screen says it should only take
about 26 minutes to install 500+Mb of files!

Is there something about ftp (number of file limitation or
size limitation) that would cause this?

Why does 6.0 behave one way and 6.1 behave differently?
Does this qualify as a bug?


------- Additional Comments From lockm@home.com  10/08/99 03:21 -------
I should mention that the place where the install stops with the ftp
install is at 24 files (I selected the Gnome workstation install).
The one it was working on when it stopped was GAWK

I also tried the HTTP install and got somewhat further but ultimately
it stopped as well.

------- Additional Comments From hchcheng@scg.math.uwaterloo.ca  10/11/99 16:15 -------
I have experienced this problem with both ftp and http installs in RH
5.1 and 6.0 (and I used the same site you did, plus a few others).
With the previous versions, I just gave up and downloaded everything
to my hard drive and install from there.  Every server hangs at
different, but predictable points.  I have not tried it with RH 6.1
yet.

------- Additional Comments From lockm@home.com  10/15/99 21:08 -------
Here is the text of the error as best I can transcribe it and type it
in
--------------
Traceback(innermost last):
File "/usr/bin/anaconda.real"
  line 225 in ?


------- Additional Comments From lockm@home.com  10/15/99 21:39 -------
Here is the text of the error as best I can transcribe it and type it
in
--------------
Traceback(innermost last):
File "/usr/bin/anaconda.real", line
  225, in ?
  intf.run(todo, test = test)
File "/tmp/lib/python1.5/site-packages/text.py",
  line 1000, in run
  rc = apply(step[1](), step[2])
File "/tmp/lib/python1.5/site-packages/text.py",
  line 572, in __call__
  if todo.doInstall():
File "/tmp/lib/python1.5/site-packages/todo.py",
 line 1482, in doInstall
  self.instCallback, p)
File "/tmp/lib/python1.5/site-packages/todo.py",
  line 1341, in instCallback
  fn = self.method.getfilename(h)
File "/tmp/lib/python1.5/site-packages/urlinstall.py",
  line 38, in getfilename file)
File "/tmp/lib/python1.5/urllib.py",
  line 66, in urlretrieve
  return _urlopener.retrieve(url, filename, reporthook)
File "/tmp/lib/python1.5/urllib.py",
  line 184, in retrieve
  fp = self.open(url)
File "/tmp/lib/python1.5/urllib.py",
  line 157, in open
  return getattr(self, name)(url)
File "/tmp/lib/python1.5/urllib.py",
  line 379, in open_ftp
  (ftp, retrlen) = self.ftpcache[key].retrfile(file, type)
File "/tmp/lib/python1.5/urllib.py",
  line 583, in retrfile
  self.ftp.nlst(file)
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 397, in nlst
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 345, in retrlines
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 285, in transfercmd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py",
  line 267, in ntransfercmd
IOError: [Errno ftp error] (110,Connnection timed out')
-------------

I do not know perl at all however, there are a couple of things I
observe.  At the top is the routine called ? supposed to be there or
is that a placeholder for a routine that was not written?

I notice that there are a couple of places in the code that do have
unmatched parentheses...
...self.instCallback, p)... and
...getfilename file)...


------- Additional Comments From sylvain_gingras@hotmail.com  10/18/99 00:03 -------
Also observed the crashing of FTP install
just as it's about to start downloading
gawk.  At this point, the activity light
on my cable modem shows no more data coming
in.  Tried to find a way to exclude gawk
(in case the problem is with this file), but
couldn't find a way to do that yet.


------- Additional Comments From sylvain_gingras@hotmail.com  10/18/99 00:05 -------
Oh, I forgot to mention that I tried on the
alberta site, the ucsd site, and the w3.org
site.  Same problem everywhere.
Comment 4 Jay Turner 1999-10-21 08:14:59 EDT
*** Bug 5761 has been marked as a duplicate of this bug. ***

I have tried to use the FTP installer to upgrade from RH6.0
to RH6.1.  I can get to the point where I am downloading
packages, but it always hangs trying to install the same
package: e2fsprogs-1.15-3.i386.rpm
The python installer will hang for approx 10 minutes and
then report an error which appears to be an FTP error.  I
have tried to independently rpm -Uvh
ftp://ftp.ou.edu/mirrors/linux/redhat/redhat-6.1/i386/RedHat
/RPMS/e2fsprogs-1.15-3.i386.rpm
This works fine.  I have reviewed the other install bugs and
I have verified that I do not have an NTFS partition on the
drive.  I see 20+ packages installed and 55MB downloaded
before this bug occurs.  It's really frustrating because the
install starts over from scratch each time rather than
starting from where it left off.

System:
RH6.0 on Intel Celeron 400
NE2K Ethernet
256MB RAM
HD with 3 partitions: Linux Swap, Linux, FAT32 (0x0B)

Any help appreciated.

-MA

------- Additional Comments From   10/24/99 12:54 -------
Not directly on *this* bug, but please revert to previous behaviour
where, in expert mode at least, non-anonymous ftp was supported.
Reason: on a local office/home network it is useful to ftp-install
from single node which may not support non-anonymous ftp. Because of
the chroot security behaviour in anon ftp, it is can be tricky to
mount the relevant redhat images under /home/ftp.
Comment 5 gfullmer 1999-10-29 09:26:59 EDT
Same problem here.  I do have a previous installation of 5.1 with the
partitions and a dual-boot NT that is taking partition hda4 & hda5.
Is that related?
Comment 6 piller 1999-11-01 21:55:59 EST
Multiple attempts to perform an ftp install of RedHat 6.1 using
updated bootnet floppy fail with exception error during package
installation stage.  I have a fast network connection, custom install
of everything (1360 MB) shows that it takes 1 hour 20 minutes, but it
never makes it before the exception error occurs.
Tried both graphical and text ftp install and they looked exactly the
same, performed the same (exception error).
It used to be easy to do ftp installations. Considering that this is
version 6.1 and an updated bootnet floppy, the presence of several
bugs in just this portion of the installer is a rather sad situation.
Does anyone know if an older bootnet installer will work to do an ftp
install of 6.1 until RedHat puts out a fix?
Comment 7 gfullmer 1999-11-01 23:54:59 EST
I thought it was just the bootnet.img disk, but
I was much suprised after copying the entire 6.1 distribution to a NT
partition and then running boot.img against it, I got the same error!
I looked at the Errata at:
  http://www.redhat.com/corp/support/errata/RHEA1999045-01.html
and downloaded the new boot.img as it recommended and it works fine.
Comment 8 richard.meer 1999-11-02 15:15:59 EST
Hi,
I've had this bug in the instalation of LINUX and some people advised
me to check the RPMS directory for anny files not ending with .RPM
I dis that and foun an log file from my FTP prog. deleted the file
and tryed the install agean, it still did'nt work ( for some other
people this did work !!) Then I compared the files in that dir with
the files on the FTP site and found out that a file called HOWTO-
corean..... something was'nt completly downloaded. I redownloaded
this file and the install worked well !! so check your RPMS dir, it
should be 555.198.893 bytes large, if it is'nt check your RPM files !!
Comment 9 dwinner 1999-11-08 13:28:59 EST
Hi,

I had exactly the same problem as the problem described here by:
jturner@redhat.com
My install moves along quite swiftly, because I too have cable modem,
then just as jturner said, it hangs, and at the same spot each time.
After lots of inactivity I get the error message and the machine shuts
down.  WHY WHY WHY WHY ... come on Redhat.  This is Linux we are
talking about, not windows.  The install should go swiftly.  Linux is
supposed to be ultra stable and virtually crash proof.  A crash on the
install is not a good sign.  Please fix this ASAP because there are
going to be some angry people trying to install Linux.
Comment 10 Dave Lindquist 1999-11-11 19:02:59 EST
Sigh.  I, too, am running into this problem, and have been checking and
rechecking this bug in hopes that it has been fixed.  However, I see that it
hasn't event been _ASSIGNED_ to anyone!

Please, can we have this fixed?  Or at least some information on why it is too
hard to fix right now?  RedHat 6.0 worked without problem -- at least give us
back our "retry" ability!
Comment 11 robertd 1999-11-16 09:32:59 EST
I am getting this problem FTPing over a LAN. I have spent over eight hours
trying to install. Sometimes I can get as far as installing the packages, other
times it gets as far as post install configuration before it quits. I am using
the latest pcmcia boot image and updates (downloaded yesterday)
Comment 12 Jay Turner 1999-12-02 12:11:59 EST
This issue has been forwarded to a developer for further action.
Comment 13 paul_domenici 1999-12-13 15:06:59 EST
Same problem as everyone else. Tried downloading via FTP numerous times without
success.  Always stops at the same place, after around 55M of data.   Seems like
you should'nt even release the installer as it WASTES PEOPLES TIME!!!   Would
be nice to know IF AND WHEN IT WILL BE FIXED!
Comment 14 h.westerman 1999-12-19 16:55:59 EST
Just a me too note.
(Tried all weekend...) Just for the record, the same bug exists in
Mandrake 6.1 and Mandrake Cooker. It hangs on the update from
RH 5.0 to 6.1, new install 6.0, new install 6.1, new install
Mandrake 6.1 & new install of mandrake Cooker.

I got most hangs of the FTP installs at about 24 minutes, but it
varies a lot...
Comment 15 Jay Turner 2000-02-04 13:05:59 EST
There is a known problem between some versions of wu-ftp and the python
urllib.py code that is shipped with 6.1.  Try out Rawhide and see if you have
better luck.  We are not able to replicate these problems here in the test lab
unfortunately and actually have not been able to replicate at all, testing here
or from homes or different sights.  Are the FTP servers that you all are pulling
from running wu-ftp?  That might very well be the problem.
Comment 16 Jay Turner 2000-02-21 16:10:59 EST
This issue is resolved in the latest beta.

Note You need to log in before you can comment on or make changes to this bug.