Bug 57125 - Nautilus no longer works after upgrade to 2.4.9-13
Nautilus no longer works after upgrade to 2.4.9-13
Status: CLOSED DUPLICATE of bug 56506
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-05 08:08 EST by Art Fore
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-27 14:53:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Art Fore 2001-12-05 08:08:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After upgrading to 2.4.9-13 kernel and all packages associated with, 
Nautilus 1.0.4.-43 does not work. It worked before upgrade

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select nautilus from applications menu
2.
3.
	

Actual Results:  nothing

Expected Results:  Nautilus should open

Additional info:

Also, start here, home, etc are not displayed on desktop.
Comment 1 Alexander Larsson 2001-12-06 11:36:39 EST
This sounds very strange. I doubt very much that it is related to the kernel.

What happens if you type this in a shell:

nautilus-clean.sh
oaf-slay
killall -9 nautilus
nautilus
Comment 2 Art Fore 2001-12-06 21:05:36 EST
Here are results of your suggestion

nautilus-clean.sh     no staleprocesses found
oaf-slay              no message returned
killall -9 nautilus   nautilus: no process killed
nautilus              Segmentation fault

To go into shell, since all I have is a blank blue screen, I press ctl+alt+f2 
and log in again. (The last time I rebooted, the control panel disappeared.)

Art

Comment 3 Alexander Larsson 2001-12-07 01:48:21 EST
Ok. So it seems that nautilus gives a segmentation fault.

Can you run nautilus in the debugger and give me a backtrace?

Btw. Why do you only have a blank blue screen? Don't you get a panel and the
rest of Gnome?
Comment 4 Art Fore 2001-12-07 07:15:05 EST
The blue screen happened after a reboot. I did have nautilus under root login 
but no control panel. I upgraded to Ximian, then added a new user. Then got 
control panel and nautilus back both in root login and my new login. Old loging 
still did not work.

I do not know how to run debugger.

Art
Comment 5 Alexander Larsson 2001-12-07 11:22:44 EST
If you upgraded to ximian I unfortunately cannot help you with those packages.

But try temporarily renaming ~/.gnome and ~/.nautilus to something else, it
seems like there is some setting in your old login that causes stuff to crash.
Comment 6 Art Fore 2001-12-07 22:48:51 EST
I will just delete the old user name when I figure out how. Have been fighting 
this thing for 4 weeks now and finally have it working quite well with the 
Ximian Gnome desktop. Problems with the RH Gnome and KDE seem to be related to 
the NVidia drivers from what I have found out by reading various user groups at 
Nvidia, and Yahoo/groups/linux-dell-laptops. I will have to say the Ximian 
Redcarpet is a lot easier to use and manage than the RedHat Network though, 
although both are very good.

My biggest complaint about Linux is trying to find information on how to do 
things. Most of the howtos assume you are a unix expert and that I am not.

Thanks for the effort.

Art
Comment 7 Alexander Larsson 2001-12-07 23:29:42 EST
Even worse. Most of the HOWTOs are quite old and while they may possibly still
be accurate in their technical contents, most describe how to do things in a
very lowlevel technical way, while there on normal current distrubutions there
often exists simple GUI apps or setup tools that lets you do what you want in a
few seconds, and those apps are not documented. :(

Oh well. Such is the way in free software. Documentation is scarse...

Remove the user by "/usr/sbin/userdel username", and then you need to remove the
files of the users home-directory.

I'm marking this bug closed.
Comment 8 Art Fore 2001-12-08 19:05:15 EST
Well, the good operation did not last too long. Crashed again today, that is 
Nautilus is no longer operating. Done the things you suggested, still no 
nautilus, comes up with segmentation fault.

I though Linux was supposed to be reliable. I never had this much problem even 
with Windows 3.1.

Comment 9 Alexander Larsson 2001-12-09 01:00:53 EST
Ok. Can you give me a strace of the crash. Run:

strace nautilus &> nautilus.log

Then attach the log to the bugreport.

Also, a backtrace would be nice:

gdb nautilus
<wait for crash>
bt

And then paste in the output in the bugtracker.

Also, what versions of eel and nautilus are you running now?
Comment 10 Art Fore 2001-12-09 08:07:20 EST
Could not copy the log, but opened it in emacs and at the end it had could not 
open display.

when I ran the back trace, it got nothing, then all of a sudden it started with 
the following

EXT3-fs error device IDE0(3,6) ext3 read directory 489633 contains holes at 
offset XXXX. Atempted to access block at end of device
03:06 rw=) want 89792116 limit 7164958. The XXXX keeps increasing up to 
89792116 when it finally stops.

it finally stopped, but could not get out of it, so I had to power down. Now, 
it comes up with damaged file system, and fsck comes back with bad magic number 
in super-block while trying to open /dev/hda6.

This happens with the nautilus in 2.4.7-10 and 2.4.9-13. Can't get the version #

Art
Comment 11 Art Fore 2001-12-09 12:26:34 EST
Reinstalled 7.2, second time I rebooted, control panel crashed. Report is below.
Rebooted again, control panel is there but no nautilus. This time I formated 
the partitians outside of RH with EXT2 format and let RH only modify format to 
EXT3 per bug # 56124 comment from person with IBM laptop.

Ran the nautil clean again with results below

+nautilus-clean.sh     no staleprocesses found
+oaf-slay              no message returned
+killall -9 nautilus   nautilus: no process killed
+nautilus              Segmentation fault

Tried to find the files per suggestion try temporarily renaming ~/.gnome and 
~/.nautilus but could not find them.

Control panel crash log:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x405aa669 in __wait4 () from /lib/i686/libc.so.6
#0  0x405aa669 in __wait4 () from /lib/i686/libc.so.6
#1  0x40626154 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40156e88 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#3  <signal handler called>
#4  0x08083810 in get_default_menu_flags () at eval.c:41
#5  0x08068076 in load_up_globals () at eval.c:41
#6  0x0805eca7 in main () at eval.c:41
#7  0x4050c507 in __libc_start_main (main=0x805ea10 <main>, argc=3, 
    ubp_av=0xbffffc44, init=0x8056b50 <_init>, fini=0x80ab690 <_fini>, 
    rtld_fini=0x4000dc14 <_dl_fini>, stack_end=0xbffffc3c)
    at ../sysdeps/generic/libc-start.c:129
#0  0x405aa669 in __wait4 () from /lib/i686/libc.so.6
No locals.
#1  0x40626154 in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x40156e88 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
No symbol table info available.
#3  <signal handler called>
No locals.
#4  0x08083810 in get_default_menu_flags () at eval.c:41
	in eval.c
ap = (void **) 0x0
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
p = 0x0
result = 0
result = 0
#5  0x08068076 in load_up_globals () at eval.c:41
41	in eval.c
ap = (void **) 0x0
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
p = 0x0
result = 0
result = 0
#6  0x0805eca7 in main () at eval.c:41
41	in eval.c
ap = (void **) 0xbffffc44
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
p = 0x80c16c0 " \236\013\b\016"
result = 3221224516
result = 135009984
#7  0x4050c507 in __libc_start_main (main=0x805ea10 <main>, argc=3, 
    ubp_av=0xbffffc44, init=0x8056b50 <_init>, fini=0x80ab690 <_fini>, 
    rtld_fini=0x4000dc14 <_dl_fini>, stack_end=0xbffffc3c)
    at ../sysdeps/generic/libc-start.c:129
	in ../sysdeps/generic/libc-start.c
ubp_av = (char **) 0xbffffc44
fini = (void (*)()) 0x400168e4 <_dl_debug_mask>
rtld_fini = (void (*)()) 0xbffff850
ubp_ev = (char **) 0xbffffc54
Comment 12 Art Fore 2001-12-09 20:53:44 EST
Reinstall again, for about the 50th time. Below are some messages that may help 
locate the problem. Seems to me that Nautilus gets confused sometime.

This time I unchecked the "use Nautilus to draw desktop" box in the nautilus 
preferences per a message I read on Bugzilla. When I rebooted, I got a Desk 
Gnome Alert  GNOME Distop guide you are not running a Gnome window manager. 
GNOME  Window manager is strongly _____ for proper destop guide.

Rebooted several times, everything fine.

Installed OpenOffice 641 with the "use Nautilus to draw desktop" box unchecked. 
Did not crash. (This is where it would always crash before). Played with Open 
Office, rebooted several times, everything seemed to be OK. Check the "use 
Nautilus to draw desktop" box again and rebooted a few times, everything seemed 
OK.

I have a USB harddrive, so I tried to use Nautilus to copy some files 
to /usr/src. (These are files that I backed up so I would not have to download 
them again. It came up with access denied, so I opened a terminal window and 
logged on as superuser. Typed nautilus  at the command line, it came up with 
the following

GNOMEUE-WARNING **: While connecting to session manager : Authentication 
rejected, reason : None of the authentication protocols specified are supported 
and host-based authentication failed.
Message : Successfully registered "OAFID : nautilus-factory : bd1e1862-9247-
4391-963 e-3758340daef3"
Message : Successfully registered "OAF1D : Bonobo_Moniker_std_factory"
GTK : error **: Bad Pixmap (Invalid Pixmap parameter)
serial 8352 error-code 4 request_code 2 minor_code 0
**WARNING ** : 2 scalable icons still left when destroying icon factory.

Nautilus opened, the promptly closed again, so I copied the files via comand 
line in the terminal.

When I tried to unmount the usbhd, I got the following message.

Nautilus was unable to unmount the selected volume.

I click the details, and get
umount /mnt/usbhd device busy.  (It was not busy)

When I rebooted, the following line took about a minuted or so to complete

md: md recoveryd(9) flushing signals.

Finally, it comes up with SCSI device shutddown. Did not get complete message 
for it rebooted.

I unchecked the "use Nautilus to draw desktop" box  and rebooted again, came up 
with the same as mentioned above. 


Art
Comment 13 Alexander Larsson 2001-12-10 11:35:13 EST
Wow. It's kind of hard to reply to this. There's like a dozen or so problems
reported in it :(

Some of the things you say makes me believe you are logged in as a user, but
trying to run things as another user (root?). This seems to be the cause of
nautilus not starting for instance, since it can't open the display owned by the
other user.

The filesystem thing looks really bad (tm), but i don't know anything about
that. If you manage to reproduce it, please file a new bug so someone else can
look at that.

The panel crash looks really strange, I'm looking at the code but it seems to do
nothing that would cause a segfault. Does it crash at the same place every time?

The "busy" in the unmount is because a file was open on the filesystem. Most
probably because some process had the usb stuff as it's current working
directory. You have to cd somewhere else before you are able to unmount it. 

It is strange that the md line took one minute to run, since i assume you don't
run RAID? (md is the raid driver.) It was probably some timeout due to the usb
unmount or something.

Are you sure you don't have any problems with bad memory? Some of the problems,
especially the filesystems ones makes me a bit suspicious. Can you try running
http://www.teresaudio.com/memtest86/ and see if it reports any problem?
Comment 14 Alexander Larsson 2001-12-10 11:48:34 EST
Btw. Do you have a laptop?

There is a known bug that makes the panel crash the first login on laptops,
because it segfaults when reading /proc/apm.
Comment 15 Art Fore 2001-12-10 13:28:32 EST
Yes, it is a Dell Inspiron 8100. Also ran memtest, no problems there.

Art
Comment 16 Art Fore 2001-12-10 16:30:05 EST
I forgot to ask, what is solution for this bug in Nautilus, or maybe the 
workaround until it gets fixed.

Art
Comment 17 Alexander Larsson 2001-12-10 16:50:04 EST
I still have no idea what causes the problem or how to solve it. Given the
multitude of problems you're seeing I suspect it is not actually nautilus that
is the core problem.

Is natuilus the only app that gives you problems?
Comment 18 Art Fore 2001-12-10 17:56:24 EST
It is always nautilus goes away and you cannot get it to start again or the 
control panel goes away or both. This always occured after loading OpenOffice 
or some other application. The only difference I did this last time was to have 
the "use nautilus to draw desktop" box checked. I rebooted several times, and 
everything seemed to work except nautilus was not drawing the desktop. This is 
with 2.4.7-10 kernel by the way. Have to upgrade the kernel to 2.4.9-13 to 
check that out yet. Used to after loading OpenOffice, two reboots and it was 
gone conistently.

Art
Comment 19 Alexander Larsson 2001-12-11 12:14:03 EST
If i am to debug this in any way you need to send me the backtrace and the
strace of the crashing nautilus. I can't just guess what happens, and I can't
reproduce it here.
Comment 20 Emmanuel Kowalski 2001-12-13 13:04:54 EST
I have run into the same kind of problem here since yesterday. I have RH 7.2
running fine on an IBM Thinkpad, and I installed it on a Dell Dimension 4100
two days ago. The first day there was no problem at all, yesterday the panel
didn't work when starting gnome, I upgraded glibc which seemed to make it
work again consistently (the panel), and today nautilus started misbehaving
(was OK before, is OK on the Thinkpad, which I actually use much more than
the DELL).

I have played with removing the preferences a number of times without getting
Nautilus to start working again, except it did once after upgrading the kernel
and rebooting, but just once and after that got back to its segfaults.

I did the steps described in the previous messages : the nautilus-clean.sh,
oaf-slay, killall, etc worked as above. 

I strace'd the segfault a number of times; it seems to stop consistently
at the same point. I also used gdb but the backtrace is very short. See below
from the strace and the backtrace.

     Emmanuel Kowalski
     egkowal@attglobal.net

---------------------------- strace -------------------------------

execve("/usr/bin/nautilus", ["nautilus"], [/* 29 vars */]) = 0
uname({sys="Linux", node="zinfandel.frog-parrot.net", ...}) = 0
brk(0)                                  = 0x80cc478
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40017000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=38079, ...}) = 0
old_mmap(NULL, 38079, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40018000
close(3)                                = 0
open("/usr/lib/libnautilus.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220`\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=624933, ...}) = 0
old_mmap(NULL, 80476, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40022000
mprotect(0x40034000, 6748, PROT_NONE)   = 0
old_mmap(0x40034000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x11000) = 0x40034000
close(3)                                = 0
open("/lib/i686/libm.so.6", O_RDONLY)   = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\320H\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=624962, ...}) = 0
old_mmap(NULL, 142580, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40036000
mprotect(0x40058000, 3316, PROT_NONE)   = 0
old_mmap(0x40058000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x21000) = 0x40058000
close(3)                                = 0
open("/lib/libdl.so.2", O_RDONLY)       = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\36\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=65997, ...}) = 0
old_mmap(NULL, 12756, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40059000
mprotect(0x4005c000, 468, PROT_NONE)    = 0
old_mmap(0x4005c000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x2000) = 0x4005c000
close(3)                                = 0
open("/usr/X11R6/lib/libXi.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300\23"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=28584, ...}) = 0
old_mmap(NULL, 30912, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4005d000
mprotect(0x40064000, 2240, PROT_NONE)   = 0
old_mmap(0x40064000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x6000) = 0x40064000
close(3)                                = 0
open("/usr/X11R6/lib/libXext.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0)\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=51632, ...}) = 0
old_mmap(NULL, 54492, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40065000
mprotect(0x40071000, 5340, PROT_NONE)   = 0
old_mmap(0x40071000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xb000) = 0x40071000
close(3)                                = 0
open("/usr/X11R6/lib/libX11.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20E\1\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=911288, ...}) = 0
old_mmap(NULL, 907320, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40073000
mprotect(0x4014c000, 18488, PROT_NONE)  = 0
old_mmap(0x4014c000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xd8000) = 0x4014c000
close(3)                                = 0
open("/usr/lib/libz.so.1", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\31\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=59618, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40151000
old_mmap(NULL, 54824, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40152000
mprotect(0x4015e000, 5672, PROT_NONE)   = 0
old_mmap(0x4015e000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xb000) = 0x4015e000
close(3)                                = 0
open("/usr/lib/libORBitCosNaming.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P(\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=30228, ...}) = 0
old_mmap(NULL, 33236, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40160000
mprotect(0x40167000, 4564, PROT_NONE)   = 0
old_mmap(0x40167000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x6000) = 0x40167000
close(3)                                = 0
open("/usr/lib/libORBit.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\333\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=279492, ...}) = 0
old_mmap(NULL, 282504, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40169000
mprotect(0x401ab000, 12168, PROT_NONE)  = 0
old_mmap(0x401ab000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x41000) = 0x401ab000
close(3)                                = 0
open("/usr/lib/libIIOP.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0009\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=49784, ...}) = 0
old_mmap(NULL, 57092, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401ae000
mprotect(0x401ba000, 7940, PROT_NONE)   = 0
old_mmap(0x401ba000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xb000) = 0x401ba000
old_mmap(0x401bb000, 3844, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x401bb000
close(3)                                = 0
open("/usr/lib/libORBitutil.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 \10\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=4416, ...}) = 0
old_mmap(NULL, 7424, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401bc000
mprotect(0x401bd000, 3328, PROT_NONE)   = 0
old_mmap(0x401bd000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3, 0) =
0x401bd000
close(3)                                = 0
open("/lib/libnsl.so.1", O_RDONLY)      = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20?\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=436384, ...}) = 0
old_mmap(NULL, 89596, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401be000
mprotect(0x401d1000, 11772, PROT_NONE)  = 0
old_mmap(0x401d1000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x12000) = 0x401d1000
old_mmap(0x401d2000, 7676, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x401d2000
close(3)                                = 0
open("/usr/lib/libaudiofile.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000y\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=141828, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x401d4000
old_mmap(NULL, 121204, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401d5000
mprotect(0x401f0000, 10612, PROT_NONE)  = 0
old_mmap(0x401f0000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1a000) = 0x401f0000
close(3)                                = 0
open("/usr/lib/libnautilus-adapter.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 \22\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=145540, ...}) = 0
old_mmap(NULL, 11520, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401f3000
mprotect(0x401f5000, 3328, PROT_NONE)   = 0
old_mmap(0x401f5000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1000) = 0x401f5000
close(3)                                = 0
open("/usr/lib/libnautilus-private.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240\364"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=2551075, ...}) = 0
old_mmap(NULL, 653248, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x401f6000
mprotect(0x40291000, 18368, PROT_NONE)  = 0
old_mmap(0x40291000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x9a000) = 0x40291000
close(3)                                = 0
open("/usr/lib/libjpeg.so.62", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220$\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=140522, ...}) = 0
old_mmap(NULL, 124032, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40296000
mprotect(0x402b4000, 1152, PROT_NONE)   = 0
old_mmap(0x402b4000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1d000) = 0x402b4000
close(3)                                = 0
open("/usr/lib/libfam.so.0", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0S\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=232338, ...}) = 0
old_mmap(NULL, 70652, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x402b5000
mprotect(0x402c4000, 9212, PROT_NONE)   = 0
old_mmap(0x402c4000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xe000) = 0x402c4000
close(3)                                = 0
open("/usr/lib/libbonobo.so.2", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000z\1\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=499885, ...}) = 0
old_mmap(NULL, 399096, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x402c7000
mprotect(0x40323000, 22264, PROT_NONE)  = 0
old_mmap(0x40323000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x5b000) = 0x40323000
close(3)                                = 0
open("/usr/lib/libbonobox.so.2", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000@\1\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=431711, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40329000
old_mmap(NULL, 357072, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4032a000
mprotect(0x4037f000, 8912, PROT_NONE)   = 0
old_mmap(0x4037f000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x54000) = 0x4037f000
close(3)                                = 0
open("/usr/lib/libbonobo-print.so.2", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000\24\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=15817, ...}) = 0
old_mmap(NULL, 14348, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40382000
mprotect(0x40385000, 2060, PROT_NONE)   = 0
old_mmap(0x40385000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x2000) = 0x40385000
close(3)                                = 0
open("/usr/lib/libgnomeprint.so.15", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0006\1"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=532125, ...}) = 0
old_mmap(NULL, 466440, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40386000
mprotect(0x403f1000, 28168, PROT_NONE)  = 0
old_mmap(0x403f1000, 28672, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x6a000) = 0x403f1000
close(3)                                = 0
open("/usr/lib/libgnomecanvaspixbuf.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340\16"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=16640, ...}) = 0
old_mmap(NULL, 15740, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x403f8000
mprotect(0x403fb000, 3452, PROT_NONE)   = 0
old_mmap(0x403fb000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x2000) = 0x403fb000
close(3)                                = 0
open("/usr/lib/libeel.so.0", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\v\2\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=1076814, ...}) = 0
old_mmap(NULL, 925424, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x403fc000
mprotect(0x404da000, 16112, PROT_NONE)  = 0
old_mmap(0x404da000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xdd000) = 0x404da000
close(3)                                = 0
open("/usr/lib/libgnomeui.so.32", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\345\1"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=987674, ...}) = 0
old_mmap(NULL, 862596, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x404de000
mprotect(0x405ab000, 22916, PROT_NONE)  = 0
old_mmap(0x405ab000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xcc000) = 0x405ab000
close(3)                                = 0
open("/usr/lib/libgdk_imlib.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260<\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=157643, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x405b1000
old_mmap(NULL, 145764, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x405b2000
mprotect(0x405d5000, 2404, PROT_NONE)   = 0
old_mmap(0x405d5000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x22000) = 0x405d5000
close(3)                                = 0
open("/usr/X11R6/lib/libSM.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 !\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=31544, ...}) = 0
old_mmap(NULL, 34344, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x405d6000
mprotect(0x405dd000, 5672, PROT_NONE)   = 0
old_mmap(0x405dd000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x6000) = 0x405dd000
close(3)                                = 0
open("/usr/X11R6/lib/libICE.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0205\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=82080, ...}) = 0
old_mmap(NULL, 91952, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x405df000
mprotect(0x405f3000, 10032, PROT_NONE)  = 0
old_mmap(0x405f3000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x13000) = 0x405f3000
old_mmap(0x405f4000, 5936, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x405f4000
close(3)                                = 0
open("/usr/lib/libgnome.so.32", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360X\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=114533, ...}) = 0
old_mmap(NULL, 95024, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x405f6000
mprotect(0x4060c000, 4912, PROT_NONE)   = 0
old_mmap(0x4060c000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x15000) = 0x4060c000
close(3)                                = 0
open("/usr/lib/libgnomesupport.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\20"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=22073, ...}) = 0
old_mmap(NULL, 20212, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4060e000
mprotect(0x40612000, 3828, PROT_NONE)   = 0
old_mmap(0x40612000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x3000) = 0x40612000
close(3)                                = 0
open("/usr/lib/libesd.so.0", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\35\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=31549, ...}) = 0
old_mmap(NULL, 27992, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40613000
mprotect(0x40619000, 3416, PROT_NONE)   = 0
old_mmap(0x40619000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x5000) = 0x40619000
close(3)                                = 0
open("/usr/lib/libdb.so.2", O_RDONLY)   = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0`\23\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=63780, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4061a000
old_mmap(NULL, 56024, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4061b000
mprotect(0x40628000, 2776, PROT_NONE)   = 0
old_mmap(0x40628000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xc000) = 0x40628000
close(3)                                = 0
open("/usr/lib/libgdk_pixbuf.so.2", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340>\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=89246, ...}) = 0
old_mmap(NULL, 80952, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40629000
mprotect(0x4063a000, 11320, PROT_NONE)  = 0
old_mmap(0x4063a000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x10000) = 0x4063a000
close(3)                                = 0
open("/usr/lib/libgnomevfs.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0 \226\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=214453, ...}) = 0
old_mmap(NULL, 175616, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4063d000
mprotect(0x40666000, 7680, PROT_NONE)   = 0
old_mmap(0x40666000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x28000) = 0x40666000
close(3)                                = 0
open("/usr/lib/libxml.so.1", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220\321"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=498438, ...}) = 0
old_mmap(NULL, 467872, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40668000
mprotect(0x406d7000, 13216, PROT_NONE)  = 0
old_mmap(0x406d7000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x6e000) = 0x406d7000
close(3)                                = 0
open("/usr/lib/libgconf-gtk-1.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\200%\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=29957, ...}) = 0
old_mmap(NULL, 24832, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x406db000
mprotect(0x406e0000, 4352, PROT_NONE)   = 0
old_mmap(0x406e0000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x4000) = 0x406e0000
close(3)                                = 0
open("/usr/lib/libgconf-1.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360\223"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=250502, ...}) = 0
old_mmap(NULL, 219340, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x406e2000
mprotect(0x40716000, 6348, PROT_NONE)   = 0
old_mmap(0x40716000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x33000) = 0x40716000
close(3)                                = 0
open("/usr/lib/liboaf.so.0", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300n\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=122729, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40718000
old_mmap(NULL, 99488, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40719000
mprotect(0x4072f000, 9376, PROT_NONE)   = 0
old_mmap(0x4072f000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x15000) = 0x4072f000
close(3)                                = 0
open("/usr/lib/libpopt.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220\21"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=29472, ...}) = 0
old_mmap(NULL, 27228, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40732000
mprotect(0x40738000, 2652, PROT_NONE)   = 0
old_mmap(0x40738000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x5000) = 0x40738000
close(3)                                = 0
open("/usr/lib/libgtk-1.2.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240\34"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=1410453, ...}) = 0
old_mmap(NULL, 1236580, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40739000
mprotect(0x4085f000, 32356, PROT_NONE)  = 0
old_mmap(0x4085f000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x125000) = 0x4085f000
close(3)                                = 0
open("/usr/lib/libgdk-1.2.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\241"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=252878, ...}) = 0
old_mmap(NULL, 217204, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40867000
mprotect(0x4089b000, 4212, PROT_NONE)   = 0
old_mmap(0x4089b000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x33000) = 0x4089b000
old_mmap(0x4089c000, 116, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4089c000
close(3)                     = 0
open("/usr/lib/libgmodule-1.2.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\v\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0644, st_size=11931, ...}) = 0
old_mmap(NULL, 11660, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4089d000
mprotect(0x4089f000, 3468, PROT_NONE)   = 0
old_mmap(0x4089f000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1000) = 0x4089f000
close(3)                                = 0
open("/usr/lib/libgthread-1.2.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\f\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=11170, ...}) = 0
old_mmap(NULL, 10620, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408a0000
mprotect(0x408a2000, 2428, PROT_NONE)   = 0
old_mmap(0x408a2000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1000) = 0x408a2000
close(3)                                = 0
open("/usr/lib/libglib-1.2.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300b\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=182363, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x408a3000
old_mmap(NULL, 146768, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408a4000
mprotect(0x408c7000, 3408, PROT_NONE)   = 0
old_mmap(0x408c7000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x22000) = 0x408c7000
close(3)                                = 0
open("/lib/i686/libpthread.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240P\0"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=531205, ...}) = 0
old_mmap(NULL, 85108, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408c8000
mprotect(0x408d5000, 31860, PROT_NONE)  = 0
old_mmap(0x408d5000, 32768, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xc000) = 0x408d5000
close(3)                                = 0
open("/usr/lib/librsvg.so.1", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@(\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=65913, ...}) = 0
old_mmap(NULL, 56444, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408dd000
mprotect(0x408ea000, 3196, PROT_NONE)   = 0
old_mmap(0x408ea000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xc000) = 0x408ea000
close(3)                                = 0
open("/usr/lib/libart_lgpl.so.2", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@\34\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=67879, ...}) = 0
old_mmap(NULL, 60372, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408eb000
mprotect(0x408f9000, 3028, PROT_NONE)   = 0
old_mmap(0x408f9000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0xd000) = 0x408f9000
close(3)                                = 0
open("/usr/lib/libfreetype.so.6", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0Pc\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=235270, ...}) = 0
old_mmap(NULL, 209644, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x408fa000
mprotect(0x4092a000, 13036, PROT_NONE)  = 0
old_mmap(0x4092a000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x2f000) = 0x4092a000
close(3)                                = 0
open("/usr/lib/libpng.so.2", O_RDONLY)  = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0PU\0\000"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=131560, ...}) = 0
old_mmap(NULL, 134568, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4092e000
mprotect(0x4094e000, 3496, PROT_NONE)   = 0
old_mmap(0x4094e000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x1f000) = 0x4094e000
close(3)                                = 0
open("/lib/i686/libc.so.6", O_RDONLY)   = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0@\307\1"..., 1024) = 1024
fstat64(3, {st_mode=S_IFREG|0755, st_size=5780406, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4094f000
old_mmap(NULL, 1291080, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40950000
mprotect(0x40a82000, 37704, PROT_NONE)  = 0
old_mmap(0x40a82000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x131000) = 0x40a82000
old_mmap(0x40a88000, 13128, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40a88000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40a8c000
munmap(0x40018000, 38079)               = 0
modify_ldt(0x1, 0xbffff9dc, 0x10)       = 0
getpid()                                = 1610
rt_sigaction(SIGRT_0, {0x408d1500, [], 0x4000000}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0x408d08b0, [], 0x4000000}, NULL, 8) = 0
rt_sigaction(SIGRT_2, {0x408d1550, [], 0x4000000}, NULL, 8) = 0
rt_sigprocmask(SIG_BLOCK, [32], NULL, 8) = 0
_sysctl({{CTL_KERN, KERN_VERSION}, 2, 0xbffff68c, 31, (nil), 0}) = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++


---------------------------- backtrace ----------------------------

[root@zinfandel root]# gdb nautilus
GNU gdb Red Hat Linux (5.1-1)
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/bin/nautilus 
[New Thread 1024 (LWP 1614)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 1614)]
0x08070cfa in main ()
(gdb) bt
#0  0x08070cfa in main ()
#1  0xbffffa7c in ?? ()
(gdb) 

----------------- some package versions -------------------------------

gnome-audio-extra-1.0.0-12
gnome-core-devel-1.4.0.4-38
gnome-libs-1.2.13-16
gnome-vfs-extras-0.1.3-1
gnome-audio-1.0.0-12
pygnome-1.4.1-3
pygnome-libglade-1.4.1-3
gdk-pixbuf-gnome-0.11.0-8
gnome-pim-1.2.0-13
libgnomeprint15-0.29-6
rep-gtk-gnome-0.15-6
switchdesk-gnome-3.9.7-1
openssh-askpass-gnome-2.9p2-11
gnome-applets-1.4.0.1-6
gnome-vfs-1.0.1-17
gnome-print-0.29-6
gnome-libs-devel-1.2.13-16
ethereal-gnome-0.8.18-9
gnome-user-docs-1.4.1-1
xmms-gnome-1.2.5-7
gnome-core-1.4.0.4-38
gnome-utils-1.4.0-4
gnome-media-1.2.3-4
nautilus-mozilla-1.0.4-43
nautilus-1.0.4-43
glibc-common-2.2.4-19
glibc-devel-2.2.4-19
glibc-2.2.4-19
kernel-doc-2.4.9-13
kernel-2.4.9-13
kernel-headers-2.4.9-13

---------------- uname -------------------------------
Linux zinfandel.frog-parrot.net 2.4.9-13 #1 Tue Oct 30 20:11:04 EST 2001 i686
unknown
Comment 21 Ed Halley 2002-02-19 22:17:49 EST
I will attach (rpm -q)s, (strace)s and (gdb nautilus)s later tonight as well. 
My system is a brand new fresh virgin install of 7.2 Enigma, and I ran (up2date
-u --nox) on all packages except kernel* immediately, even before logging into a
regular user account for the first time.  After stracing and gdb'ing, I will
upgrade kernel also, then retry Nautilus.

When logging into user account, I get no Nautilus-as-desktop, no response from
Start Here.  When run from a terminal, nautilus responds with "Segmentation
fault".  Running (nautilus --help) gives help, but all other attempts crash.
Comment 22 Havoc Pennington 2002-02-27 14:53:34 EST
Based on the strace, it's dying in libc before it even hits Nautilus main() -
several other "nautilus crashes on start" reports indicate the same thing.
Comment 23 Havoc Pennington 2002-02-27 14:59:09 EST
#57698 has a similar backtrace, things die prior to main().

I'm putting all these as dups of #56506 because in all those cases Nautilus
fails after fresh install, and it seems to be a function of the hardware (only
happens on a particular machine, but reproduceable on that machine).

*** This bug has been marked as a duplicate of 56506 ***

Note You need to log in before you can comment on or make changes to this bug.