Bug 571727 - python-meh makes the user click 'exit installer' twice
python-meh makes the user click 'exit installer' twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target 569071 571861
  Show dependency treegraph
 
Reported: 2010-03-09 05:50 EST by Ales Kozumplik
Modified: 2014-09-30 19:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-meh-0.7.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 569071
Environment:
Last Closed: 2010-06-24 12:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (1.40 KB, patch)
2010-03-09 05:53 EST, Ales Kozumplik
no flags Details | Diff

  None (edit)
Description Ales Kozumplik 2010-03-09 05:50:46 EST
+++ This bug was initially created as a clone of Bug #569071 +++

Why do I need to click "Exit installer" again?

Of course I did ... and immediately got a black screen.

Also, it says the "error file" was "written", even though I uploaded it to Bugzilla.

--- Additional comment from hdegoede@redhat.com on 2010-03-01 05:21:32 EST ---

Steve,

May I summarize this bug with "System does not reboot after clicking exit installer after an exception" ?

Ales,

I think this is a reboot issue (see above), since you last worked on the reboot
code I'm assigning this to you.

Regards,

Hans
Comment 1 Ales Kozumplik 2010-03-09 05:53:41 EST
Created attachment 398767 [details]
proposed fix
Comment 2 Ales Kozumplik 2010-03-09 05:56:38 EST
Chris,

this is one of the two problems with #569071. Attached a fix, tested. If you ack it, I can push it too.

Ales
Comment 3 Chris Lumens 2010-03-09 09:04:23 EST
Ales - looks fine, but make sure you push it to f13-branch.  This code no longer exists in master.  Go ahead and push it, and I'll reassign this bug for you to close when you do.  Thanks for the patch.
Comment 4 Ales Kozumplik 2010-03-09 12:36:07 EST
I just learned that we are nearing beta test compose with F13 so I will only push this if it's still a beta blocker after the blocker review.
Comment 5 James Laska 2010-03-09 12:57:19 EST
Is this the same request as bug#568374?
Comment 6 Ales Kozumplik 2010-03-09 13:09:43 EST
Yes, it is the exact same issue.
Comment 7 Ales Kozumplik 2010-03-12 04:10:16 EST
Chris, I've just tried to push this but I don't have the write access:

error: unable to create temporary sha1 filename ./objects/tmp_obj_gT2A3s: Permission denied

fatal: failed to write object
error: unpack failed: unpacker exited with error code
To ssh://git.fedorahosted.org/git/python-meh.git
 ! [remote rejected] f13-branch -> f13-branch (n/a (unpacker error))
error: failed to push some refs to 'ssh://git.fedorahosted.org/git/python-meh.git'
Comment 8 Chris Lumens 2010-03-12 09:48:08 EST
Ales - I've just added you to the gitpython-meh group, so you should be able to commit now.  I'm not sure whether that database takes some time to sync up or not so if your commit still fails, wait a while longer and try it again.
Comment 9 Ales Kozumplik 2010-03-15 08:23:55 EDT
Fixed by 5256ade365802c8f7df051702f673e28a40080af, to be part of python-meh-0.8.
Comment 10 Fedora Update System 2010-03-24 11:00:18 EDT
python-meh-0.7.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-meh-0.7.1-1.fc13
Comment 11 Fedora Update System 2010-03-25 18:30:48 EDT
python-meh-0.7.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-meh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-meh-0.7.1-1.fc13
Comment 12 James Laska 2010-04-16 16:39:55 EDT
Discussed at F13Blocker meeting.  This is a welcome change to the traceback handling dialogs, but wouldn't be something to hold the F-13 release for.  Move to the F13Target (nice to have) list.
Comment 13 Fedora Update System 2010-06-24 12:20:05 EDT
python-meh-0.7.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.