Bug 569071 - exception reporting terminates with black display
exception reporting terminates with black display
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On: 571727
Blocks: F13Blocker/F13FinalBlocker 571861
  Show dependency treegraph
 
Reported: 2010-02-27 17:08 EST by Steve Tyler
Modified: 2014-09-30 19:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.35-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 571727 571861 (view as bug list)
Environment:
Last Closed: 2010-03-22 22:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing "an unhandled exception has occurred" and python backtrace (106.33 KB, image/png)
2010-02-27 17:08 EST, Steve Tyler
no flags Details
screenshot showing save to local disk dialog (84.04 KB, image/png)
2010-02-27 17:22 EST, Steve Tyler
no flags Details
screenshot showing Bugzilla login dialog (89.06 KB, image/png)
2010-02-27 17:28 EST, Steve Tyler
no flags Details
screenshot showing bug sent dialog (92.08 KB, image/png)
2010-02-27 17:35 EST, Steve Tyler
no flags Details
screenshot showing dump written dialog (90.70 KB, image/png)
2010-02-27 17:42 EST, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2010-02-27 17:08:52 EST
Created attachment 396796 [details]
screenshot showing "an unhandled exception has occurred" and python backtrace

Description of problem:
Just after attempting to save a custom disk layout, the installer popped up a dialog announcing that "an unhandled exception has occurred". At the end of the reporting process, I clicked "Exit installer", after which the display was black except for a functional pointer. The consoles worked, and I had to reboot from a console.

Version-Release number of selected component (if applicable):
http://serverbeach1.fedoraproject.org/pub/alt/stage/13-Alpha.RC4/Fedora/x86_64/iso/Fedora-13-Alpha-x86_64-netinst.iso

How reproducible:
Twice now:
1. live ISO on a USB stick (Bug 568556).
2. netinst.iso on a CDRW.

Steps to Reproduce:
Bug 568556
The second time, I actually was configuring two partitions and a logical volume.
  
Actual results:
Bug 568556

Expected results:
Bug 568556

Additional info:
Bug 568814 - live install exceptions include /tmp/syslog, but /var/log/dmesg should be used instead
Bug 569057 - DiskLabelCommitError: Could not commit to disk /dev/sdb5
Comment 1 Steve Tyler 2010-02-27 17:22:30 EST
Created attachment 396798 [details]
screenshot showing save to local disk dialog

Wouldn't the local disk be ram disk? (I didn't investigate this path further ... chose the Bugzilla option)
The installer corrupted the disk partition I would have preferred to save to -- it couldn't be mounted from a console. I found another partition to mount and save the screenshots to. The installer environment does not appear to create logical volume devices (/dev/mapper is empty except for "control"). If my entire disk were configured as a volume group, there would not be anywhere to save. Maybe a USB stick?

Same message when booted into F12:
[root@walnut mnt]# mkdir foo
[root@walnut mnt]# mount /dev/sdb5 foo
mount: you must specify the filesystem type
[root@walnut mnt]# mount -t ext4 /dev/sdb5 foo
mount: wrong fs type, bad option, bad superblock on /dev/sdb5,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

[root@walnut mnt]# fdisk -l /dev/sdb

Disk /dev/sdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xff3d5e55

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14        4418    35383162+  8e  Linux LVM
/dev/sdb3   *        4419        4483      522112+  83  Linux
/dev/sdb4            4484        4865     3068415    f  W95 Ext'd (LBA)
/dev/sdb5            4484        4865     3068383+  83  Linux
[root@walnut mnt]#
Comment 2 Steve Tyler 2010-02-27 17:28:12 EST
Created attachment 396800 [details]
screenshot showing Bugzilla login dialog

My password is 16 random alphanumeric characters -- I do not have it memorized. I have put in a text file. That text file is on a logical volume, which could not be mounted. Fortunately, I have a copy on my laptop so I typed it in instead of using copy/paste. There is no way to make the password visible in this dialog.

Example password from gnome-password-generator: xLkxi0Ss6fZCuMoH
Comment 3 Steve Tyler 2010-02-27 17:35:27 EST
Created attachment 396801 [details]
screenshot showing bug sent dialog

[Skipped over a few screenshots ...]

Am I supposed write that number down? (rhetorical)
Clicked "Exit installer".
Comment 4 Steve Tyler 2010-02-27 17:42:13 EST
Created attachment 396802 [details]
screenshot showing dump written dialog

Why do I need to click "Exit installer" again?

Of course I did ... and immediately got a black screen.

Also, it says the "error file" was "written", even though I uploaded it to Bugzilla.
Comment 5 Hans de Goede 2010-03-01 05:21:32 EST
Steve,

May I summarize this bug with "System does not reboot after clicking exit installer after an exception" ?

Ales,

I think this is a reboot issue (see above), since you last worked on the reboot
code I'm assigning this to you.

Regards,

Hans
Comment 6 Ales Kozumplik 2010-03-09 05:59:39 EST
This is actually two different problems:

1) having to press 'exit installer' twice, for that see 571727.
2) anaconda does not reboot when it should. I will track progress on that one in this bug.
Comment 7 Steve Tyler 2010-03-09 06:48:40 EST
(In reply to comment #6)
> This is actually two different problems:

OK. I turned this bug into a commentary on the exception handling feature generally, and it seemed like it be would easier to step through the screenshots all in one bug.

> 1) having to press 'exit installer' twice, for that see 571727.

Thanks. I am CCed on Bug 571727 (FYI, BZ will auto-generate bug links with the syntax "Bug NNNNNN").

> 2) anaconda does not reboot when it should. I will track progress on that one
> in this bug.    

Thanks.
Comment 8 Ales Kozumplik 2010-03-09 07:45:39 EST
I verified that the black screen and text "press cad to reboot" on tty1 is behavior identical to F12, so this is not a regression. Question is whether this should be remedied and how. Will talk to python-meh experts.
Comment 9 Ales Kozumplik 2010-03-09 07:46:09 EST
> Thanks. I am CCed on Bug 571727 (FYI, BZ will auto-generate bug links with the
> syntax "Bug NNNNNN").

Yeah, thanks. I always forget.
Comment 10 Ales Kozumplik 2010-03-09 13:04:19 EST
For the F13, we'll have to wait to see if the next blocker meeting retains this bug as a F13Blocker and either push or close this as fixed rawhide.
Comment 11 Steve Tyler 2010-03-09 13:56:33 EST
(In reply to comment #10)
> For the F13, we'll have to wait to see if the next blocker meeting retains this
> bug as a F13Blocker and either push or close this as fixed rawhide.    

Thanks, Ales!

http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=17eabf5237837885d17afd89a9154e5bec637eba
Comment 12 Ales Kozumplik 2010-03-12 03:58:48 EST
committed to the f13 branch: d1b18653de068e78d59f20a7772ef7fadd60dd17, will be released with anaconda-13.34.

Ales
Comment 13 Fedora Update System 2010-03-18 13:12:41 EDT
anaconda-13.35-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.35-1.fc13
Comment 14 Fedora Update System 2010-03-22 22:25:45 EDT
anaconda-13.35-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.