Bug 571793 - [abrt] crash in blender-2.49b-5.fc12: Process /usr/bin/blender.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in blender-2.49b-5.fc12: Process /usr/bin/blender.bin was killed...
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:730538bec5d741489f830186e6f...
Keywords:
: 584456 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-09 15:04 UTC by Roger Cowles
Modified: 2010-12-03 17:39 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-03 17:39:50 UTC


Attachments (Terms of Use)
File: backtrace (21.64 KB, text/plain)
2010-03-09 15:04 UTC, Roger Cowles
no flags Details

Description Roger Cowles 2010-03-09 15:04:39 UTC
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/blender.bin
comment: I had been getting this crash earlier but from a post on the yafaray boards was able to work around it by running qtconfig-qt4 and setting the QT window style to Plastique, however, that no longer appears to work maybe due to an update to the QT4 packages that recently came along for Fedora 12 ?
component: blender
executable: /usr/bin/blender.bin
kernel: 2.6.32.9-67.fc12.i686
package: blender-2.49b-5.fc12
rating: 4
reason: Process /usr/bin/blender.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Build yafaray from SVN repository
2. Install yafaray
3. Configure Blender to use locally built yafaray
4. Attempt to render a model using Yafaray

Comment 1 Roger Cowles 2010-03-09 15:04:41 UTC
Created attachment 398815 [details]
File: backtrace

Comment 2 Jochen Schmitt 2010-03-28 17:02:11 UTC
thank you that you have take the time to create this bug report.

Because I have say anything about QApplication in the backtrace, I would suggest, that you should make an update of Qt on your system.

Best Regards:

Jochen Schmitt

Comment 3 Karel Klíč 2010-05-25 08:29:25 UTC
*** Bug 584456 has been marked as a duplicate of this bug. ***

Comment 4 Diogo Lima 2010-05-31 01:41:43 UTC
I saw the exact same problem on gentoo, when you try to export to yafaray with QT Gui enabled, blender would crash and the output was unclear what was wrong.

But on one of my tests I discovered that disabling NLS (use flag) from blender, solved the yafaray incompability.

So I don't know what it is but it has something to do with NLS that makes QT crash

Comment 5 Bug Zapper 2010-11-03 20:19:48 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2010-12-03 17:39:50 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.