Bug 5718 - sndconfig doesn't set up ProAudioSpectrum 16 properly
sndconfig doesn't set up ProAudioSpectrum 16 properly
Status: CLOSED DUPLICATE of bug 5309
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 06:02 EDT by gar
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 17:33:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gar 1999-10-08 06:02:33 EDT
I have had a lot of trouble getting this card installed with
modules.  It works fine when you compile it into the kernel,
this is because the PAS's IO addr is fixed at 0x380 (I am
writing this from work it is either 380 or 388 - if you
email me I can send my working conf.modules file :) and you
can only choose soundblaster type IO addresses (ie 0x220
etc).

From reading a lot of Alan Cox's docs, it seems you have to
have the sound blaster module loaded as well as the PAS
module to make it work (which seems a little strange, but
whatever).  The other thing to be aware of is with both
these modules loaded, the output audio dev is /dev/audio for
16bit SB, and /dev/dsp for 8bit SB.  The MPU-401 and
joystick modules can also be loaded, although I havn't
bothered at home.

If you would like I have a booklet for the card, and I am
thinking bout buying a lil PCI sound card (like an ensoniq
or something cheap) as it is kinda starting to be a pain,
but I can donate it and the manual (which has a great
appendix with all IO's etc listed in the back) to RHLabs -
just gimme the postal addr :)

power to the penquin!

Luke
Comment 1 Bill Nottingham 1999-11-01 15:49:59 EST
We have a PAS here, and it works fine with
'modprobe pas2 io=0x220 irq=5 dma=1'.
 What arguments are you using?
Comment 2 Bill Nottingham 2000-02-08 17:33:59 EST
*** This bug has been marked as a duplicate of 5309 ***

Note You need to log in before you can comment on or make changes to this bug.