This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 571940 - glade-provided UIs are not being translated
glade-provided UIs are not being translated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 467392 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-09 16:01 EST by Ville-Pekka Vainio
Modified: 2010-04-06 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: pyparted-3.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 576848 (view as bug list)
Environment:
Last Closed: 2010-03-27 01:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2010-03-09 16:01:52 EST
Description of problem:
The "Please name this computer" screen is missing translations when used in Finnish even though the Finnish translation is 100% complete according to Transifex. There is the following entry in the fi.po file, but it doesn't seem to end up in Anaconda:

#: ui/network.glade.h:2
msgid ""
"Please name this computer.  The hostname identifies the computer on a "
"network."
msgstr ""
"Anna tälle tietokoneelle nimi. Se helpottaa koneen tunnistamista verkossa."

--

The "Please select the nearest city..." text can't be translated, it's missing from the po/pot files completely.

--

The following texts aren't translated in the UI but are in the po file:

# ../iw/timezone_gui.py:181 ../iw/timezone_gui.py:182
#: textw/timezone_text.py:92
msgid "System clock uses UTC"
msgstr "Järjestelmän kello on UTC-ajassa"

#: ui/account.glade.h:3
msgid ""
"The root account is used for administering the system.  Enter a password for "
"the root user."
msgstr ""
"Pääkäyttäjän root-tunnusta käytetään järjestelmän ylläpitoon. Anna salasana "
"root-käyttäjälle."


#: ui/autopart.glade.h:5
msgid "Which type of installation would you like?"
msgstr "Millaisen asennuksen haluat tehdä?"

#: ui/autopart.glade.h:6
msgid "_Encrypt system"
msgstr "_Salaa järjestelmä"

#: ui/autopart.glade.h:2
msgid "Re_view and modify partitioning layout"
msgstr "Ta_rkastele ja muuta osiointia"


Version-Release number of selected component (if applicable):
13.32, in F13 Alpha

Please pay attention to including all translations and having all text translatable for the Beta and Gold releases.
Comment 1 Ales Kozumplik 2010-03-23 12:46:24 EDT
I can confirm this with Czech (100% complete translation for f13-branch):
https://translate.fedoraproject.org/projects/p/anaconda/c/f13-branch/

I can see both the glade strings and other UI strings, e.g. "_Previous" or the computer name screen.
Comment 2 Ales Kozumplik 2010-03-23 12:47:56 EDT
I mean "_Back" of course.
Comment 3 Fedora Update System 2010-03-26 10:42:36 EDT
pyparted-3.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pyparted-3.2-1.fc13
Comment 4 Fedora Update System 2010-03-27 01:02:52 EDT
pyparted-3.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Ales Kozumplik 2010-04-06 02:54:42 EDT
*** Bug 467392 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.