Bug 572096 - [Regression] No stylus input on Tablet PC since Fedora 13 Alpha
[Regression] No stylus input on Tablet PC since Fedora 13 Alpha
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 582852
  Show dependency treegraph
 
Reported: 2010-03-10 04:18 EST by Luya Tshimbalanga
Modified: 2018-04-11 03:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-31 04:12:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from LT20 laptop (38.62 KB, text/plain)
2010-03-10 04:19 EST, Luya Tshimbalanga
no flags Details
evtest-capture result for wacom driver (631 bytes, text/xml)
2010-04-22 05:04 EDT, Luya Tshimbalanga
no flags Details
evtest-capture result without X (631 bytes, text/xml)
2010-04-23 14:37 EDT, Luya Tshimbalanga
no flags Details
udevadm report (113.77 KB, text/plain)
2010-05-14 06:02 EDT, Luya Tshimbalanga
no flags Details
evtest-capture without X server (113.85 KB, text/plain)
2010-05-21 01:43 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2010-03-10 04:18:31 EST
Description of problem:
After fresh installation of Fedora 13 Alpha, the stylus input will not work anymore

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Fresh installation
2.
3.
  
Actual results:
No input

Expected results:
Should be an input from stylus

Additional info:
Comment 1 Luya Tshimbalanga 2010-03-10 04:19:56 EST
Created attachment 399040 [details]
Xorg.0.log from LT20 laptop
Comment 2 Luya Tshimbalanga 2010-03-10 14:41:27 EST
Running evtest result:

]# evtest /dev/input/event9
Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0xa5c product 0x4503 version 0x111
Input device name: "HID 0a5c:4503"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
  Event type 4 (Misc)
    Event code 4 (ScanCode)
Testing ... (interrupt to exit

It seems to recognize wacom screen but no input works.
Comment 3 Peter Hutterer 2010-03-14 23:54:38 EDT
This looks like an evdev problem - the device is assigned the evdev driver.

In the evtest output above - did you get any events when you touched the screen? If so, can you please run evtest-capture against the device and attach the resulting xml file here.
Comment 4 Luya Tshimbalanga 2010-03-15 00:54:29 EDT
Alas no event at all. I reverted to Fedora 12 on my laptop. I will run evtest-capture when I got Fedora 13 Alpha liveusb instead.
Comment 5 Matěj Cepl 2010-03-15 19:11:46 EDT
OK, putting the bug back to needinfo, so that it won't get lost. You have 30 days to provide requested information.

Thank you for helping us to make Fedora better
Comment 6 Luya Tshimbalanga 2010-03-16 01:51:17 EDT
evtest-capture.xml is empty with no input at all from Wacom device so it could not be included as attachment. It seems evdev is broken for Tablet. Test done using Fedora 13 Alpha liveusb.

Here is resulting output:

# evtest-capture 
Available devices:
/dev/input/event0:	Lid Switch
/dev/input/event1:	Power Button
/dev/input/event2:	Sleep Button
/dev/input/event3:	Power Button
/dev/input/event4:	Macintosh mouse button emulation
/dev/input/event5:	AT Translated Set 2 keyboard
/dev/input/event6:	SynPS/2 Synaptics TouchPad
/dev/input/event7:	HID 0a5c:4502
/dev/input/event8:	HID 0a5c:4503
/dev/input/event9:	Video Bus
Select the device event number [0-9]: 7
Writing to 'evtest-capture.xml'
Capturing device 'HID 0a5c:4502'.
Press Ctrl+C to stop.
^CStopping.
Segmentation fault (core dumped)
[root@localhost ~]# evtest-capture 8
Failed with error: No such file or directory
[root@localhost ~]# evtest-capture
Available devices:
/dev/input/event0:	Lid Switch
/dev/input/event1:	Power Button
/dev/input/event2:	Sleep Button
/dev/input/event3:	Power Button
/dev/input/event4:	Macintosh mouse button emulation
/dev/input/event5:	AT Translated Set 2 keyboard
/dev/input/event6:	SynPS/2 Synaptics TouchPad
/dev/input/event7:	HID 0a5c:4502
/dev/input/event8:	HID 0a5c:4503
/dev/input/event9:	Video Bus
Select the device event number [0-9]: 8
Writing to 'evtest-capture.xml'
Capturing device 'HID 0a5c:4503'.
Press Ctrl+C to stop.
^CStopping.
Segmentation fault (core dumped)
[root@localhost ~]# evtest-capture 9
Failed with error: No such file or directory
[root@localhost ~]# evtest-capture
Available devices:
/dev/input/event0:	Lid Switch
/dev/input/event1:	Power Button
/dev/input/event2:	Sleep Button
/dev/input/event3:	Power Button
/dev/input/event4:	Macintosh mouse button emulation
/dev/input/event5:	AT Translated Set 2 keyboard
/dev/input/event6:	SynPS/2 Synaptics TouchPad
/dev/input/event7:	HID 0a5c:4502
/dev/input/event8:	HID 0a5c:4503
/dev/input/event9:	Video Bus
Select the device event number [0-9]: 9
Writing to 'evtest-capture.xml'
Capturing device 'Video Bus'.
Press Ctrl+C to stop.
^CStopping.
Segmentation fault (core dumped)
[root@localhost ~]# ls
evtest-capture.xml
[root@localhost ~]# vi evtest-capture.xml 
[root@localhost ~]# evtest-capture 7
Failed with error: No such file or directory
[root@localhost ~]# evtest-capture
Available devices:
/dev/input/event0:	Lid Switch
/dev/input/event1:	Power Button
/dev/input/event2:	Sleep Button
/dev/input/event3:	Power Button
/dev/input/event4:	Macintosh mouse button emulation
/dev/input/event5:	AT Translated Set 2 keyboard
/dev/input/event6:	SynPS/2 Synaptics TouchPad
/dev/input/event7:	HID 0a5c:4502
/dev/input/event8:	HID 0a5c:4503
/dev/input/event9:	Video Bus
Select the device event number [0-9]: 7
Writing to 'evtest-capture.xml'
Capturing device 'HID 0a5c:4502'.
Press Ctrl+C to stop.
^CStopping.
Segmentation fault (core dumped)
Comment 7 Luya Tshimbalanga 2010-04-15 13:53:21 EDT
Any progress about enabling Wacom on Tablet? I run Fedora 13 Beta from Live Media but no input so far from either event7 and event8.
Comment 8 Luya Tshimbalanga 2010-04-17 19:39:07 EDT
Running Fedora 13 Beta updated on 20100417. Segmentation fault on both event8 and event9. No input from stylus and evtest-capture.xml is empty.
Comment 9 Fedora Update System 2010-04-22 02:19:39 EDT
evtest-1.26-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/evtest-1.26-1.fc13
Comment 10 Peter Hutterer 2010-04-22 02:22:38 EDT
with the wacom driver, evtest-capture won't work too well (same with evtest). the driver puts a grab on the device and no other process can then receive events. The evtest-capture crash is fixed in evtest-1.26 but to get events you need to VT switch away from the server before using evtest-capture.
Comment 11 Luya Tshimbalanga 2010-04-22 05:04:17 EDT
Created attachment 408268 [details]
evtest-capture result for wacom driver

I run evtest-capture as followed instruction. The result is included and still no input from Wacom serial on my laptop.
Comment 12 Peter Hutterer 2010-04-22 19:03:45 EDT
sigh. sounds like the kernel driver is mute then? just to make sure, can you boot into runlevel 3 (without X running) and check with evtest or evtest-capture if the device sends events then.


init 3 as root will do that (and shut down your X session in the process), init 5 gets you back to your normal runlevel and starts a new session.
Comment 13 Luya Tshimbalanga 2010-04-23 14:37:08 EDT
Created attachment 408702 [details]
evtest-capture result without X

Result from evtest-capture on event9 running on init 3 with no input using stylus.
I verified wacom driver is installed yet it appears evtest did not recognized as serial Wacom tablet compared to Fedora 12. Just to make sure, here is 50-wacom-conf

Section "InputClass"
        Identifier "Wacom class"
        MatchProduct "Wacom|WALTOP|WACOM"
        Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom serial class"
        MatchProduct "WACf|FUJ02e5|FUJ02e7"
        Driver "wacom"
        Option "ForceDevice" "ISDV4"
EndSection

# N-Trig Duosense Electromagnetic Digitizer
Section "InputClass"
        Identifier "Wacom N-Trig class"
        MatchProduct "HID 1b96:0001"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
EndSection

Here is a part of 10-evdev-conf

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

A small question, should both 10-evdev-conf and 50-wacom-conf be moved in /etc/X11/xorg.conf.d ?
Comment 14 Luya Tshimbalanga 2010-04-27 12:54:18 EDT
After updating the latest kernel 2.6.33.2-60.fc13.i686, still no input for Wacom Serial Tablet PC Pen Tablet/Digitizer. It seems change on evdev broke Serial Tablet PC support. However, using USB Wacon Graphire 2 is working fine.
Comment 15 Luya Tshimbalanga 2010-05-14 06:02:37 EDT
Created attachment 413995 [details]
udevadm report

 I tested the design suite liveusb for F13 20100511, the same problem occurred. evtest-capture returned nothing and I cannot include empty file. I followed instruction from #582582 because there were no wacom-serial.conf inside /etc/X11, still no luck. Should this report be merged with #582582 because the similar issue?
Comment 16 Fedora Update System 2010-05-17 15:08:37 EDT
evtest-1.26-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Luya Tshimbalanga 2010-05-18 06:08:21 EDT
fix from #582582 made stylus input working although evtest-capture seems unable to capture it for some reason.
Comment 18 Peter Hutterer 2010-05-18 19:46:38 EDT
you did VT switch away, did you? if the wacom driver has a grab on the device, evtest won't see anything.
Comment 19 Luya Tshimbalanga 2010-05-21 01:43:23 EDT
Created attachment 415583 [details]
evtest-capture without X server

Here is the evtest-capture result switching away from X. I first thought I would see the output but I don't see trace.
Comment 20 Peter Hutterer 2010-05-30 19:55:09 EDT
that file doesn't look like an evtest-capture output to me :)

anyway, with 582852 fixed, can we close this bug now? I think this is the main issue here, let's ignore the evtest-capture stuff for now.
Comment 21 Luya Tshimbalanga 2010-05-31 01:34:49 EDT
+1.
Comment 22 Matěj Cepl 2010-05-31 04:12:24 EDT
Thank you, closing per comment 21.

Note You need to log in before you can comment on or make changes to this bug.