Bug 582852 - No tablet detection since updating to F13 Beta
No tablet detection since updating to F13 Beta
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-wacom (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Triaged
Depends On: 572096
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 19:53 EDT by Ryan Rix
Modified: 2010-05-28 14:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-wacom-0.10.6-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 14:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg logfile (1.29 MB, application/octet-stream)
2010-04-26 23:26 EDT, Ryan Rix
no flags Details
Second attempt at xorg.log (39.00 KB, text/plain)
2010-04-28 23:21 EDT, Ryan Rix
no flags Details
udevadm-info --export-db output (118.76 KB, text/plain)
2010-05-05 09:36 EDT, Ryan Rix
no flags Details
udevadm info --export-db output after tablet works (119.26 KB, text/plain)
2010-05-18 02:12 EDT, Ryan Rix
no flags Details
udevadm report after tablet work (LT20) (113.85 KB, text/plain)
2010-05-18 05:57 EDT, Luya Tshimbalanga
no flags Details
udevadm info --export-db output from a Lenovo X200 Tablet (129.98 KB, text/plain)
2010-05-18 08:22 EDT, Tore Anderson
no flags Details
Debian/Ubuntu wacom rules (7.51 KB, text/plain)
2010-05-27 12:30 EDT, Sitsofe Wheeler
no flags Details

  None (edit)
Description Ryan Rix 2010-04-15 19:53:12 EDT
Description of problem:
ThinkPad x200 tablet is not recognized by XInput since the latest update on Fedora 13 beta. it is found in lshal though catting the device file and moving the stylus across the screen yields no useful results.

udi = '/org/freedesktop/Hal/devices/pnp_WACf004'
  info.linux.driver = 'serial'  (string)
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  info.subsystem = 'pnp'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pnp_WACf004'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'pnp'  (string)
  linux.sysfs_path = '/sys/devices/pnp0/00:0a'  (string)
  pnp.description = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  pnp.id = 'WACf004'  (string)
  pnp.serial.irq = 5  (0x5)  (int)
  pnp.serial.port = '0x200'  (string)

udi = '/org/freedesktop/Hal/devices/pnp_WACf004_serial_platform_0'
  info.capabilities = {'serial'} (string list)
  info.category = 'serial'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pnp_WACf004'  (string)
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  info.subsystem = 'tty'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pnp_WACf004_serial_platform_0'  (string)
  linux.device_file = '/dev/ttyS0'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'tty'  (string)
  linux.sysfs_path = '/sys/devices/pnp0/00:0a/tty/ttyS0'  (string)
  serial.device = '/dev/ttyS0'  (string)
  serial.originating_device = '/org/freedesktop/Hal/devices/pnp_WACf004'  (string)
  serial.port = 0  (0x0)  (int)
  serial.type = 'platform'  (string)

Version-Release number of selected component (if applicable):
xorg-x11-drv-wacom-0.10.4-2.fc12.x86_64 worked
xorg-x11-drv-wacom-0.10.5-1.fc13.x86_64 doesn't

I can relay any other needed versions
Comment 1 Peter Hutterer 2010-04-22 23:36:24 EDT
Please attach your Xorg.log. F-13 doesn't use HAL for device detection anymore, so that's only partially useful.
Comment 2 Ryan Rix 2010-04-26 23:24:18 EDT
My apologies for the delay, missed the bugmail! Attaching the logfile
Comment 3 Ryan Rix 2010-04-26 23:26:15 EDT
Created attachment 409339 [details]
Xorg logfile
Comment 4 Luya Tshimbalanga 2010-04-27 13:34:02 EDT
I think that bug is also related to #572096 because the regression occurred since Fedora 13 Alpha.
Comment 5 Ryan Rix 2010-04-27 17:04:19 EDT
Very possible. Though that points to an issue lower in the stack. I can go pondering through the kernel's git logs for something, but I'm a little strapped on time these next few weeks for school finals :(
Comment 6 Ryan Rix 2010-04-28 21:06:57 EDT
Just updated to 0.10.6-1.fc13, not any improvement :(
Comment 7 Peter Hutterer 2010-04-28 22:27:10 EDT
please save the following as /etc/X11/xorg.conf.d/60-wacom-serial.conf:

Section "InputClass"
        Identifier "Wacom serial class"
        MatchProduct "Wacom Serial Tablet"
        Driver "wacom"
        Option "ForceDevice" "ISDV4"
EndSection


Then restart X, does this show wacom in the logs now?
Comment 8 Peter Hutterer 2010-04-28 22:27:39 EDT
note, you need the latest F13 X server, if you're still on the beta please use /etc/xorg.conf.d/60-wacom.conf instead
Comment 9 Ryan Rix 2010-04-28 23:20:58 EDT
[root@TheSwan ~]# rpm -qa |grep xorg-x11-server
xorg-x11-server-common-1.8.0-8.fc13.x86_64
xorg-x11-server-utils-7.4-16.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-8.fc13.x86_64

[root@TheSwan ~]# ls /etc/xorg.conf.d/
00-system-setup-keyboard.conf  50-wacom.conf
[root@TheSwan ~]# ls /etc/X11/xorg.conf.d/
00-system-setup-keyboard.conf  50-wacom.conf


Attaching logfile, basically the same thing as without these conf files.
Comment 10 Ryan Rix 2010-04-28 23:21:38 EDT
Created attachment 410014 [details]
Second attempt at xorg.log
Comment 11 Peter Hutterer 2010-05-05 02:22:44 EDT
what's the output of "udevadm info --export-db", can you attach this here please?
I wonder if the serial tablet just doesn't get the right IDs assigned to it.
Comment 12 Ryan Rix 2010-05-05 09:34:28 EDT
Annnd, here we go.
Comment 13 Ryan Rix 2010-05-05 09:36:52 EDT
Created attachment 411603 [details]
udevadm-info --export-db output
Comment 14 Ryan Rix 2010-05-05 14:41:46 EDT
I'm available in #fedora-devel any time today if you want to debug in Real Time. My nick is rrix.
Comment 15 Tore Anderson 2010-05-14 17:20:32 EDT
I'm also affected by this bug.  After upgrading to current F13, the tablet on my Lenovo X200 Tablet stopped working.  I see output when doing "cat /dev/ttyS0" and moving the stylus around, but the following commands doesn't say anything about any wacom tablet:

lshw | grep -i wacom
dmidecode | grep -i wacom
lshal | grep -i wacom
udevadm info --export-db | grep -i wacom

So it seems like while the tablet device itself works as expected, the X server no longer loads the wacom input driver.  For me personally this is a F13Blocker, unless I can figure out any way of setting it up manually.

Tore
Comment 16 Tore Anderson 2010-05-14 18:44:55 EDT
Got it to work now.  The changes I did, were:

1) Modify /usr/share/X11/xorg.conf.d/50-wacom.conf line 20 so it says «MatchProduct "WACf|WACf008|FUJ02e5|FUJ02e7"» (adding "WACf008").

2) Create /etc/udev/rules.d/99-wacom.conf, containing the following line: «ACTION=="add|change", ATTRS{id}=="WACf008", ENV{Name}="Serial Wacom Tablet", ENV{SUBSYSTEM}="input", ENV{ID_INPUT}="1"».

I'm not sure if all of those changes are necessary, or if some are too non-specific for inclusion in Fedora proper.  But at least they made stuff work for me.

Tore
Comment 17 Luya Tshimbalanga 2010-05-15 13:43:29 EDT
I have set a dependance on #572096 because the problem is very much identical since Fedora 12 Alpha. I tried the method from Comment #16 with currently no success.
Comment 18 Luya Tshimbalanga 2010-05-15 13:48:37 EDT
(In reply to comment #15)
> I'm also affected by this bug.  After upgrading to current F13, the tablet on
> my Lenovo X200 Tablet stopped working.  I see output when doing "cat
> /dev/ttyS0" and moving the stylus around, but the following commands doesn't
> say anything about any wacom tablet:
> 
> lshw | grep -i wacom
> dmidecode | grep -i wacom
> lshal | grep -i wacom
> udevadm info --export-db | grep -i wacom
> 

I received 

# lshal | grep -i wacom
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  pnp.description = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  info.product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)

The rest returns no input.
Comment 19 Luya Tshimbalanga 2010-05-15 13:49:51 EDT
I forgot to mention the test is done on F13 Design spin 20100511.
Comment 20 Ryan Rix 2010-05-15 14:28:30 EDT
So, I tried comment 16 on xorg-x11-drv-wacom-0.10.6-1.fc13.x86_64 and xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64 with no positive effect. However, something DID change, because a KDE daemon module I have installed to control and monitor tablet systems now crashes while being loaded...

solid-hardware list details now returns the following entry:

udi = '/org/freedesktop/Hal/devices/pnp_WACf004_serial_platform_0'
  parent = '/org/freedesktop/Hal/devices/pnp_WACf004'  (string)
  vendor = ''  (string)
  product = 'Wacom Serial Tablet PC Pen Tablet/Digitizer'  (string)
  SerialInterface.driverHandle = '/dev/ttyS0'  (string)
  SerialInterface.serialType = '^A'  (string)
  SerialInterface.port = 0  (0x0)  (int)

The other wacom device in HAL is now gone.

udevadm info now lists:
P: /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/WACF004:00
E: UDEV_LOG=3
E: DEVPATH=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/WACF004:00
E: MODALIAS=acpi:WACF004:
E: SUBSYSTEM=acpi
Comment 21 Tore Anderson 2010-05-15 17:56:16 EDT
(In reply to comment #20)

> So, I tried comment 16 on xorg-x11-drv-wacom-0.10.6-1.fc13.x86_64 and
> xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64 with no positive effect. However,
> something DID change, because a KDE daemon module I have installed to control
> and monitor tablet systems now crashes while being loaded...
> 
> solid-hardware list details now returns the following entry:
> 
> udi = '/org/freedesktop/Hal/devices/pnp_WACf004_serial_platform_0'
>   parent = '/org/freedesktop/Hal/devices/pnp_WACf004'  (string)

Perhaps you should try using the string "WACf004" where I used "WACf008", since it appears we have different tablet models.  The same goes for you, Luya, you should check your device ID and make sure the udev rules and the xorg.conf.d snippet uses the correct one.

Tore
Comment 22 Ryan Rix 2010-05-16 17:57:10 EDT
The MatchProduct string doesn't do anything since WACf is a substring of WACf00x, and MatchProduct matches to substrings...

As for the udev rule, I used WACf004, to no positive effect.
Comment 23 Luya Tshimbalanga 2010-05-16 19:09:40 EDT
(In reply to comment #22)
> The MatchProduct string doesn't do anything since WACf is a substring of
> WACf00x, and MatchProduct matches to substrings...
> 
> As for the udev rule, I used WACf004, to no positive effect.    

Same result as well. =(
Comment 24 Peter Hutterer 2010-05-17 19:57:27 EDT
Thanks Tore, I've added your udev rules to the package, a scratch package is available here: http://koji.fedoraproject.org/scratch/whot/task_2193280/
can you please check this, the rules format is slightly different to your comment so it'll be easier to add new ones in the future.

the xorg.conf.d change shouldn't be necessary, the current WACf string should match WACf008 as well.

Regardless of whether it works or not, can you please attach the udevadm info --export-db output after installing the rules file (you'll need to reboot after installing or at least run udevadm trigger)
Comment 25 Manny 2010-05-17 23:35:11 EDT
(In reply to comment #24)
> Thanks Tore, I've added your udev rules to the package, a scratch package is
> available here: http://koji.fedoraproject.org/scratch/whot/task_2193280/
> can you please check this, the rules format is slightly different to your
> comment so it'll be easier to add new ones in the future.
> 
> the xorg.conf.d change shouldn't be necessary, the current WACf string should
> match WACf008 as well.
> 
> Regardless of whether it works or not, can you please attach the udevadm info
> --export-db output after installing the rules file (you'll need to reboot after
> installing or at least run udevadm trigger)    

I installed the updated package and it resolved the tablet recognition issue on my X61 tablet. Thanks!
Comment 26 Fedora Update System 2010-05-18 00:50:43 EDT
xorg-x11-drv-wacom-0.10.6-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xorg-x11-drv-wacom-0.10.6-2.fc13
Comment 27 Ryan Rix 2010-05-18 02:10:02 EDT
Worksforme, Peter! Thanks! :)

Uploading udevadm info
Comment 28 Ryan Rix 2010-05-18 02:12:11 EDT
Created attachment 414745 [details]
udevadm info --export-db output after tablet works
Comment 29 Luya Tshimbalanga 2010-05-18 05:57:35 EDT
Created attachment 414792 [details]
udevadm report after tablet work (LT20)

Latest package fixed the issue for tablet.
Comment 30 Tore Anderson 2010-05-18 08:22:05 EDT
Created attachment 414832 [details]
udevadm info --export-db output from a Lenovo X200 Tablet

(In reply to comment #24)
> Thanks Tore, I've added your udev rules to the package, a scratch package is
> available here: http://koji.fedoraproject.org/scratch/whot/task_2193280/
> can you please check this, the rules format is slightly different to your
> comment so it'll be easier to add new ones in the future.

Seems to work fine, thanks!

> the xorg.conf.d change shouldn't be necessary, the current WACf string should
> match WACf008 as well.

Ok.  As I said, I didn't know if all of the changes was necessary or not.  I just tried making changes in an incremental manner until I got it to work - so some of those changes were probably useless...

> Regardless of whether it works or not, can you please attach the udevadm info
> --export-db output after installing the rules file (you'll need to reboot after
> installing or at least run udevadm trigger)    

Attached.  Thanks again!

Tore
Comment 31 Fedora Update System 2010-05-18 17:48:56 EDT
xorg-x11-drv-wacom-0.10.6-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-wacom'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xorg-x11-drv-wacom-0.10.6-2.fc13
Comment 32 Sitsofe Wheeler 2010-05-27 12:30:10 EDT
Created attachment 417299 [details]
Debian/Ubuntu wacom rules

For what is worth, here are the Debian/Ubuntu udev rules for Wacom tablets.
Comment 33 August Schwerdfeger 2010-05-28 10:24:53 EDT
I am using xorg-x11-drv-wacom-0.10.6-3.fc13 with an HP EliteBook 2730p and my tablet is not being auto-detected. I can get it to work using the work-around in comment #16 (although this requires a reconfiguration of extended input devices) or by creating xorg.conf manually.
Comment 34 Fedora Update System 2010-05-28 14:00:05 EDT
xorg-x11-drv-wacom-0.10.6-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.