Bug 572224 - [abrt] crash in gpodder-2.1-2.fc12: gui.py:1740:play_or_download:TypeError: unknown type (null)
Summary: [abrt] crash in gpodder-2.1-2.fc12: gui.py:1740:play_or_download:TypeError: u...
Keywords:
Status: CLOSED DUPLICATE of bug 594907
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e8b852ee
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-10 15:35 UTC by sbitschn
Modified: 2010-05-23 17:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-23 17:49:53 UTC


Attachments (Terms of Use)
File: backtrace (928 bytes, text/plain)
2010-03-10 15:35 UTC, sbitschn
no flags Details

Description sbitschn 2010-03-10 15:35:24 UTC
abrt 1.0.7 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/gpodder
comment: Just tried to add http://www.npr.org/rss/podcast.php?id=510253
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.32.8-58.fc12.x86_64
package: gpodder-2.1-2.fc12
reason: gui.py:1740:play_or_download:TypeError: unknown type (null)
release: Fedora release 12 (Constantine)

backtrace
-----
gui.py:1740:play_or_download:TypeError: unknown type (null)

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 702, in <lambda>
    selection.connect('changed', lambda s: self.play_or_download())
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 1740, in play_or_download
    episode = model.get_value(model.get_iter(path), EpisodeListModel.C_EPISODE)
TypeError: unknown type (null)

Local variables in innermost frame:
paths: [(0,), (1,), (2,), (3,), (4,), (5,), (6,), (7,), (8,)]
selection: <gtk.TreeSelection object at 0x7f6840b35820 (GtkTreeSelection at 0x20740c0)>
can_delete: False
is_locked: False
self: <gpodder.gui.gPodder at /gui at 0x1f709d0>
can_download: False
can_play: False
can_cancel: False
open_instead_of_play: False
can_transfer: False
path: (0,)
model: <gtk.TreeModelFilter object at 0x1f92af0 (GtkTreeModelFilter at 0x20a06e0)>
is_played: False

How to reproduce
-----
1. Tried to add http://www.npr.org/rss/podcast.php?id=510253
2.
3.

Comment 1 sbitschn 2010-03-10 15:35:26 UTC
Created attachment 399111 [details]
File: backtrace

Comment 2 Ville-Pekka Vainio 2010-03-10 23:08:03 UTC
Reported upstream: https://bugs.gpodder.org/show_bug.cgi?id=934

Comment 3 Ville-Pekka Vainio 2010-03-14 21:09:42 UTC
sbitschn: Could you give some more details on how this bug happens? Can you reliably reproduce it or did it just occur once?

Comment 4 Kerry 2010-03-24 20:52:20 UTC

Comment
-----
Was part way through checking for updates. The program kept running though, maybe it just had problem with one feed.

Comment 5 Terry Wallwork 2010-04-29 21:33:11 UTC
Package: gpodder-2.1-3.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


Comment
-----
Gpodder asked to download new podcasts while i was already download podcasts

Comment 6 Ville-Pekka Vainio 2010-05-23 17:49:53 UTC
We've received the first report for this bug in the new Fedora 12 package, version 2.3. I'll close this bug as a duplicate of the newer bug, because we'll probably be receiving the next abrt reports as a comments on that bug.

*** This bug has been marked as a duplicate of bug 594907 ***


Note You need to log in before you can comment on or make changes to this bug.