Bug 594907 - [abrt] crash in gpodder-2.3-1.fc12: gui.py:2025:play_or_download:TypeError: unknown type (null)
Summary: [abrt] crash in gpodder-2.3-1.fc12: gui.py:2025:play_or_download:TypeError: u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:316e8dbd
: 572224 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 21:52 UTC by Kerry
Modified: 2010-06-14 17:13 UTC (History)
3 users (show)

Fixed In Version: gpodder-2.3-4.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-14 17:13:08 UTC


Attachments (Terms of Use)
File: backtrace (900 bytes, text/plain)
2010-05-21 21:52 UTC, Kerry
no flags Details

Description Kerry 2010-05-21 21:52:36 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/gpodder
comment: The program didn't crash, not sure why ABRT came up.
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.32.11-99.fc12.i686.PAE
package: gpodder-2.3-1.fc12
reason: gui.py:2025:play_or_download:TypeError: unknown type (null)
release: Fedora release 12 (Constantine)

backtrace
-----
gui.py:2025:play_or_download:TypeError: unknown type (null)

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 892, in <lambda>
    selection.connect('changed', lambda s: self.play_or_download())
  File "/usr/lib/python2.6/site-packages/gpodder/gui.py", line 2025, in play_or_download
    episode = model.get_value(model.get_iter(path), EpisodeListModel.C_EPISODE)
TypeError: unknown type (null)

Local variables in innermost frame:
paths: [(0,), (1,), (2,), (3,), (4,)]
selection: <gtk.TreeSelection object at 0x9407f54 (GtkTreeSelection at 0x944d780)>
can_delete: False
is_locked: False
self: <gpodder.gui.gPodder at /gui at 0xb73eb20c>
can_download: False
can_play: False
can_cancel: False
open_instead_of_play: False
can_transfer: False
path: (0,)
model: <gtk.TreeModelFilter object at 0x93d8f2c (GtkTreeModelFilter at 0x943faa8)>
is_played: False

Comment 1 Kerry 2010-05-21 21:52:39 UTC
Created attachment 415787 [details]
File: backtrace

Comment 2 Ville-Pekka Vainio 2010-05-23 17:49:53 UTC
*** Bug 572224 has been marked as a duplicate of this bug. ***

Comment 3 Ville-Pekka Vainio 2010-05-23 17:54:53 UTC
Reported upstream: https://bugs.gpodder.org/show_bug.cgi?id=934

Comment 4 Fedora Update System 2010-05-28 19:59:40 UTC
gpodder-2.3-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gpodder-2.3-3.fc12

Comment 5 Fedora Update System 2010-05-31 18:15:35 UTC
gpodder-2.3-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gpodder-2.3-3.fc12

Comment 6 Fedora Update System 2010-06-07 22:19:00 UTC
gpodder-2.3-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gpodder-2.3-4.fc12

Comment 7 Fedora Update System 2010-06-14 17:13:04 UTC
gpodder-2.3-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.