Bug 572372 - update Twisted to 10.1.0
Summary: update Twisted to 10.1.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-twisted
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Vander Stichele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 562379 596049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-11 01:33 UTC by djh
Modified: 2010-10-18 05:42 UTC (History)
28 users (show)

Fixed In Version: python-twisted-mail-10.1.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-18 05:42:10 UTC


Attachments (Terms of Use)
list of packages dependent on twisted (3.20 KB, text/plain)
2010-04-04 22:00 UTC, Julian Sikorski
no flags Details
updated dep list (3.88 KB, text/plain)
2010-08-05 21:05 UTC, Julian Sikorski
no flags Details

Description djh 2010-03-11 01:33:44 UTC
Rawhide/F13 has Twisted 8.2.0.  10.0.0 was released last week.

Is packaging each sub-project in a separate SRPM still the preferred method?

Comment 1 Julian Sikorski 2010-03-23 20:05:46 UTC
*** Bug 562379 has been marked as a duplicate of this bug. ***

Comment 2 Julian Sikorski 2010-04-04 22:00:02 UTC
Created attachment 404426 [details]
list of packages dependent on twisted

Output of: repoquery --whatrequires `repoquery --provides python-twisted-*` | sort

Comment 3 Julian Sikorski 2010-05-26 08:37:10 UTC
*** Bug 596049 has been marked as a duplicate of this bug. ***

Comment 4 Julian Sikorski 2010-07-14 20:49:43 UTC
I have prepared the packages updated to 10.1.0. All I can say is that they build and that telepathy-sunshine works. If you could test these packages this would help tremendously:
http://belegdol.fedorapeople.org/twisted/

Comment 5 Julian Sikorski 2010-07-14 21:02:12 UTC
Michal, Peter: jabbim and openxcap are the only consumers of python-twisted-web2, according to repoquery. Would web2 still be needed if twisted is updated to 10.1.0?

Comment 6 Michal Schmidt 2010-07-14 22:31:01 UTC
(In reply to comment #4)
> http://belegdol.fedorapeople.org/twisted/    

I'm using jabbim with these Twisted 10.1.0 packages now and it works fine so far. Thank you for working on it.

Jabbim uses web2 for BOSH (XMPP over HTTP) connectivity. It uses it as a fallback when it cannot establish a TCP connection to the XMPP server's usual port 5222. So BOSH helps in situations when the user is only allowed to use port 80 or sits behind a HTTP proxy.

When web2 is not available, Jabbim degrades functionality gracefully. BOSH won't work then, but that's it.

I took a look at what Debian ships (packages.debian.org). They have Twisted 10.0 + web2 8.1. As long as it works, can we too keep web2 in the distribution?

Comment 7 Julian Sikorski 2010-08-05 20:26:24 UTC
I guess we can, there is no reason to drop it when it's not interfering.

Comment 8 Julian Sikorski 2010-08-05 21:05:48 UTC
Created attachment 436981 [details]
updated dep list

Since there was no large response to the devel list thread, forgive me this email spam. Basically, we would like to make sure packages work as expected before we update. So, if you could test the packages in comment #4 and see if the package you maintain still functions, this would be perfect.
I am attaching a new dep list.

Comment 9 Susi Lehtola 2010-08-05 23:05:46 UTC
cnucnu seems to be working.

Comment 10 Gianluca Sforna 2010-08-06 23:08:11 UTC
for buildbot I could only try the test suite, and that passes with no issues

Comment 11 Julian Sikorski 2010-08-07 20:24:39 UTC
In order to make testing easier, I have prepared a fedorapeople repo:
http://repos.fedorapeople.org/repos/belegdol/twisted/
It contains packages for Fedora 13 and 14, x86_64 and i386.
If you simply don't care if your package breaks or you plan to deal with the breakage once the update lands, please also make a note here. Happy testing.

Comment 12 Peter Lemenkov 2010-08-08 15:47:08 UTC
(In reply to comment #11)
> In order to make testing easier, I have prepared a fedorapeople repo:
> http://repos.fedorapeople.org/repos/belegdol/twisted/
> It contains packages for Fedora 13 and 14, x86_64 and i386.
> If you simply don't care if your package breaks or you plan to deal with the
> breakage once the update lands, please also make a note here. Happy testing.    

No regressions were found by me so far (using python-sippy). I don't have any objections against this upgrade.

Comment 13 Chen Lei 2010-08-10 18:02:02 UTC
python-twisted-core works for me, thanks Julian.

Comment 14 Nicoleau Fabien 2010-08-29 11:00:46 UTC
Hi,
I've tested "itaka" that depends on python-twisted-web and python-twisted-core.

Works fine.

Comment 15 Chen Lei 2010-08-29 13:00:19 UTC
Since debian already update Twisted to 10.x for squeeze (testing), so I think it's very safe to push this update to fedora.

See
http://packages.debian.org/search?keywords=python-twisted

Comment 16 Julian Sikorski 2010-08-29 16:19:14 UTC
I'm still waiting for Thomas to give me commit access - which can be problematic since he seems to be very busy these days.

Comment 17 Julian Sikorski 2010-09-21 21:35:33 UTC
Updated packages are now getting built for rawhide. If nothing explodes, I'll build them for F-14 soon.

Comment 18 Fedora Update System 2010-09-23 20:22:28 UTC
python-twisted-words-10.1.0-1.fc14,python-twisted-mail-10.1.0-1.fc14,python-twisted-names-10.1.0-1.fc14,python-twisted-news-10.1.0-1.fc14,python-twisted-runner-10.1.0-1.fc14,python-twisted-web-10.1.0-1.fc14,python-twisted-lore-10.1.0-1.fc14,python-twisted-conch-10.1.0-1.fc14,python-twisted-core-10.1.0-1.fc14,python-twisted-10.1.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-twisted-words-10.1.0-1.fc14,python-twisted-mail-10.1.0-1.fc14,python-twisted-names-10.1.0-1.fc14,python-twisted-news-10.1.0-1.fc14,python-twisted-runner-10.1.0-1.fc14,python-twisted-web-10.1.0-1.fc14,python-twisted-lore-10.1.0-1.fc14,python-twisted-conch-10.1.0-1.fc14,python-twisted-core-10.1.0-1.fc14,python-twisted-10.1.0-1.fc14

Comment 19 Fedora Update System 2010-09-24 22:01:49 UTC
python-twisted-words-10.1.0-1.fc14, python-twisted-mail-10.1.0-1.fc14, python-twisted-names-10.1.0-1.fc14, python-twisted-news-10.1.0-1.fc14, python-twisted-runner-10.1.0-1.fc14, python-twisted-web-10.1.0-1.fc14, python-twisted-lore-10.1.0-1.fc14, python-twisted-conch-10.1.0-1.fc14, python-twisted-core-10.1.0-1.fc14, python-twisted-10.1.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-twisted-words python-twisted-mail python-twisted-names python-twisted-news python-twisted-runner python-twisted-web python-twisted-lore python-twisted-conch python-twisted-core python-twisted'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-twisted-words-10.1.0-1.fc14,python-twisted-mail-10.1.0-1.fc14,python-twisted-names-10.1.0-1.fc14,python-twisted-news-10.1.0-1.fc14,python-twisted-runner-10.1.0-1.fc14,python-twisted-web-10.1.0-1.fc14,python-twisted-lore-10.1.0-1.fc14,python-twisted-conch-10.1.0-1.fc14,python-twisted-core-10.1.0-1.fc14,python-twisted-10.1.0-1.fc14

Comment 20 Fedora Update System 2010-10-02 01:13:07 UTC
python-twisted-mail-10.1.0-1.fc14, python-twisted-names-10.1.0-1.fc14, python-twisted-news-10.1.0-1.fc14, python-twisted-runner-10.1.0-1.fc14, python-twisted-web-10.1.0-1.fc14, python-twisted-lore-10.1.0-1.fc14, python-twisted-conch-10.1.0-1.fc14, python-twisted-10.1.0-1.fc14, python-twisted-words-10.1.0-2.fc14, python-twisted-core-10.1.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-twisted-mail python-twisted-names python-twisted-news python-twisted-runner python-twisted-web python-twisted-lore python-twisted-conch python-twisted python-twisted-words python-twisted-core'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-twisted-words-10.1.0-2.fc14,python-twisted-mail-10.1.0-1.fc14,python-twisted-names-10.1.0-1.fc14,python-twisted-news-10.1.0-1.fc14,python-twisted-runner-10.1.0-1.fc14,python-twisted-web-10.1.0-1.fc14,python-twisted-lore-10.1.0-1.fc14,python-twisted-conch-10.1.0-1.fc14,python-twisted-core-10.1.0-3.fc14,python-twisted-10.1.0-1.fc14

Comment 21 Fedora Update System 2010-10-09 02:56:09 UTC
python-twisted-mail-10.1.0-1.fc14, python-twisted-names-10.1.0-1.fc14, python-twisted-news-10.1.0-1.fc14, python-twisted-web-10.1.0-1.fc14, python-twisted-lore-10.1.0-1.fc14, python-twisted-conch-10.1.0-1.fc14, python-twisted-10.1.0-1.fc14, python-twisted-words-10.1.0-2.fc14, python-twisted-core-10.1.0-3.fc14, python-twisted-runner-10.1.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-twisted-mail python-twisted-names python-twisted-news python-twisted-web python-twisted-lore python-twisted-conch python-twisted python-twisted-words python-twisted-core python-twisted-runner'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-twisted-words-10.1.0-2.fc14,python-twisted-mail-10.1.0-1.fc14,python-twisted-names-10.1.0-1.fc14,python-twisted-news-10.1.0-1.fc14,python-twisted-runner-10.1.0-2.fc14,python-twisted-web-10.1.0-1.fc14,python-twisted-lore-10.1.0-1.fc14,python-twisted-conch-10.1.0-1.fc14,python-twisted-core-10.1.0-3.fc14,python-twisted-10.1.0-1.fc14

Comment 22 Fedora Update System 2010-10-18 05:41:52 UTC
python-twisted-mail-10.1.0-1.fc14, python-twisted-names-10.1.0-1.fc14, python-twisted-news-10.1.0-1.fc14, python-twisted-web-10.1.0-1.fc14, python-twisted-lore-10.1.0-1.fc14, python-twisted-conch-10.1.0-1.fc14, python-twisted-10.1.0-1.fc14, python-twisted-words-10.1.0-2.fc14, python-twisted-core-10.1.0-3.fc14, python-twisted-runner-10.1.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.