Bug 572489 - Network is disabled on install
Network is disabled on install
Status: CLOSED DUPLICATE of bug 498207
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
: 572547 572618 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 06:09 EST by Peter Knight
Modified: 2010-08-18 08:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 08:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-ks.cfg on F13 (1.39 KB, text/plain)
2010-03-11 09:50 EST, Kamil Páral
no flags Details

  None (edit)
Description Peter Knight 2010-03-11 06:09:34 EST
Description of problem:

On a new install of Fedora 12, the network is disabled. 

Version-Release number of selected component (if applicable):

Fedora 12

How reproducible:

I've only done one install, but other people report this:

http://www.mjmwired.net/resources/mjm-fedora-f12.html

Steps to Reproduce:
1.  Insert install DVD into PC
2.  Run through normal installation steps
3.
  
Actual results:

Network is disabled

Expected results:

Should be requested whether network is required, or not.

Additional info:

If the network is dis-abled at install time, it makes it very difficult
to review documentation and impossible to visit FedoraForum to solve other installation/configuration problems.  Effectively stops you using Fedora 12 as your 'only' PC - as you need another PC to search for problems.
Comment 1 Radek Vykydal 2010-03-11 06:49:04 EST
Network configuration editor is going to be added to anaconda. Respective rhel bug is #520146. I am keeping this bug open to track the issue for fedora.
Comment 2 Chris Lumens 2010-03-11 09:35:43 EST
*** Bug 572547 has been marked as a duplicate of this bug. ***
Comment 3 Kamil Páral 2010-03-11 09:50:04 EST
As per bug 572547 it happens also on F13. Used standard DVD install. Attaching kickstart.
Comment 4 Kamil Páral 2010-03-11 09:50:50 EST
Created attachment 399360 [details]
anaconda-ks.cfg on F13
Comment 5 Chris Lumens 2010-03-11 12:59:39 EST
*** Bug 572618 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2010-03-19 12:33:56 EDT
Discussed at 2010-03-12 (not a typo) blocker meeting, we agreed this does not meet the F13 Beta or Final blocker criteria. Dropping from the list. See http://meetbot.fedoraproject.org/fedora-bugzappers/2010-03-12/f13beta-blocker-review.2010-03-12-16.08.log.html .



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Radek Vykydal 2010-04-08 10:26:08 EDT
Network Configuration (using nm-connection-editor) was added into anaconda UI in version anaconda 14.1-1. Per comment #6 it is not going to appear in Fedora 13.
Comment 8 Kamil Páral 2010-04-08 10:54:09 EDT
Adam in comment #6 just said it hadn't been evaluated as F13 Blocker. That doesn't mean it can't be considered as nice-to-have feature. Quite the opposite, I think it is pretty important to include this patch. I will raise this question at next QA meeting at latest.
Comment 9 Radek Vykydal 2010-04-08 11:30:19 EDT
(In reply to comment #8)
> Adam in comment #6 just said it hadn't been evaluated as F13 Blocker. That
> doesn't mean it can't be considered as nice-to-have feature. Quite the
> opposite, I think it is pretty important to include this patch. I will raise
> this question at next QA meeting at latest.    

Kamil, nm-c-e integration requires also including of Metacity WM into stage 2, which is change of large scope - anaconda team judgement on this seem to be that it is too dangerous for f13 (but of course, feel free to use your ways to demand the feature).
Comment 10 Kamil Páral 2010-08-18 03:57:23 EDT
Reverting to ASSIGNED. This bug is still not fixed in Fedora 14 (anaconda 14.15). Anaconda truly gained a connection editor, but with default DVD install the 'System eth0' connection is still disabled on boot. User has to edit connections via NetworkManager and set "Connect automatically" by hand.

Anaconda should set network interfaces to be enabled on boot by default, even for DVD installation.

Note: A little related is bug #624939 that shows that you can't even set this desired behaviour during installation. Therefore - no way.
Comment 11 Radek Vykydal 2010-08-18 08:21:52 EDT

*** This bug has been marked as a duplicate of bug 498207 ***

Note You need to log in before you can comment on or make changes to this bug.