Bug 572514 - While fencing with Dell idrac6 use fence_ipmilan agent
While fencing with Dell idrac6 use fence_ipmilan agent
Status: CLOSED DUPLICATE of bug 496749
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 07:34 EST by Praveen K Paladugu
Modified: 2016-04-26 12:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 10:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Praveen K Paladugu 2010-03-11 07:34:03 EST
Description of problem: 
  While using Dell idrac6 as the fencing agent, fence_idrac was the agent which was used. This fence_idrac agent uses ssh to communicate with the Dell iDrac. Since a couple of bugs were identified with this communication mode, it was decided to use fence_ipmilan agent. 


  When Dell idrac6 is selected as the fencing agent on Conga, the cluster.conf should have fence_ipmilan as the agent, but it currently has fence_idrac. This has to be changed.

 Also the Conga GUI screen has a "Use SSH" check box which is not valid anymore while working with Dell iDrac6.


How reproducible:
Everytime

Steps to Reproduce:
1. Add a cluster node using Conga.
2. Configure Dell iDRAC6 fecning agent (on a DELL server with DELL iDRAC6 installed)
3. Fence the node added to Conga.
  
Actual results:
 The node is not fenced.

Expected results:
The cluster node should restart

Additional info:
Comment 1 Perry Myers 2010-03-12 10:37:39 EST
Earlier betas had the fence_idrac screen in Conga, but this was reverted with the latest beta build after we decided to standardize on fence_ipmilan.  So this should be resolved already.

*** This bug has been marked as a duplicate of bug 496749 ***
Comment 2 Praveen K Paladugu 2010-03-15 11:57:13 EDT
Hey Perry, 

 Could you please suggest on what Beta version was this issue fixed? I tested the same with RHEL5.5Beta build and it wasn't fixed.

 Also, is the fix for this issue part of RHEL6 branch as well?

Praveen
Comment 3 Perry Myers 2010-03-15 13:54:32 EDT
(In reply to comment #2)
> Hey Perry, 
> 
>  Could you please suggest on what Beta version was this issue fixed? I tested
> the same with RHEL5.5Beta build and it wasn't fixed.
> 
>  Also, is the fix for this issue part of RHEL6 branch as well?

RHEL6 has a different framework for Conga so the patch for fence_idrac was not included there at all.  The existing fence_ipmilan should work fine.

The build of conga that reverted the fence_idrac functionality was 0.12.2-12.

What version of luci are you looking at presently?  0.12.2-12 should have been included in 5.5 beta1 snapshot.
Comment 4 Praveen K Paladugu 2010-03-15 16:07:36 EDT
Perry,

 I last verified this issue on Rhel5.5Beta which had 0.12.2-10 version of luci. I verified this issue with 0.12.2-12 version (in RHEL5.5Beta-snapshot3) and there is no option of "Dell iDrac6" on the Conga anymore.  


 Also, there was supposed to be a KBase or Whitepaper which is going to detail how the customers should configure the fencing details. Do you happen to know when that is going to be out?


Thank you 
Praveen
Comment 5 Perry Myers 2010-03-15 16:17:13 EDT
(In reply to comment #4)
> Perry,
> 
>  I last verified this issue on Rhel5.5Beta which had 0.12.2-10 version of luci.
> I verified this issue with 0.12.2-12 version (in RHEL5.5Beta-snapshot3) and
> there is no option of "Dell iDrac6" on the Conga anymore.  

Ok good.
  
> 
>  Also, there was supposed to be a KBase or Whitepaper which is going to detail
> how the customers should configure the fencing details. Do you happen to know
> when that is going to be out?

The kbase will just be the following page imported into the kbase system:
http://sources.redhat.com/cluster/wiki/FenceAgents

We'll add a line that states that iDrac/Drac6 has ipmi support and that will indicate to customers that fence_ipmilan is the supported agent for that hardware.

Note You need to log in before you can comment on or make changes to this bug.