Bug 57266 - A stray file creates an extra entry in the control-center menu tree
Summary: A stray file creates an extra entry in the control-center menu tree
Status: CLOSED DUPLICATE of bug 59698
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtkhtml   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-08 02:56 UTC by Bill Crawford
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 21:12:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Crawford 2001-12-08 02:56:51 UTC
Description of Problem:
An extra entry for "HTML Viewer" appears under a menu tree item labelled
"*MISSINGNAME*" in the control-center

Version-Release number of selected component (if applicable):
control-center-1.4.0.1-19
gtkhtml-1.0.0-1

How Reproducible:
Open gnomecc with the latest gtkhtml installed ...

Additional Information:
Stray file is /usr/share/control-center/capplets/gtkhtml-properties.desktop
which appears to be a misplaced copy of
/usr/share/control-center/Documents/gtkhtml-properties.desktop ...

Comment 1 Havoc Pennington 2001-12-16 16:25:26 UTC
Blah, gtkhtml probably expects the newer control center shell. No plans to
upgrade to that so will probably just move gtkhtml-properties.desktop



Comment 2 Martin Norback 2001-12-17 13:36:28 UTC
gtkhtml also provides the following files:

/etc/CORBA/servers
/usr/bin
/usr/share/control-center
/usr/share/control-center/Documents
/usr/share/control-center/capplet
/usr/share/gnome
/usr/share/gnome/apps
/usr/share/gnome/apps/Settings
/usr/share/gnome/apps/Settings/Documents
/usr/share/gnome/html
/usr/share/oaf

which are provided by other, more basic packages, and should not be provided by
the gtkhtml package.

I've probably missed a few here as well.

All of these will trigger the nasty "directory is not empty" when removing the
rpm, at least I think so.

On a side note, doing tpm -qf /usr/bin gives the following:

filesystem-2.0.7-1
koffice-2.0.1-2
kdegames-2.1.1-1
kdegraphics-2.1.1-1
klyx-0.11-2
gtkhtml-1.0.0-1

so there are more packages than just gtkhtml that does this thing.

Comment 3 Bill Crawford 2001-12-17 14:43:00 UTC
This isn't necessarily a bad thing with shared paths ... it means that whatever
order you remove packages, as long as all the files get removed, so do the
paths.  If you remove packages on Solaris, for example, you'll see messages like
"Not removing share path /foo/bar/fum" ...

Comment 4 Havoc Pennington 2001-12-17 15:14:19 UTC
Having multiple packages own a directory is OK, though owning /usr/bin is a bit
silly it's also harmless.

Comment 5 Havoc Pennington 2002-02-26 21:15:31 UTC

*** This bug has been marked as a duplicate of 59698 ***


Note You need to log in before you can comment on or make changes to this bug.