Bug 572771 - Thaw doesn't work after hibernate with F-13
Thaw doesn't work after hibernate with F-13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-11 18:52 EST by Bojan Smojver
Modified: 2013-01-10 00:46 EST (History)
12 users (show)

See Also:
Fixed In Version: anaconda-13.40-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 02:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2010-03-11 18:52:47 EST
Description of problem:
The machine would not thaw after it has been hibernated. This is a Dell Inspiron 6400. This is vanilla (default desktop) install of F-13 alpha, with updates up to 11 Mar 2010.

Version-Release number of selected component (if applicable):
kernel-2.6.33-1.fc13

How reproducible:
Always.

Steps to Reproduce:
1. Hibernate.
2. Attempt to thaw.

  
Actual results:
Grub is set to zero timeout on hibernate, so this bit whizzes by quickly. There is no attempt to resume from the image saved to swap that I can see. Later on in the boot process, it is reported that an image has been found on swap and that the swap space will be reinitialised.

Expected results:
F-12 thaws fine on this box (without KMS). Disabling KMS is not an option - Intel driver doesn't work any more.

Additional info:
See: https://bugzilla.redhat.com/show_bug.cgi?id=537494#c31
Comment 1 Bojan Smojver 2010-04-08 02:09:23 EDT
Just updated to the latest, including the -24 kernel which will be in beta. Still no thaw.

Guys, this is clearly a regression. Am I the only one reporting it?
Comment 2 Bojan Smojver 2010-04-09 05:47:06 EDT
(In reply to comment #1)

> Guys, this is clearly a regression. Am I the only one reporting it?    

Looks like other people noticed the same:

http://www.thinkwiki.org/wiki/Installing_Fedora_13_on_a_ThinkPad_X40

Can we get some feedback on this?
Comment 3 Bojan Smojver 2010-04-14 19:51:32 EDT
I just changed priority/severity to high, because without this we cannot beat F-13 into shape regarding problems with hibernate/thaw and Intel graphics.

See: https://bugzilla.kernel.org/show_bug.cgi?id=13811
Also see: bug #537494.
Comment 4 Bojan Smojver 2010-04-20 05:46:33 EDT
Still doesn't work, with fully updated F-13 as of 2010-04-20. Kernel from koji: 2.6.33.2-56.fc13.i686.PAE.

Has anyone even looked at this bug?
Comment 5 Bojan Smojver 2010-04-29 17:52:38 EDT
Just dropped the Dell Inspiron 6400 from the title of this bug. My new Dell Studio 1588 notebook also cannot thaw.
Comment 6 Jesse Keating 2010-04-29 18:40:18 EDT
I'll put this on the blocker for review, but I'm not all that optimistic that it would be a release blocker.  Nowhere within our release criteria https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria do we have anything about suspend or hibernate.  But that's why we do review, to make a group decision.
Comment 7 Bojan Smojver 2010-04-29 20:00:18 EDT
Yeah, I went through the release criteria myself and hibernate/thaw wasn't there. Who knows, maybe it should be?

It's just that it's a regression, so I'm surprised nobody noticed it. Suspend/resume is nice, but not so much when your battery dies :-)

PS. I'll bet $5 that the fix will be less than 10 lines ;-)
Comment 8 Bojan Smojver 2010-04-29 20:03:32 EDT
Oh, and thanks!
Comment 9 Orion Poplawski 2010-04-30 10:51:15 EDT
Just a comment that hibernate/thaw works fine for me on two different machines, so it's surely not affecting everyone.
Comment 10 Adam Williamson 2010-04-30 15:09:20 EDT
This bug was discussed at the 2010/04/30 blocker review meeting. 

We agreed it is not a release blocker. We generally do not consider suspend/hibernate bugs which are hardware-specific as blockers, as it's unrealistic to expect all possible suspend/hibernate scenarios to work (they never have for any release). We would consider an issue which caused all, or the vast majority, of systems to fail to suspend/hibernate properly as a blocker, but that would be all. This is why there is (intentionally) no criterion for suspend/hibernate functionality.

We would accept a fix for this for the final release if it's ready in time (Tuesday 2010/05/04), and is reasonably small / safe.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Bojan Smojver 2010-04-30 19:30:20 EDT
(In reply to comment #9)
> Just a comment that hibernate/thaw works fine for me on two different machines,
> so it's surely not affecting everyone.    

Out of curiosity, what's you file system setup? Is it using LVM or straight partitions?
Comment 12 Bojan Smojver 2010-05-04 02:34:58 EDT
Found the culprit. Anaconda put these into my kernel line of /boot/grub/grub.conf:

kernel /vmlinuz-2.6.33.3-72.fc13.i686.PAE ro root=/dev/mapper/vg00-f13 rd_LVM_LV=vg00/f13 rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us

When I changed to:

kernel /vmlinuz-2.6.33.3-72.fc13.i686.PAE ro root=/dev/mapper/vg00-f13 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us

Hibernate started working again.

So, something to do with Anaconda/dracut, I guess. Not sure exactly how rd_NO_LUKS rd_NO_MD rd_NO_DM affected the who thing, but they did.
Comment 13 Michal Schmidt 2010-05-04 03:15:15 EDT
So removing the rd_* options from the command line makes it work. These options are interpreted by the initramfs. Reassigning to dracut then.
Comment 14 Bojan Smojver 2010-05-04 03:49:32 EDT
Changing priority/severity to medium, because there is a known workaround.
Comment 15 Bojan Smojver 2010-05-04 04:18:23 EDT
(In reply to comment #12)
 
> So, something to do with Anaconda/dracut, I guess. Not sure exactly how
> rd_NO_LUKS rd_NO_MD rd_NO_DM affected the who thing, but they did.    

Ah, darn cut'n'paste... I also cut out rd_LVM_LV=vg00/f13, as can be seen above.
Comment 16 Harald Hoyer 2010-05-04 04:38:42 EDT
where are your swap partitions located?
Comment 17 Harald Hoyer 2010-05-04 04:39:48 EDT
anaconda should probably honor the swap partitions in the setup of the dracut arguments.
Comment 18 Bojan Smojver 2010-05-04 05:07:49 EDT
(In reply to comment #16)
> where are your swap partitions located?    

On LVM:

/dev/mapper/vg00-lv01 swap swap defaults 0 0

BTW, the workaround also makes Studio 1558 thaw just fine.

Have this in the kernel line there:

kernel /vmlinuz-2.6.33.3-72.fc13.x86_64 ro root=/dev/mapper/vg00-lv00 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us
Comment 19 Harald Hoyer 2010-05-04 05:11:13 EDT
the correct fix would be for you to add "rd_LVM_LV=vg00/lv01" to the original kernel command line
Comment 20 Bojan Smojver 2010-05-04 05:38:55 EDT
OK, lemme try that.
Comment 21 Bojan Smojver 2010-05-04 05:50:16 EDT
(In reply to comment #19)
> the correct fix would be for you to add "rd_LVM_LV=vg00/lv01" to the original
> kernel command line    

Yeah, that works. Now I have:

kernel /vmlinuz-2.6.33.3-72.fc13.x86_64 ro root=/dev/mapper/vg00-lv00 rd_LVM_LV=vg00/lv00 rd_LVM_LV=vg00/lv01 rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us
Comment 22 Hans de Goede 2010-05-04 06:33:55 EDT
Fixing this would require cherry picking the following patches to F-13 branch:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=cbd54442e4f3f839032135bde73c837a44bb4b75
http://git.fedorahosted.org/git?p=anaconda.git;a=commitdiff;h=fd25f5c189e26f66c1c4872956ee7b769b257cfa

The first one has seen quite a bit of testing in RHEL-6, the second one is new but pretty safe. So if someone can make a call if this is a F13Blocker or not I'll cherry pick them (or not).
Comment 23 Michal Schmidt 2010-05-04 07:47:34 EDT
Since this is a bug in anaconda, does it mean that it cannot be reasonably fixed in a post-release update?
Comment 24 Hans de Goede 2010-05-04 08:00:02 EDT
(In reply to comment #23)
> Since this is a bug in anaconda, does it mean that it cannot be reasonably
> fixed in a post-release update?    

Correct.
Comment 25 Michal Schmidt 2010-05-04 08:19:42 EDT
In that case I say it really should be a blocker...

(In reply to comment #10)
> We agreed it is not a release blocker. We generally do not consider
> suspend/hibernate bugs which are hardware-specific as blockers,

Based on the findings here, it is not hw-specific.

> We would consider an issue which caused all, or
> the vast majority, of systems to fail to suspend/hibernate properly as a
> blocker, but that would be all.

This one will cause most systems to fail to resume from hibernation,
as the default installation uses swap on LVM.

And it cannot be solved by a post-release update.
Comment 26 Adam Williamson 2010-05-04 08:30:29 EDT
Yeah, I agree this is a blocker given the better diagnosis we have of the problem. Please pull the fix into the next anaconda.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Hans de Goede 2010-05-04 10:09:45 EDT
This is fixed in anaconda-13.40-1, moving to modified.
Comment 28 Adam Williamson 2010-05-04 19:04:20 EDT
Bojan, can you please test with this updates.img:

http://people.fedoraproject.org/~jwrdegoede/f13-updates.img

? it should fix the bug. Thanks!
Comment 29 Bojan Smojver 2010-05-04 19:36:01 EDT
(In reply to comment #28)
> Bojan, can you please test with this updates.img:
> 
> http://people.fedoraproject.org/~jwrdegoede/f13-updates.img
> 
> ? it should fix the bug. Thanks!    

OK. I guess I supply this image to F-13 Beta installer, correct?
Comment 30 Adam Williamson 2010-05-04 20:34:31 EDT
yeah (or, well, even TC1: http://serverbeach1.fedoraproject.org/pub/alt/stage/13.TC1/ )

use updates=http://people.fedoraproject.org/~jwrdegoede/f13-updates.img as a kernel parameter.
Comment 31 Bojan Smojver 2010-05-04 20:45:59 EDT
OK, thanks. I'm guessing the image will be good for both i686 and x86_64, right? I have both here...

Anyhow, I'm busy doing my day job right now (bills have to be paid and all that), so I'll do this sometime tonight, Sydney time.
Comment 32 Fedora Update System 2010-05-05 01:16:25 EDT
anaconda-13.40-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 33 Fedora Update System 2010-05-05 03:22:57 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 34 Bojan Smojver 2010-05-05 07:26:36 EDT
(In reply to comment #31)
> OK, thanks. I'm guessing the image will be good for both i686 and x86_64,
> right? I have both here...

Tried on x86_64, got bug #589088.
Comment 35 Hans de Goede 2010-05-05 08:29:06 EDT
(In reply to comment #34)
> (In reply to comment #31)
> > OK, thanks. I'm guessing the image will be good for both i686 and x86_64,
> > right? I have both here...
> 
> Tried on x86_64, got bug #589088.    

Bug 589088 is caused by using an updates.img meant to be used with TC1 with the beta. You must use the provided updates.img with TC1, it can be used with either i686 or x86_64.
Comment 36 Bojan Smojver 2010-05-05 08:49:40 EDT
Right, thanks. I'll download that tomorrow and try again. I tried with Beta, which I used previously to install this box.
Comment 37 Hans de Goede 2010-05-05 09:25:26 EDT
(In reply to comment #36)
> Right, thanks. I'll download that tomorrow and try again. I tried with Beta,
> which I used previously to install this box.    

Great thanks for testing!
Comment 38 Adam Williamson 2010-05-05 12:58:24 EDT
We should now be able to confirm that this bug is fixed using the images here:

http://alt.fedoraproject.org/pub/alt/stage/13.0505/Fedora/i386/os/images/

if we have not yet confirmed the fix, can anyone able to reproduce this bug please test with one of those images and check that the bug is fixed? Thanks.
Comment 39 Jesse Keating 2010-05-05 15:19:31 EDT
Verified the right stuff shows up in the grub config, and pm-hibernate/thaw works as expected.
Comment 40 Bojan Smojver 2010-05-05 20:38:39 EDT
(In reply to comment #38)
> We should now be able to confirm that this bug is fixed using the images here:
> 
> http://alt.fedoraproject.org/pub/alt/stage/13.0505/Fedora/i386/os/images/
> 
> if we have not yet confirmed the fix, can anyone able to reproduce this bug
> please test with one of those images and check that the bug is fixed? Thanks.    

Downloading now.
Comment 41 Adam Williamson 2010-05-05 21:29:16 EDT
I think we'll wait for Bojan's confirmation to close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 42 Bojan Smojver 2010-05-05 23:16:37 EDT
(In reply to comment #41)
> I think we'll wait for Bojan's confirmation to close this.

Works! Ship it boys :-)

PS. I installed next to my x86_64 and noticed a few things:

1. I used custom FS layout. Anaconda was unable to recognise my existing swap partition as swap, so I created another one, which was then added to the kernel line under rd_LVM_LV, together with the new root partition. I'm guessing because there was an existing hibernation image on that partition (that of x86_64), so it was careful not to break it. Hopefully on purpose.

2. I was expecting that my existing grub.conf, which had references to my existing x86_64 F-13, would be preserved. Not so. I simply got one entry - that of the new i686 install done by 13.0505. Not sure about that one.

This was in grub.conf after installation:

title Fedora (2.6.33.3-79.fc13.i686.PAE)
	root (hd0,0)
	kernel /vmlinuz-2.6.33.3-79.fc13.i686.PAE ro root=/dev/mapper/vg00-f13.0505 rd_LVM_LV=vg00/f13.0505 rd_LVM_LV=vg00/f13.0505.swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
	initrd /initramfs-2.6.33.3-79.fc13.i686.PAE.img
Comment 43 Fedora Update System 2010-05-06 02:55:06 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.