Bug 5729 - Netscape 4.7 RPM chkfontpath BAD
Netscape 4.7 RPM chkfontpath BAD
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 5709 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 10:36 EDT by Andrew Schretter
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-08 19:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Schretter 1999-10-08 10:36:15 EDT
Your netscape 4.7 RPM dies on just about any
Java page, the reason, you explicitly removed the font
path /usr/X11R6/lib/fonts/75dpi from the font servers
paths.  Why?  I have no clue, even Netscape says its a
bug and tells us to put it back in.  This might not be
needed for RedHat 6.1 but definitely for 6.0.

Just change your SRPM spec file and replace the line :

 /usr/sbin/chkfontpath -q -r /usr/X11R6/lib/X11/fonts/75dpi

with

 /usr/sbin/chkfontpath -q -a /usr/X11R6/lib/X11/fonts/75dpi

so we can be happy.

Andrew
Comment 1 Bill Nottingham 1999-10-08 11:01:59 EDT
Yikes, that is broken. Fixed packages should appear later today
at some point...
Comment 2 Bill Nottingham 1999-10-08 15:46:59 EDT
*** Bug 5709 has been marked as a duplicate of this bug. ***

Can't print anything in Netscape print menu although all
WordPerfect files print OK.

Netscape was reinstalled in vain (ver 4.7)
The error on the printed pages states:

Error: /invalidfont in findfont
                               Operand stack:
                                                F0
Times-Roman   Font   Times


This appears to be a damaged font or a damaged font finder.
Is there a workaround to fix this. I suspect that it was
introduced with a bug contained in the XFREE86 rpms, but
that's only a guess.


------- Additional Comments From notting@redhat.com  10/08/99 11:49 -------
Run (as root):

chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi
/etc/rc.d/init.d/xfs reload

That should solve it.
Comment 3 Bill Nottingham 1999-10-08 19:43:59 EDT
fixed in the errata 4.7-1.1 release, available now.

Note You need to log in before you can comment on or make changes to this bug.