Bug 573675 - Does not detect Hauppauge lirc_dev correctly
Summary: Does not detect Hauppauge lirc_dev correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lirc
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 575642 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-15 14:56 UTC by Kim Bisgaard
Modified: 2010-03-30 02:24 UTC (History)
4 users (show)

Fixed In Version: kernel-2.6.32.10-90.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-18 15:51:20 UTC


Attachments (Terms of Use)

Description Kim Bisgaard 2010-03-15 14:56:09 UTC
Description of problem:
Does not detect Hauppauge lirc_dev correctly

Version-Release number of selected component (if applicable):
Kernel > 2.6.31

How reproducible:
Always

Additional info:
If I use the updated lirc package (0.8.6-4), besides not working *it will
consume 1 core at full speed!*

Below is with lirc-0.8.6-1

With 2.6.31 (working):
Mar 10 19:09:15 jukebox kernel: Linux version 2.6.31.12-174.2.22.fc12.i686
(mockbuild@x86-04.phx2.fedoraproject.org) (gcc version
 4.4.3 20100127 (Red Hat 4.4.3-4) (GCC) ) #1 SMP Fri Feb 19 19:26:06 UTC 2010
Mar 10 19:09:45 jukebox kernel: lirc_dev: IR Remote Control driver registered,
major 249 
Mar 10 19:09:45 jukebox kernel: lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge
IR)
Mar 10 19:09:45 jukebox kernel: i2c ir driver 3-0018: lirc_dev: driver lirc_i2c
registered at minor = 0
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: accepted new client on
/var/run/lirc/lircd
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: could not get hardware features
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: this device driver does not support
the LIRC ioctl interface
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: major number of /dev/lirc0 is 249
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: LIRC major number is 61
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: check if /dev/lirc0 is a LIRC device
Mar 10 19:11:07 jukebox lircd-0.8.6[1188]: Failed to initialize hardware
Mar 10 19:16:59 jukebox lircd-0.8.6[1188]: caught signal
Mar 10 19:16:59 jukebox lircd-0.8.6[3984]: lircd(default) ready, using
/var/run/lirc/lircd
Mar 10 19:17:01 jukebox lircd-0.8.6[3984]: accepted new client on
/var/run/lirc/lircd

with 2.6.32.9-70 (Not working):
Linux version 2.6.32.9-70.fc12.i686 (mockbuild@x86-02.phx2.fedoraproject.org)
(gcc version 4.4.3 
20100127 (Red Hat 4.4.3-4) (GCC) ) #1 SMP Wed Mar 3 05:14:32 UTC 2010
Mar 13 13:45:30 jukebox lircd-0.8.6[1305]: lircd(default) ready, using
/var/run/lirc/lircd
Mar 13 13:46:02 jukebox kernel: lirc_dev: IR Remote Control driver registered,
major 249 
Mar 13 13:46:02 jukebox kernel: lirc_i2c: chip 0x0 found @ 0x18 (Leadtek IR)
Mar 13 13:46:02 jukebox kernel: i2c ir driver 3-0018: lirc_dev: driver lirc_i2c
registered at minor = 0
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: accepted new client on
/var/run/lirc/lircd
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: could not get hardware features
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: this device driver does not support
the LIRC ioctl interface
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: major number of /dev/lirc0 is 249
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: LIRC major number is 61
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: check if /dev/lirc0 is a LIRC device
Mar 13 13:46:34 jukebox lircd-0.8.6[1305]: Failed to initialize hardware

Comment 1 Jarod Wilson 2010-03-16 19:29:06 UTC
Okay, this *should* be fixed by a kernel build currently working its way through the build system:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2057058

Please give it a go once its done building...

Comment 2 Jarod Wilson 2010-03-16 21:33:21 UTC
Build just finished, please give it a try and let me know if it is indeed fixed...

Comment 3 Kim Bisgaard 2010-03-18 15:34:02 UTC
I do not think it is working - at least it still detects falsely:
Mar 18 16:12:22 jukebox kernel: lirc_dev: IR Remote Control driver registered, major 249 
Mar 18 16:12:22 jukebox kernel: lirc_i2c: chip 0x0 found @ 0x18 (Hauppauge IR)
Mar 18 16:12:22 jukebox kernel: i2c ir driver 0-0018: lirc_dev: driver lirc_i2c registered at minor = 0

I am not totally certain because I have not been able to boot into X and test as usual, for various mindbugging reasons :-/

Comment 4 Jarod Wilson 2010-03-18 15:51:20 UTC
(In reply to comment #3)
> I do not think it is working - at least it still detects falsely:
> Mar 18 16:12:22 jukebox kernel: lirc_dev: IR Remote Control driver registered,
> major 249 
> Mar 18 16:12:22 jukebox kernel: lirc_i2c: chip 0x0 found @ 0x18 (Hauppauge IR)
> Mar 18 16:12:22 jukebox kernel: i2c ir driver 0-0018: lirc_dev: driver lirc_i2c
> registered at minor = 0
> 
> I am not totally certain because I have not been able to boot into X and test
> as usual, for various mindbugging reasons :-/    

That actually looks as expected. The 'chip 0x0' part is the struct i2c_adap->id field, which is deprecated and removed from the cx2341x driver, and thus 0. lirc_i2c has initialized the IR part at address 0x18, and it *should* be functional now.

In the future, more devices will lose that id field, and we'll have to do something better to figure out which exact device we're talking to, but I've already got something in mind for that... Basically, each device will need to identify itself on the i2c bus with a distinct name, rather than all devices lirc_i2c attaches to being identified as 'ir_video' parts... Anyway. Yeah, you should be fine now. Holler if it doesn't actually work, but I had someone on the mythtv users list also test this build and their hauppauge IR was working fine again.

Comment 5 Jarod Wilson 2010-03-22 13:59:35 UTC
*** Bug 575642 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-03-23 14:56:08 UTC
kernel-2.6.32.10-90.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.10-90.fc12

Comment 7 Fedora Update System 2010-03-30 02:23:47 UTC
kernel-2.6.32.10-90.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.