Bug 57403 - SDL-devel requires superfluous libs
Summary: SDL-devel requires superfluous libs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SDL (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 58054 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-11 17:57 UTC by Ed McKenzie
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-11 17:57:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-12-11 17:57:10 UTC
up2date SDL-devel pulled in the following libs:

kdelibs
kdelibs-sound
qt-devel
kdelibs-devel
kdelibs-sound-devel
SDL-devel

Comment 1 Bernhard Rosenkraenzer 2001-12-13 13:05:23 UTC
No, they're actually needed.

SDL links to arts, which is in kdelibs-sound.

sdl-config --libs says:
[...] -lartsc [...]

Therefore you need kdelibs-sound-devel to link an SDL application.

In the next release, arts will be separated from kdelibs. Until then, these 
libraries are all but superfluous.


Comment 2 Bernhard Rosenkraenzer 2002-01-08 13:01:18 UTC
*** Bug 58054 has been marked as a duplicate of this bug. ***

Comment 3 Bernhard Rosenkraenzer 2002-01-08 17:18:50 UTC
*** Bug 58054 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.