Bug 58054 - SDL-devel depends on kde-sound-devel
SDL-devel depends on kde-sound-devel
Status: CLOSED DUPLICATE of bug 57403
Product: Red Hat Linux
Classification: Retired
Component: SDL (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-07 08:06 EST by Mike Shaver
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 12:10:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Shaver 2002-01-07 08:06:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
In order to install SDL-devel, I apparently need to install kde-sound-devel,
which ends up pulling in a pile of KDE stuff I have no particular interest in,
with a finale of fam and xinetd.

This seems pretty unreasonable, especially with the additional joy of:

<bcrl> shaver: if you're running rh, stick to the rh sdl packages as others are
subtly incompatible (no, i can't figure out why)

If you can't factor SDL-devel such that there's an additional, optional package
for the KDE bits, please at least provide an alternate, conflicting package
(SDL-devel-nokde) for those of us who don't really want to pull in the universe.

Version-Release number of selected component (if applicable):
SDL-devel-1.2.2-3

How reproducible:
Always

Steps to Reproduce:
1. Develop wacky desire to install SDL-devel.

2. Using red carpet or a scratchpad, compute the transitive closure of the
package dependencies.

3. Weep.
Comment 1 Bernhard Rosenkraenzer 2002-01-08 08:01:23 EST
Please don't report stuff that has been reported and closed long before.
See bugs #57403 and #57325.


*** This bug has been marked as a duplicate of 57403 ***
Comment 2 Mike Shaver 2002-01-08 12:10:13 EST
Uh, very sorry, but I searched for "SDL depend" on the bug entry form and found
no bugs, so I thought I'd report it.  (How was I supposed to find "Why do I
_need_ kdelibs-sound-devel ???" to know that it had been reported and closed?) 
If it's such a hardship to handle duplicate bugs, you might want to change the
summaries on the ones you deal with so that other reports have a hope of finding
them.

Of course, I still think it's possible to package things such that you don't
have to install kdelibs-sound-devel in order to use SDL-devel in the general
case.  Why?  Because you can use SDL without the kdelibs-sound stuff installed!
 If you split the package such that there's a separate SDL-devel-kdebits
package, as I suggest above, then people won't have to drag down another 50M of
KDE nonsense in order to compile a program against the SDL headers and libs.

Reopening, not just because I'm a jerk, but also because I'd like to understand
why that packaging change isn't possible.  I seem to recall that the debian guys
had packaging setup for a while, but the recollection is dim.  I'll look for
more details on that later, and post here.
Comment 3 Bernhard Rosenkraenzer 2002-01-08 12:18:55 EST
The explanation can be found in the resolutions of the bugs mentioned in my earlier comment. (Also note that SDL-devel requires kdelibs-sound-devel, not SDL itself).

Basically:
SDL supports the KDE sound system, arts.
Therefore, sdl-config --libs outputs, among other things: -lartsc
As a result, anything trying to link against SDL will use gcc -lartsc, thereby
requiring /usr/lib/libartsc.so, which is provided by kdelibs-sound-devel.

The fix is to package libarts* separately, this has been done in rawhide, but not in time for 7.2.

If you need more details, take a look at the current rawhide packages and the duplicates.


*** This bug has been marked as a duplicate of 57403 ***
Comment 4 Mike Shaver 2002-01-08 12:46:25 EST
I read those bugs, and then I checked my system:

: bootstrap; rpm -qf /usr/lib/libartsc.so
arts-2.2-11

N.B.: not in kdelibs-sound-devel, nor kdelibs-sound.

So as far as I can tell, the explanation given in those bugs is _not_ correct.

IUs the real problem here that you guys split arts out, but not arts-devel?  If
I fix the spec file to produce a separate arts-devel, would you take it as an
RH7.2 update?

Note You need to log in before you can comment on or make changes to this bug.