Bug 574332 - [abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib/firefox-3.5.8/firefox was killed by signal 11 (SIGSEGV)
[abrt] crash in firefox-3.5.8-1.fc12: Process /usr/lib/firefox-3.5.8/firefox ...
Status: CLOSED DUPLICATE of bug 574318
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:fbfffa700e9e3f4eb88594c39d5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 05:01 EDT by Michele Castigliego
Modified: 2010-09-20 09:21 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 09:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (29.26 KB, text/plain)
2010-03-17 05:01 EDT, Michele Castigliego
no flags Details
./run-mozilla -g firefox -d gdb (3.43 KB, text/plain)
2010-03-17 11:15 EDT, Tobias Florek
no flags Details

  None (edit)
Description Michele Castigliego 2010-03-17 05:01:33 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5.8/firefox
component: firefox
executable: /usr/lib/firefox-3.5.8/firefox
kernel: 2.6.32.9-70.fc12.i686.PAE
package: firefox-3.5.8-1.fc12
rating: 3
reason: Process /usr/lib/firefox-3.5.8/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Michele Castigliego 2010-03-17 05:01:36 EDT
Created attachment 400694 [details]
File: backtrace
Comment 2 Giandomenico De Tullio 2010-03-17 05:53:17 EDT

How to reproduce
-----

1. run firefox



Comment
-----
 After updated gtk2 from updates-testing, I run firefox
(clicked an https:// url and so  launched firefox)

Perhaps a false-positive?
Comment 3 Giandomenico De Tullio 2010-03-17 06:58:29 EDT
No, it is *NOT* a  false-positive: 


$ firefox --debug 


Program received signal SIGSEGV, Segmentation fault.
0x00c85b83 in g_type_check_instance_cast () from /lib/libgobject-2.0.so.0
(gdb) 

rebuilding w/ new gtk2? ^.-
Comment 4 Giandomenico De Tullio 2010-03-17 07:04:46 EDT
ops, gobject-2.0 is not from gtk2 but glib2 :/

# rpm -qa "glib2*"
glib2-devel-2.22.4-2.fc12.i686
glib2-2.22.4-2.fc12.i686
errore: rpmdbNextIterator: salto h#    4247 firma Header V3 RSA/SHA256 : BAD, ID chiave 57bbccba


WTF?
Comment 5 Giandomenico De Tullio 2010-03-17 07:23:59 EDT
see http://article.gmane.org/gmane.comp.gnome.gtk%2B.devel.general/18599 

relaunched thunderbird-3.0.3 also then create bugid: rh #574369 
     https://bugzilla.redhat.com/show_bug.cgi?id=574369
Comment 6 adalsaady 2010-03-17 08:39:38 EDT

How to reproduce
-----
1. run it
2. crash
3.


Comment
-----
there is no window just crash when I open it
Comment 7 adalsaady 2010-03-17 09:04:35 EDT
bash-4.0$ firefox -safe-mode

(firefox:2901): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkEntry'

(firefox:2901): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkWidget'

(firefox:2901): Gtk-CRITICAL **: gtk_widget_has_screen: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:2901): GLib-GObject-WARNING **: invalid cast from `(null)' to `GtkEntry'

(firefox:2901): GLib-GObject-WARNING **: invalid cast from `(null)' to `GtkWidget'

(firefox:2901): Gtk-CRITICAL **: gtk_widget_has_screen: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:2901): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkEntry'

(firefox:2901): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkWidget'

(firefox:2901): Gtk-CRITICAL **: gtk_widget_has_screen: assertion `GTK_IS_WIDGET (widget)' failed


bash-4.0$ firefox
/usr/lib/firefox-3.5.8/run-mozilla.sh: line 131:  2936 Segmentation fault      (core dumped) "$prog" ${1+"$@"}


I hope this will help to fix it
Comment 8 Michele Castigliego 2010-03-17 09:28:53 EDT
I removed gtk2 package from testing reverting to updates one 2.18.7 1.fc12 and it works again now.
Comment 9 Anne 2010-03-17 09:57:42 EDT

Comment
-----
I attempted to start firefox after running updates then logging out to re-start X
Comment 10 adalsaady 2010-03-17 09:59:50 EDT
(In reply to comment #8)
> I removed gtk2 package from testing reverting to updates one 2.18.7 1.fc12 and
> it works again now.    

and it works with me again
thanks
Comment 11 Anne 2010-03-17 10:02:51 EDT
Is the following message relevant?

warning: user mockbuild does not exist - using root

I've never seen that in updates before.
Comment 12 Tobias Florek 2010-03-17 11:08:41 EDT

How to reproduce
-----
1. start firefox w/ noscript extension (from mozilla-noscript package or from addons.mozilla.org does not matter)
2. watch it segfault


Comment
-----
this does not happen w/o noscript. running firefox in gdb shows, that it segfaults in g_type_check_instance_cast () from /lib/libgobject-2.0.so.0. i can attach a log, but the backtrace should contain more info.

(if you came here for info to avoid it, start firefox in safe mode and disable noscript:
% firefox -safe-mode
)
Comment 13 Tobias Florek 2010-03-17 11:15:41 EDT
Created attachment 400797 [details]
./run-mozilla -g firefox -d gdb

this is a ./run-mozilla -g firefox -d gdb
Comment 14 mma 2010-03-17 12:45:01 EDT

How to reproduce
-----
1. just installed firefox
2. have old .mozilla/forefox Data in $HOME
3. he crashes bevor main windows opens
Comment 15 Alexey Kazakov 2010-03-17 14:25:15 EDT

How to reproduce
-----
1. Try to start firefox.


Comment
-----
Firefox won't start
Comment 16 arturpolak1 2010-03-17 17:02:54 EDT

How to reproduce
-----
1.Do all the software updates
2.Run Firefox
3.Upss... Bug... :(( Firefox won't start...
Comment 17 Witek Mozga 2010-03-17 18:37:03 EDT

How to reproduce
-----
1. just run firefox
2.
3.


Comment
-----
I did "yum update" using updates-testing enabled
Comment 18 qwerttre 2010-03-17 20:49:40 EDT

How to reproduce
-----
1.run firefox
2.
3.


Comment
-----
last night I updated to the latest packages in updates-testing and now I try to run firefox and all I get is a crash
Comment 19 Samuel 2010-03-18 04:29:07 EDT

How to reproduce
-----
1. just start firefox
2.
3.
Comment 20 Yihya Hugirat 2010-03-18 04:43:47 EDT

How to reproduce
-----
1.i have but the laptop to sleep
2. after that started firefox then i got this error
3.
Comment 21 Giandomenico De Tullio 2010-03-18 04:46:49 EDT
I've checked upcoming gtk2-2.18.9 for f12-updates-testing from koji,

it fixes the problem.
Comment 22 mma 2010-03-19 06:57:39 EDT

How to reproduce
-----
1. just installed firefox
2. have old .mozilla/forefox Data in $HOME
3. he crashes bevor main windows opens
Comment 23 Tobias Florek 2010-03-22 09:23:04 EDT
this can be closed w/ latest gtk2-update
Comment 24 Pavel Mlčoch 2010-03-30 03:27:37 EDT

How to reproduce
-----
1. Start my firefox by click
Comment 25 Matěj Cepl 2010-09-20 09:21:37 EDT

*** This bug has been marked as a duplicate of bug 574318 ***

Note You need to log in before you can comment on or make changes to this bug.