Bug 574602 - Upgrading to 1.3.1 results in JBossESB plug-in file name mismatches
Upgrading to 1.3.1 results in JBossESB plug-in file name mismatches
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
1.3.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon24-soap
  Show dependency treegraph
 
Reported: 2010-03-17 18:25 EDT by Larry O'Leary
Modified: 2014-09-02 10:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 11:01:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2010-03-17 18:25:30 EDT
Description of problem:

If the JBossESB plug-in is installed (rhq-jbossesb-soa-plugin-SOA.4.3.0.GA_CP02.jar) and you upgrade RHQ to 1.3.1 with the JBossESB plug-in for 1.3.1 (rhq-jbossesb-plugin-SOA.4.3.0.GA_CP02.jar) you will receive an INFO message every five minutes stating the following:

INFO  [org.rhq.enterprise.server.core.plugin.AgentPluginDeploymentScanner] Filesystem has a plugin [JBossESB] at the file [/local/jon-server-2.3.1.GA/jbossas/server/default/deploy/rhq.ear/rhq-downloads/rhq-plugins/rhq-jbossesb-plugin-SOA.4.3.0.GA_CP02.jar] which is different than where the DB thinks it should be [/local/jon-server-2.3.1.GA/jbossas/server/default/deploy/rhq.ear/rhq-downloads/rhq-plugins/rhq-jbossesb-soa-plugin-SOA.4.3.0.GA_CP02.jar]


This does not appear to impact the JBossESB plug-in other then the annoying messages.
Version-Release number of selected component (if applicable):
RHQ 1.3.0 -> 1.3.1
JBossESB plug-in for 1.3.1

How reproducible:
Always


Steps to Reproduce:
1. Install JON 2.3 along with SOA-P plug-in pack
2. Install JON 2.3.1 using upgrade instructions to upgrade the 2.3 installation making sure to install the new JBossESB plug-in for 2.3.1
3. Start the server as normal
  
Actual results:
Every five minutes get a log message stating that the JBossESB plug-in file name according to the database is rhq-jbossesb-soa-plugin-SOA.4.3.0.GA_CP02.jar and according to the file system is rhq-jbossesb-plugin-SOA.4.3.0.GA_CP02.jar.

Expected results:
No strange log messages indicating that there is a plug-in problem.

Additional info:

This issue seems to be a direct result of the JBossESB plug-in file name changing since 1.3.0.  The actual JBossESB plug-in contents did not change between these releases and therefore the version information in the file did not change.  Because the version info didn't change, JON did not upgrade the plug-in in the DB because it supposedly hadn't changed.  Even though this message is displayed in the log, it appears to have no negative affect on the plug-in and the Agent's who are using the plug-in.  To workaround the issue:

   1. Go to http://localhost:7080/admin/test/sql.jsp
   2. Execute the following SQL:

      UPDATE rhq_plugin SET path='rhq-jbossesb-plugin-SOA.4.3.0.GA_CP02.jar' WHERE name='JBossESB' AND path='rhq-jbossesb-soa-plugin-SOA.4.3.0.GA_CP02.jar'
Comment 1 Charles Crouch 2010-05-28 10:23:28 EDT
Related jira:  https://jira.jboss.org/jira/browse/SOA-2054
Comment 2 Corey Welton 2010-09-13 16:33:16 EDT
mazz - add whatever is necessary to plugin docs that needs to be done to prevent this
Comment 3 Heiko W. Rupp 2013-12-07 11:01:54 EST
Closing as outdated.

Note You need to log in before you can comment on or make changes to this bug.