Bug 57489 - Old man page for dig and nslookup
Old man page for dig and nslookup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 18:14 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 16:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-13 18:14:36 EST
Description of Problem:
The man page for dig and nslookup is from August 30, 1990. The man page for
nsupdate and host is from 2000.

Version-Release number of selected component (if applicable):
bind-utils-9.1.3-4

How Reproducible:
man dig (press SHIFT+g)
man nslookup (press SHIFT+g)
;-)

Actual Results:
4th Berkeley Distribution        June 24, 1990       4th Berkeley Distribution

Expected Results:
BIND9 9                          Jun 30, 2000                          BIND9 9
Comment 1 James Ralston 2002-03-20 14:20:02 EST
Well, since the bind package doesn't provide a man page for nslookup (probably
because they consider it to be a deprecated program and want to discourage
people from using it), it's probably a good thing that Red Hat provides a man
page (albeit outdated) for it; AFAICT, the outdated man page still matches
current versions of nslookup(8) pretty closely, and the nslookup program in
bind9 doesn't have any built-in documentation.

However, since at least bind 9.1.0 (and perhaps older versions), bind *does*
actually ship with an up-to-date man page for dig(1).  Red Hat's bind package is
stomping bind's dig(1) man page with its own, outdated man page.

Bernhard: please, please, please dike dig.1.gz out of bind-manpages.tar.bz2 and
release an errata update for bind (for all affected Red Hat releases).  The
dig.1.gz in bind-manpages.tar.bz2 is so outdated (w/respect to the dig program
that ships with bind9) that it's leading people astray.
Comment 2 James Ralston 2002-03-20 17:30:15 EST
Oops.  I realize now that bind-manpages.tar.bz2 package might be coming from (or
partially from) the ISC, because Jim Reid mentioned on the bind9-users mailing
list that in BIND8, the man pages were in a separate tarball from the sources.

Bernhard: Jim Reid also said that if Red Hat is writing man pages for bind, they
would appreciate it if Red Hat would feed those man pages back to the ISC.  Just
FYI...
Comment 3 James Ralston 2002-07-16 16:17:50 EDT
This problem has been fixed for Red Hat 7.3.  Specifically, the dig(1) man page
that comes with bind9 is no longer overwritten with the dig(1) man page from
bind-manpages.tar.bz2.

Is there any reason why this bug shouldn't be closed with CURRENTRELEASE?
Comment 4 Karsten Hopp 2002-07-22 09:46:55 EDT
no, there's no reason. Closing now

Note You need to log in before you can comment on or make changes to this bug.