Bug 57490 - "Operating System Not Found"
"Operating System Not Found"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 18:29 EST by Ben Klang
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 11:14:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file used when bug occured, both times. (2.95 KB, text/plain)
2001-12-18 11:14 EST, Ben Klang
no flags Details

  None (edit)
Description Ben Klang 2001-12-13 18:29:52 EST
Description of Problem:
I recently modified a working kickstart install of mine to include a
separate partition for var.  The old configuration had a 2048GB software
raid1 across 2 scsi drives with the remainder on both disks allocated to
another raid1 partition on /other (intentionally omitting swap).  After
installation in this configuration, with the kickstart raid patch from Bug
no. 55310, everything worked as advertised. Upon updating the configuration
to include a 1536mb raid1 partition (/) and a 512mb raid1 (/var) partition,
then allocating the rest to /other.  This leaves me with an unbooting OS.

I then tried to manually step through the disk druid (leaving the packages
to the kick start installation).  EVERYTHING was handled by an identical
kickstart file, with me to do the partitioning interactively.

Old, working configuration:
sda,sdb: 36GB HP SCSI LVD Drives
sd[ab]1: 2048GB software RAID
sb[ab]2: Grow to fill disk software RAID
md0: formatted and mounted on / with ext3 using sd[ab]1
md1: formatted and mounted on /other with ext3 using sd[ab]2

New, non-working configuration:
sd[ab]1: 1536GB software RAID
sd[ab]2: 512MB software RAID
sd[ab]3: Grow to fill disk software RAID
md0: formatted and mounted on / with ext3 using sd[ab]1
md1: formatted and mounted on /var with ext3 using sd[ab]2
md2: formatted and mounted on /other with ext3 using sd[ab3]

In this configuration, I get "Operating system not found" upon rebooting
from the installation.  THe first configuration works fine.

This is RedHat 7.2 with kickstart and the patch from bug #55310.  It is an
HP LP1000R dual-capable, but single processor 933MHz PIII and 2GB of ram. 
It has non-hardware-raid 2xSCSI 36GB HDD's.



Version-Release number of selected component (if applicable):
RedHat 7.2 with grub 0.90-11

How Reproducible:


Steps to Reproduce:
1. See Above
2. 
3. 

Actual Results:
OS Not Found

Expected Results:
Normal Boot

Additional Information:
	Help?
Comment 1 Ben Klang 2001-12-13 18:32:26 EST
Update:
I tried this configuration and it worked:

sda,sdb 36GB SCSI LVD
sd[ab]1: 2048MB software RAID
sd[ab]2: 512MB software RAID
sd[ab]3: Grow to fill remaining, software RAID
md0: sd[ab]1, ext3, mounted to /
md1: sd[ab]2, ext3, mounted to /var
md2: sd[ab]3, ext3, mounted to /other

The ONLY change is that I used 2048MB for each part of md0 instead of 1536mb
partitions.
Comment 2 Jeremy Katz 2001-12-15 02:01:40 EST
What SCSI controller?  Also, where do the cylinder boundaries lie dependent on
the two different partition sizes?
Comment 3 Ben Klang 2001-12-15 02:13:30 EST
The SCSI Controller is a SYM53C800.  I don't know how to answer your question
about cylinder boundaries (unless you can tell me how to get that information)
except to tell you that the two HDs are identical.  They are stock from HP and
the server model is an LP1000R.
Comment 4 Ben Klang 2001-12-18 11:12:33 EST
I have run into the exact same problem again.  On an identically configured
LP1000R, I get "Operating System not found" after using the same floppy I did to
fix the first machine.  I am beginning to wonder if it has something to do with
both machines being factory fresh until I've tried to install them a couple
times.  I am attaching the ks.cfg that I used for both installs.
Comment 5 Ben Klang 2001-12-18 11:14:20 EST
Created attachment 40929 [details]
Kickstart file used when bug occured, both times.
Comment 6 Ben Klang 2001-12-18 17:55:16 EST
Problem appears to be related to bad scsi controllers on the machine.  Very
strange symptom, as machine acted normal if booted via rescue floppy.  Giveaway
should have been when the SCSI BIOS never appeared during POST.  My apologies
for this waste of time.

Note You need to log in before you can comment on or make changes to this bug.