Bug 55310 - Problem with Kickstart and Software RAID?
Problem with Kickstart and Software RAID?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 55949 56827 57964 58322 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 11:09 EST by David Carter
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 15:31:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart File (5.38 KB, text/plain)
2001-10-29 11:11 EST, David Carter
no flags Details
Anaconda Crash Dump (deleted)
2001-10-29 11:19 EST, David Carter
no flags Details
Anaconda Crash Dump (deleted)
2001-10-29 11:19 EST, David Carter
no flags Details
Anaconda Crash Dump (deleted)
2001-10-29 11:21 EST, David Carter
no flags Details
Anaconda Crash Dump (deleted)
2001-10-29 11:47 EST, David Carter
no flags Details
Working ks.cfg, Broken ks.cfg plus anacdump.txt (10.33 KB, application/octet-stream)
2001-10-30 06:56 EST, David Carter
no flags Details

  None (edit)
Description David Carter 2001-10-29 11:09:28 EST
Description of Problem:

Installer bails out with a "TypeError: number coercion failed" if
software RAID mirroring is configured

Version-Release number of selected component (if applicable):

Redhat 7.2 (similar ks.cfg file works just fine in Redhat 7.1)

How Reproducible:

Will attach ks.cfg file and anacdump.txt
Comment 1 David Carter 2001-10-29 11:11:28 EST
Created attachment 35401 [details]
Kickstart File
Comment 2 Brent Fox 2001-10-29 11:13:49 EST
Can you capture the entire debug message when the install crashes?  That would
be helpful.
Comment 3 David Carter 2001-10-30 06:56:08 EST
Created attachment 35661 [details]
Working ks.cfg, Broken ks.cfg plus anacdump.txt
Comment 4 David Carter 2001-10-30 07:02:52 EST
Added a .tar.gz file which contains working and broken Kickstart files plus
anacdump.txt archive. It looks like the problem is specific to mirrored swap
partitions. Difference between working and broken ks.cfg files:

magenta[7.2]$ diff -c test2.cfg  test3.cfg 
*** test2.cfg   Tue Oct 30 11:54:19 2001
--- test3.cfg   Tue Oct 30 11:54:19 2001
***************
*** 28,37 ****
  # Split the four disks in two parts: OS and spool space
  part raid.01 --size 2047 --ondisk sda
  part raid.02 --size 2047 --ondisk sdb
! part swap    --size 2047 --ondisk sdb
  
  # Create two mirrored pairs from this disk space
  raid /       --level 1 --device md0 raid.01 raid.02
  
  # Authentication mechanisms
  auth --enablemd5 --useshadow
--- 28,39 ----
  # Split the four disks in two parts: OS and spool space
  part raid.01 --size 2047 --ondisk sda
  part raid.02 --size 2047 --ondisk sdb
! part raid.03 --size 2047 --ondisk sda
! part raid.04 --size 2047 --ondisk sdb
  
  # Create two mirrored pairs from this disk space
  raid /       --level 1 --device md0 raid.01 raid.02
+ raid swap    --level 1 --device md2 raid.03 raid.04
  
  # Authentication mechanisms
  auth --enablemd5 --useshadow

anacdump.txt includes:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 364, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 243, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/autopart.py", line 899, in doAutoPartition
    (errors, warnings) = sanityCheckAllRequests(partitions, diskset, 1)
  File "/usr/lib/anaconda/partitioning.py", line 595, in sanityCheckAllRequests
    swapSize = swapSize + requestSize(request, diskset)
TypeError: number coercion failed

This looks consistent with some problem involving mirrored swap, which worked
just fine in Redhat 7.1.

Hope this helps. Let me know if you need any further information.



Comment 5 Brent Fox 2001-10-30 23:12:51 EST
I will try to duplicate this behavior when I get to work tomorrow.  Can you tell
me why you would want the RAID swap device to be md2 instead of md1?

You've got:
# Create two mirrored pairs from this disk space
raid /       --level 1 --device md0 raid.01 raid.02
raid swap    --level 1 --device md2 raid.03 raid.04

Why not:
# Create two mirrored pairs from this disk space
raid /       --level 1 --device md0 raid.01 raid.02
raid swap    --level 1 --device md1 raid.03 raid.04

instead?  Does that make any difference at all?
Comment 6 David Carter 2001-10-31 04:33:35 EST
> I will try to duplicate this behavior when I get to work tomorrow.

Thanks.

> Can you tell me why you would want the RAID swap device to be md2 instead
> of md1?

I just cut the original ks.cfg that I sent on Monday (which had four
seperate md devices) down to a minimal test case. I can confirm that
I see the same behaviour using md0 and md1. Also if I generate two
mirrored pairs using four partitions on a single disk.
Comment 7 Brent Fox 2001-11-01 20:11:33 EST
Ok, I've got a reproducible test case.  I'm investigating further.
Comment 8 Brent Fox 2001-11-02 01:06:34 EST
I've committed a fix for this in CVS.
Comment 9 Brent Fox 2001-11-05 12:12:36 EST
I have made an updates disk available at
ftp://people.redhat.com/bfox/7.2-raid-swap-update.img.

You need to dd this file to a floppy, then boot the 7.2 install with 'linux
updates ks=floppy'.  When prompted, insert the updates disk that you made.  This
works for me in my testing...does it work for you?
Comment 10 Brent Fox 2001-11-09 15:31:50 EST
*** Bug 55949 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2001-11-28 15:47:33 EST
*** Bug 56827 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2002-01-15 14:06:19 EST
*** Bug 58322 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2002-03-14 18:10:46 EST
*** Bug 57964 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.