Bug 574984 - openoffice.org hangs repeatedly (insert picture ?)
Summary: openoffice.org hangs repeatedly (insert picture ?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 610959 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 02:20 UTC by John Poelstra
Modified: 2010-08-04 09:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-04 09:15:25 UTC
Type: ---


Attachments (Terms of Use)
Views.xcu (17.22 KB, text/plain)
2010-03-28 15:32 UTC, John Poelstra
no flags Details
hang.stack (5.78 KB, text/plain)
2010-03-28 15:32 UTC, John Poelstra
no flags Details
log of failed yum transaction (29.11 KB, text/plain)
2010-06-16 15:46 UTC, John Poelstra
no flags Details
failed install log (41.88 KB, text/plain)
2010-06-16 15:59 UTC, John Poelstra
no flags Details

Description John Poelstra 2010-03-19 02:20:17 UTC
Description of problem:

I don't have a good way to recreate this problem, but consistently for the past two weeks on i386 and x86_64 openoffice writer hangs, usually when i have more than one document open at the same time or in conjunction with openoffice draw.

The only way I have found to recover to do do a kill -9 to the process :(


Version-Release number of selected component (if applicable):
$ rpm -qa | grep openoffice
openoffice.org-ure-3.1.1-19.26.fc12.i686
openoffice.org-calc-core-3.1.1-19.26.fc12.i686
openoffice.org-graphicfilter-3.1.1-19.26.fc12.i686
openoffice.org-opensymbol-fonts-3.1.1-19.26.fc12.noarch
openoffice.org-core-3.1.1-19.26.fc12.i686
openoffice.org-presenter-screen-3.1.1-19.26.fc12.i686
openoffice.org-writer-3.1.1-19.26.fc12.i686
openoffice.org-draw-core-3.1.1-19.26.fc12.i686
openoffice.org-draw-3.1.1-19.26.fc12.i686
openoffice.org-brand-3.1.1-19.26.fc12.i686
openoffice.org-impress-3.1.1-19.26.fc12.i686
openoffice.org-calc-3.1.1-19.26.fc12.i686
openoffice.org-pdfimport-3.1.1-19.26.fc12.i686
openoffice.org-impress-core-3.1.1-19.26.fc12.i686
openoffice.org-writer-core-3.1.1-19.26.fc12.i686


How reproducible:
open several writer documents and try to be productive.  This is not specific to a particular document. I

Comment 1 John Poelstra 2010-03-19 02:22:50 UTC
just found one way to make it hang on i386

1. open a new document
2. select insert/picture/from file
3. hangs

Comment 2 David Tardon 2010-03-19 07:38:44 UTC
Sorry, cannot reproduce. Could you repeat this, run

pstack $(/sbin/pidof swriter.bin) > /tmp/hang.stack

when it hangs and attach /tmp/hang.stack here? I'd like to see ~/.openoffice.org/3/user/registry/data/org/openoffice/Office/Views.xcu too.

Comment 3 David Tardon 2010-03-25 12:52:36 UTC
Feel free to reopen if you can supply us with the requested data.

Comment 4 John Poelstra 2010-03-28 13:16:34 UTC
I'm running the upstream 3.2 version because I couldn't get any work done.  It runs great.  

When I have time to uninstall it and revert to the Fedora crashing version to provide feedback I will.

Comment 5 John Poelstra 2010-03-28 15:31:13 UTC
Had time sooner than I thought.  

I do some work where I have write, calc, and draw all open at the same time.  The culprit seems to be having oodraw running at the same time.  To reproduce this time...

1) started two or three new writer documents
2) inserted jpg files to each of them
3) opened an existing oodraw file
4) started a new writer document
   --select insert picture from file
   --freezes before I get the dialog to insert a picture

See attached files you requested

$ rpm -qa | grep openoffice | sort 
openoffice.org-brand-3.1.1-19.28.fc12.x86_64
openoffice.org-calc-3.1.1-19.28.fc12.x86_64
openoffice.org-calc-core-3.1.1-19.28.fc12.x86_64
openoffice.org-core-3.1.1-19.28.fc12.x86_64
openoffice.org-draw-3.1.1-19.28.fc12.x86_64
openoffice.org-draw-core-3.1.1-19.28.fc12.x86_64
openoffice.org-graphicfilter-3.1.1-19.28.fc12.x86_64
openoffice.org-impress-3.1.1-19.28.fc12.x86_64
openoffice.org-impress-core-3.1.1-19.28.fc12.x86_64
openoffice.org-opensymbol-fonts-3.1.1-19.28.fc12.noarch
openoffice.org-pdfimport-3.1.1-19.28.fc12.x86_64
openoffice.org-presenter-screen-3.1.1-19.28.fc12.x86_64
openoffice.org-ure-3.1.1-19.28.fc12.x86_64
openoffice.org-writer-3.1.1-19.28.fc12.x86_64
openoffice.org-writer-core-3.1.1-19.28.fc12.x86_64

I'm moving back to upstream 3.2 so I can GTD so it may take time to repro any other things you need.

Comment 6 John Poelstra 2010-03-28 15:32:00 UTC
Created attachment 403107 [details]
Views.xcu

Comment 7 John Poelstra 2010-03-28 15:32:29 UTC
Created attachment 403108 [details]
hang.stack

Comment 8 Caolan McNamara 2010-04-01 11:26:08 UTC
Launched writer, Launched another writer, inserted png in each, opened draw document launched another writer, inserted png in it. No problem.

More than likely the problem is with the gtk file dialog.

Re "Upstream 3.2 version ... runs great." -> "revert to the Fedora crashing version". The default file dialog for vanilla is not the gtk file dialog. So...

a) I can't reproduce it, if there is a single reproducible way to get this to happen that'd be great. From where are the pictures being inserted ? A normal filesystem dir, or anything exotic. Is preview picture toggled on or off ?

b) As an experiment if you can try toggling on tools->openoffice.org->general->open/save dialogs "Use OpenOffice.org dialogs" and see if that makes it "go away".

Comment 9 Caolan McNamara 2010-04-08 10:14:09 UTC
There was the F-11 libX11 bug 477174 which also affected acroread, I don't think that's indicated here, so...

a) If there is a single reproducible way to get this to
happen that'd be great. From where are the pictures being inserted ? A normal
filesystem dir, or anything exotic. Is preview picture toggled on or off ?

b) As an experiment if you can try toggling on
tools->openoffice.org->general->open/save dialogs "Use OpenOffice.org dialogs"
and see if that makes it "go away".

Comment 10 Bill Peck 2010-04-21 19:17:44 UTC
If I do option b from previous comment it fixes it.

b) As an experiment if you can try toggling on
tools->openoffice.org->general->open/save dialogs "Use OpenOffice.org dialogs"
and see if that makes it "go away"

I'm running F12 with gnome shell.

Comment 11 Bill Peck 2010-04-21 20:54:15 UTC
This happens for me when just running open office Impress.  It affects all file dialogs.

Comment 12 Caolan McNamara 2010-04-27 15:21:23 UTC
An attempt with gnome-shell works fine for me too. So still baffled as to this one.

Comment 13 Caolan McNamara 2010-05-30 07:57:28 UTC
Dunno about this one. Its just too suspicious to see this only reported by two @redhat people and no one else. If there's something wrong with the integration of the gtk main loop and OOo one there'd surely be a storm of reports.

Comment 14 Caolan McNamara 2010-06-14 14:19:16 UTC
There is a possibility that bug #603043 (which I also can't reproduce, but whose fix reportedly works) is the same root problem as this. Lets give that a shot, if so then this will be good in >= 3.1.1-19.33

Comment 15 Fedora Update System 2010-06-15 07:48:20 UTC
openoffice.org-3.1.1-19.33.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.33.fc12

Comment 16 Fedora Update System 2010-06-15 16:01:57 UTC
openoffice.org-3.1.1-19.33.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.33.fc12

Comment 17 Caolan McNamara 2010-06-16 14:10:35 UTC
Seeing as I can't reproduce this one myself, it would be great if someone who was able to see it before could check to see if this update would make any difference to the problem.

Comment 18 John Poelstra 2010-06-16 15:45:42 UTC
Can't install the new packages because of deps breakage.  See attached log

Comment 19 John Poelstra 2010-06-16 15:46:37 UTC
Created attachment 424508 [details]
log of failed yum transaction

Comment 20 John Poelstra 2010-06-16 15:48:09 UTC
Give me a couple of minutes to post the correct error log

Comment 21 Caolan McNamara 2010-06-16 15:54:25 UTC
My prediction from "I'm running the upstream 3.2 version..." is that you have conflicting rpms from different repositories and a yum erase openoffice.org-ure to remove the vanilla OOo before installing the fedora one is called for

Comment 22 John Poelstra 2010-06-16 15:59:42 UTC
Created attachment 424511 [details]
failed install log

Comment 23 John Poelstra 2010-06-16 16:00:52 UTC
(In reply to comment #21)
> My prediction from "I'm running the upstream 3.2 version..." is that you have
> conflicting rpms from different repositories and a yum erase openoffice.org-ure
> to remove the vanilla OOo before installing the fedora one is called for    

I did.

[root@xps ~]# rpm -qa | grep -i office
kacst-office-fonts-2.0-5.fc12.noarch
koffice-kivio-1.6.3-26.20090306svn.fc12.x86_64
koffice-core-1.6.3-26.20090306svn.fc12.x86_64
koffice-libs-1.6.3-26.20090306svn.fc12.x86_64

Comment 24 Caolan McNamara 2010-06-16 16:10:24 UTC
openoffice.org-ure is nevertheless missing from the transaction, try adding it manually to the yum line.

Comment 25 John Poelstra 2010-06-16 16:43:28 UTC
(In reply to comment #24)
> openoffice.org-ure is nevertheless missing from the transaction, try adding it
> manually to the yum line.    

That doesn't help.  Same error message.  Shouldn't yum know to include it as a dependency if it is?

Comment 26 Bill Peck 2010-06-16 16:58:47 UTC
Installs for me..  and it seems to fix the bug for me as well.

Comment 27 Caolan McNamara 2010-06-16 19:13:53 UTC
caolanm->bpeck: Great thanks

caolanm->poelstra: It should have. I wonder if you have a exclude=openoffice.org-ure in your yum.conf or something of that nature ?

Comment 28 John Poelstra 2010-06-16 22:10:39 UTC
(In reply to comment #27)
> caolanm->bpeck: Great thanks
> 
> caolanm->poelstra: It should have. I wonder if you have a
> exclude=openoffice.org-ure in your yum.conf or something of that nature ?    

My apologies for the confusion.  That was the problem :(

I can't reproduce the problem w/ the new version :)

Comment 29 Fedora Update System 2010-07-05 07:52:58 UTC
openoffice.org-3.1.1-19.34.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.34.fc12

Comment 30 Fedora Update System 2010-07-06 17:26:27 UTC
openoffice.org-3.1.1-19.34.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.34.fc12

Comment 31 Caolan McNamara 2010-07-07 19:19:27 UTC
*** Bug 610959 has been marked as a duplicate of this bug. ***

Comment 32 Caolan McNamara 2010-08-04 09:15:25 UTC
This update has been pushed to stable


Note You need to log in before you can comment on or make changes to this bug.