Bug 574985 - gpg signing messages always spawns pinentry-gtk
Summary: gpg signing messages always spawns pinentry-gtk
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-keyring
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 609341 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 02:25 UTC by Jesse Keating
Modified: 2015-03-03 22:45 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-03-21 17:15:18 UTC


Attachments (Terms of Use)

Description Jesse Keating 2010-03-19 02:25:18 UTC
This used to make use of gnome-keyring/seahorse, only now I get pinentry-gtk every single time, and there is no option to cache the passphrase for a period of time.  This is a regression from F-12

Comment 1 Matthew Barnes 2010-03-19 03:13:24 UTC
I'm fairly certain this isn't an Evolution issue, as we simply call "gpg".  Not really sure how passphrase requests are intercepted by seahorse/pinentry-gtk, but we don't call it explicitly.

Comment 2 Jesse Keating 2010-03-19 03:50:01 UTC
Fair enough, I'm not sure if I should pass this along to seahorse or gnome-keyring.  Throwing it at gnome-keyring for now I guess.

Comment 3 Matthias Clasen 2010-03-19 22:57:54 UTC
I just tried this here, and I get the seahorse-agent dialog.

First questions here:

- Do you have seahorse-plugins installed (where seahorse-agent lives)

- Is it running in your session ?

- what does env | grep GPG say ?

Comment 4 Jesse Keating 2010-03-19 23:26:36 UTC
Ah, I did not have -plugins installed.  Did that recently get split out or something?

I'll check the rest after I restart my session with -plugins installed.

Comment 5 Jesse Keating 2010-03-21 17:15:18 UTC
After installing seahorse-plugins I now get seahorse instead of pinentry-gtk.  Since this is an upgrade from F11 days, maybe there was a package split that I didn't notice.  Closing anyway.

Comment 6 Matthew Barnes 2010-06-02 13:18:47 UTC
*** Bug 595158 has been marked as a duplicate of this bug. ***

Comment 7 markm 2010-06-02 13:31:58 UTC
the above solution didn't work for me.

although I have seahorse-plugins installed and seahorse-agent is running, i still get pinentry-gtk-2 popup question and the passphrase is not remembered.

I must admit it worked for me once, but it stopped now.

Comment 8 Milan Crha 2010-06-03 08:15:16 UTC
you can also try to disable "use-agent" in your ~/.gnupg/gpg.conf , which will change behaviour in a way that you'll be asked with Evolution's password dialog, with a checkbox to remember password for the session, but that's probably not the thing you need, as the use-agent is a system wide setting, which has nothing to do with Evolution itself (even we can disable agent use when invoking gpg on the background, but it isn't there in 2.30.x)

Comment 9 markm 2010-06-03 13:17:10 UTC
I have disabled use-agent, though I still get either “pinentry-gtk-2” or seahorse window without an option to remember my passphrase in the session.

and yes, I only sign my emails sent from Evolution. Not sure why and who did those changes, but I consider those changes as a huge usability issue. I cannot make it work - if I select to remember my passphrase, it remembers it forever, if I opt for not remembering it, I have to enter a passphrase every time. If I select “show icon in a notification bar” and then I click that icon, I get “pinentry-gtk-2” again.

Those changes are broken by design!

Comment 10 Matthew Barnes 2010-06-30 02:50:12 UTC
*** Bug 609341 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.