This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 575121 - Going back to repo UI screen and and modifying Installation Repo causes traceback
Going back to repo UI screen and and modifying Installation Repo causes trace...
Status: CLOSED DUPLICATE of bug 505189
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Beta/F13BetaBlocker
  Show dependency treegraph
 
Reported: 2010-03-19 10:31 EDT by James Laska
Modified: 2013-09-02 02:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 574777
Environment:
Last Closed: 2010-03-19 10:48:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-03-19 10:31:33 EDT
= Steps to reproduce =
1. Boot from disc1 ISO
2. Proceed with a default install
3. At reposet, click Next
4. A dialog appears noting that discs#1 and #2 will be needed, press Back
5. Select the 'Installation source' repository
6. Select 'Modify repository', make no changes, then press OK
7. Select Next, to proceed with install

= Additional information =
 * NOTE, if I do not fiddle with the CD/DVD repository in steps 5-6, the CDROM
install completes successfully

--- Additional comment from rvykydal@redhat.com on 2010-03-03 11:14:53 EST ---

James, thanks for reproducer, This updates image (against f13 alpha rc4 which is anaconda 13.32) 
http://rvykydal.fedorapeople.org/updates.tsinfo.img
fixes the issue for me.

I noticed that steps 5. and 6. (no matter if they were preceded by 3. and 4.) make installation process significantly resource-hungrier - in my 512 MB VM I can install about 800 packages and then install fails with "install exited abnormally [1/1]" - this is another bug independent of this one, however.

--- Additional comment from rvykydal@redhat.com on 2010-03-09 05:43:18 EST ---

This will be fixed by commit f8c1f662b5195805d5fbde60c6593909cd8f4395 in next build of anaconda from master branch, which should be anaconda-14.0-1 I think.

--- Additional comment from rvykydal@redhat.com on 2010-03-16 06:38:47 EDT ---

(In reply to comment #15)
 
> I noticed that steps 5. and 6. (no matter if they were preceded by 3. and 4.)
> make installation process significantly resource-hungrier - in my 512 MB VM I
> can install about 800 packages and then install fails with "install exited
> abnormally [1/1]" - this is another bug independent of this one, however.    

For reference, this issue should be fixed by patch
https://www.redhat.com/archives/anaconda-devel-list/2010-March/msg00217.html
sent for review.

--- Additional comment from jlaska@redhat.com on 2010-03-18 10:04:34 EDT ---

I've hit this several times while testing Fedora 13 Alpha and Beta TC0 (see bug#568396).  While there is no specific release criteria to address this, I think this falls into an except testers will encounter during CD-ROM installations.

Adding blocks:F13Beta to request pulling this change into F13Beta.  The use case affected is anytime you go "Back" to the reposetup step, and modify the Installation repository, this failure will occur.

This seems fairly specific and a safe fix to pull into F-13.

--- Additional comment from rvykydal@redhat.com on 2010-03-18 10:32:01 EDT ---


(In reply to comment #0)

to pick important info:
  
> 
> = Steps to reproduce =
> 1. Boot from disc1 ISO
> 2. Proceed with a default install
> 3. At reposet, click Next
> 4. A dialog appears noting that discs#1 and #2 will be needed, press Back
> 5. Select the 'Installation source' repository
> 6. Select 'Modify repository', make no changes, then press OK
> 7. Select Next, to proceed with install
 

> Adding blocks:F13Beta to request pulling this change into F13Beta.  The use
> case affected is anytime you go "Back" to the reposetup step, and modify the
> Installation repository, this failure will occur.

fixed in master with:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=f8c1f662b5195805d5fbde60c6593909cd8f4395

--- Additional comment from pm-rhel@redhat.com on 2010-03-18 10:58:21 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 1 James Laska 2010-03-19 10:48:37 EDT
Sorry, this is already being tracked in Fedora as bug#505189

*** This bug has been marked as a duplicate of bug 505189 ***

Note You need to log in before you can comment on or make changes to this bug.